Bug 103681 - Complete graphic hang when playing specific game
Summary: Complete graphic hang when playing specific game
Status: RESOLVED DUPLICATE of bug 102962
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-11 00:39 UTC by vdragon
Modified: 2017-11-27 12:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg log when encountering issue (282.49 KB, text/x-log)
2017-11-11 00:39 UTC, vdragon
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description vdragon 2017-11-11 00:39:50 UTC
Created attachment 135389 [details]
dmesg log when encountering issue

When running the game 'Overwatch' through wine, I am encountering a complete graphic freeze (the system appear to run correctly in the background, but the display is completely frozen on all screens), after which if i try to shutdown the system, it appears to become unresponsive (at least to ssh access) and I manually shut it down via a long press of the power button. All the time the graphics are frozen, all the 'tachyometer' leds on the gpu are on.

System setup is:
GPU: rx Vega 64
System: Archlinux
Kernel: amd-staging 4.13.0 at commit e16e1739c334c1e3a180402c7e30391f6de8ddf2 locally compiled via archlinux aur tools
Mesa : git version d48492074a51045e443d8cab2baf944d7349b7ba locally compiled with the following options passed to autogen.sh:
               --prefix=/usr \
               --sysconfdir=/etc \
               --with-dri-driverdir=/usr/lib/xorg/modules/dri \
               --with-gallium-drivers=i915,r300,r600,radeonsi,nouveau,svga,swrast,virgl \
               --with-dri-drivers=i915,i965,r200,radeon,nouveau,swrast \
               --with-platforms=x11,drm,wayland \
               --with-vulkan-drivers=intel,radeon \
               --enable-texture-float \
               --enable-gallium-osmesa \
               --enable-xa \
               --enable-nine \
               --disable-xvmc \
               --enable-vdpau \
               --enable-omx-bellagio \
               --enable-opencl \
               --enable-opencl-icd \
               --enable-glx-tls \
               --enable-libglvnd
               (copied from mesa-git aur package)
               
Attached is the system log after waiting some time then sending the shutdown command.
Comment 1 vdragon 2017-11-11 01:23:58 UTC
How to reproduce:
Any kind of real gameplay will cause the crash.
One way i found to do it quickly is to go to training mode, switch to pharah quickly (may already be crashed at that point), and then shoot the first training robot in range.
Comment 2 sander.smid 2017-11-27 12:33:16 UTC

*** This bug has been marked as a duplicate of bug 102962 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.