Bug 102962 - GPU crash running Overwatch in wine-staging
Summary: GPU crash running Overwatch in wine-staging
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 17.2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
: 103681 104475 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-24 15:05 UTC by Tobias Auerochs
Modified: 2019-09-25 18:00 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
broken colors with mesa override (2.10 MB, image/png)
2018-03-31 17:36 UTC, Thomas Crider
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Auerochs 2017-09-24 15:05:55 UTC
Running Overwatch in wine-staging 2.17 or 2.16 causes frequent GPU crashes, in particular almost always when selecting Symmetra in the Hero Selection screen. As far as I can tell there is no version of wine-staging (including specific commits) that avoid this issue.

Interestingly, a patched version of wine-staging 2.16 and earlier (https://github.com/gamax92/wine-overwatch) does not seem to trigger this at all. (I suspect their removal of some wined3d related patches started to trigger this, whilst the earlier version avoided it.)

No errors are shown on both wine's and mesa's end, although I have not successfully tried a build with -DDEBUG CFLAG, which I could try in case this is helpful.

I have tried working out which of the patches applied by the repository are avoiding the issue, but haven't work out any good leads.

Running on Arch Linux with linux 4.13.3 (Custom compiled with unrelated patches) and mesa 17.2.1. The issue can be reproduced both with the standard wine-staging package on Arch as well as compiling the mentioned patched version.

It might be worthwile to contact the wine developers about this, but their bug reporting guidelines specifically say to not report driver issues there, so I decided to report here first.
Comment 1 Józef Kucia 2017-09-24 22:11:02 UTC
This is likely a Wine/wine-staging bug and shouldn't be reported to Mesa. Why do you think it is a driver bug?
Comment 2 Tobias Auerochs 2017-09-24 22:51:06 UTC
As I mentioned, it causes a GPU crash, meaning the entire graphics session freezes, other than mouse cursor, I'm not referring to wine simply crashing.

I'm not familiar with advanced OpenGL (specifically what wine requires to implement d3d11) and if that would ever be allowed to cause a GPU crash at all to begin with.

Also, to my knowledge (although I cannot test this myself currently), this does not seem to happen on other drivers.

This either runs down to the sequence of OpenGL commands issued by wine tripping mesa or wine not implementing d3d11 well enough and emitting invalid OpenGL commands (which just happen to cause a GPU crash instead of a gl error or process crash) to the best of my knowledge.

If you think this is better reported to wine directly, I can close this and open a report there. (Sorry for the inconvenience then)
Comment 3 Matt 2017-10-21 04:40:22 UTC
This bug has been going on for me since wine-staging 2.17 and continues in 2.19 released today.

Some particulars of my setup.

Fiji (Fury) card
running patched kernel 4.12 with Display Core patches
mesa-git - 17.3.0-0.105.git4f42ea4


I'm not sure what we would need to dissect this issue to determine once and for all if it is purely wine's fault or if it is indeed mesa at fault. When it happens the entire graphics system crashes and is unresponsive.
Comment 4 sander.smid 2017-11-26 17:20:36 UTC
I created a ticket on Wine for the same issue which contains a full log of the wine session.


Relevant Wine Bug Ticket
------------------------
https://bugs.winehq.org/show_bug.cgi?id=44077


System info
-----------
* wine-2.21 (Staging)
* Linux oribi 4.13.12-1-ARCH #1 SMP PREEMPT Wed Nov 8 11:54:06 CET 2017 x86_64 GNU/Linux
* Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/580]
* Display Server: x11 (X.Org 1.19.5 ) drivers: nvidia (unloaded: modesetting,fbdev,nv,vesa,nouveau)
* Resolution: 1920x1200@59.95hz
* OpenGL: renderer: AMD Radeon RX 480 Graphics (AMD POLARIS10 / DRM 3.18.0 / 4.13.12-1-ARCH, LLVM 5.0.0)
* version: 4.5 Mesa 17.2.5
Comment 5 sander.smid 2017-11-27 12:33:16 UTC
*** Bug 103681 has been marked as a duplicate of this bug. ***
Comment 6 sander.smid 2017-11-27 12:35:26 UTC
The Wine devs just closed the issue on their bugtracker as NOTOURBUG.
Comment 7 sander.smid 2017-12-06 21:49:59 UTC
I can look into providing additional information for this issue. However I'm not familiar with the process of debugging or log gathering for GPU crashes. Any information on the subject is welcome.
Comment 8 Józef Kucia 2017-12-06 22:17:43 UTC
(In reply to Tobias Auerochs from comment #2)
> As I mentioned, it causes a GPU crash, meaning the entire graphics session
> freezes, other than mouse cursor, I'm not referring to wine simply crashing.
> 
> I'm not familiar with advanced OpenGL (specifically what wine requires to
> implement d3d11) and if that would ever be allowed to cause a GPU crash at
> all to begin with.

OpenGL applications can cause GPU hangs quite easily.
Comment 9 Thomas Crider 2018-03-31 17:36:35 UTC
Created attachment 138466 [details]
broken colors with mesa override

This was originally able to be resolved using MESA_GL_VERSION_OVERRIDE=4.0COMPAT, however commit 72de747c6a6cdd0be84a24932a4452f453861dbe broke that functionality, so that MESA-GL_VERSION_OVERRIDE no longer renders properly, at least on my system. See attached.
Comment 10 amd_user 2018-06-22 17:20:19 UTC
Why does the system freeze when selecting Symmetra in the Hero Selection screen? Is it a mesa bug or wine bug?

linux 4.17.2
amd ryzen 3
mesa 18.1.2
wine-staging 3.10
Comment 11 Timothy Arceri 2018-07-18 07:18:01 UTC
(In reply to gloriouseggroll from comment #9)
> Created attachment 138466 [details]
> broken colors with mesa override
> 
> This was originally able to be resolved using
> MESA_GL_VERSION_OVERRIDE=4.0COMPAT, however commit
> 72de747c6a6cdd0be84a24932a4452f453861dbe broke that functionality, so that
> MESA-GL_VERSION_OVERRIDE no longer renders properly, at least on my system.
> See attached.

radeonsi now has compat 4.4 enabled by default (in git and upcoming 18.2 release). Does the game now work for you with a recent Mesa from git?
Comment 12 Tobias Auerochs 2018-07-18 18:02:21 UTC
(In reply to Timothy Arceri from comment #11)
> (In reply to gloriouseggroll from comment #9)
> > Created attachment 138466 [details]
> > broken colors with mesa override
> > 
> > This was originally able to be resolved using
> > MESA_GL_VERSION_OVERRIDE=4.0COMPAT, however commit
> > 72de747c6a6cdd0be84a24932a4452f453861dbe broke that functionality, so that
> > MESA-GL_VERSION_OVERRIDE no longer renders properly, at least on my system.
> > See attached.
> 
> radeonsi now has compat 4.4 enabled by default (in git and upcoming 18.2
> release). Does the game now work for you with a recent Mesa from git?

Tried launching the game with mesa-git 103535.88e56804a7 (unofficial Arch repo), rendering in menus (including backgrounds) worked correctly, however the system still hangs the same way as before (e.g. when selecting Symmetra).

Trying MESA_GL_VERSION_OVERRIDE=4.0COMPAT on mesa-git appears to have no effect at all anymore, or any other version for that matter. (With the override it does not freeze on mesa 18.1.4, but graphics glitches occur with it, without the override it renders correctly and freezes as well, just like mesa-git does)
Comment 13 Timothy Arceri 2018-09-08 10:03:33 UTC
(In reply to Tobias Auerochs from comment #12)
> (In reply to Timothy Arceri from comment #11)
> > (In reply to gloriouseggroll from comment #9)
> > > Created attachment 138466 [details]
> > > broken colors with mesa override
> > > 
> > > This was originally able to be resolved using
> > > MESA_GL_VERSION_OVERRIDE=4.0COMPAT, however commit
> > > 72de747c6a6cdd0be84a24932a4452f453861dbe broke that functionality, so that
> > > MESA-GL_VERSION_OVERRIDE no longer renders properly, at least on my system.
> > > See attached.
> > 
> > radeonsi now has compat 4.4 enabled by default (in git and upcoming 18.2
> > release). Does the game now work for you with a recent Mesa from git?
> 
> Tried launching the game with mesa-git 103535.88e56804a7 (unofficial Arch
> repo), rendering in menus (including backgrounds) worked correctly, however
> the system still hangs the same way as before (e.g. when selecting Symmetra).

Picked the game up as part of Humble bundle, I seem to be able to select Symmetra without any freeze. Is this still happening for you?
Comment 14 Timothy Arceri 2018-09-09 22:58:59 UTC
*** Bug 104475 has been marked as a duplicate of this bug. ***
Comment 15 Tobias Auerochs 2018-09-10 03:36:19 UTC
(In reply to Timothy Arceri from comment #13)
> (In reply to Tobias Auerochs from comment #12)
> > (In reply to Timothy Arceri from comment #11)
> > > (In reply to gloriouseggroll from comment #9)
> > > > Created attachment 138466 [details]
> > > > broken colors with mesa override
> > > > 
> > > > This was originally able to be resolved using
> > > > MESA_GL_VERSION_OVERRIDE=4.0COMPAT, however commit
> > > > 72de747c6a6cdd0be84a24932a4452f453861dbe broke that functionality, so that
> > > > MESA-GL_VERSION_OVERRIDE no longer renders properly, at least on my system.
> > > > See attached.
> > > 
> > > radeonsi now has compat 4.4 enabled by default (in git and upcoming 18.2
> > > release). Does the game now work for you with a recent Mesa from git?
> > 
> > Tried launching the game with mesa-git 103535.88e56804a7 (unofficial Arch
> > repo), rendering in menus (including backgrounds) worked correctly, however
> > the system still hangs the same way as before (e.g. when selecting Symmetra).
> 
> Picked the game up as part of Humble bundle, I seem to be able to select
> Symmetra without any freeze. Is this still happening for you?

Tested using mesa 18.2.0 (Arch testing repository) without any mesa overrides and still froze (on second attempt selection worked, but right click shot still froze).
Specifically I was also using wine-staging 3.15, llvm 6.0.1 and a customized linux 4.18.3 kernel, maybe newer llvm yields better results (have not gotten around to testing that).

Interestingly I am able to run the game perfectly stable when dxvk is installed (and radv), aside from the expected poor-ish performance.
Comment 16 Simon 2018-09-19 22:08:51 UTC
I have the same issue - I am running ArchLabs with arch repos, recent drivers, lutris installer of Overwatch. When firing D.Vas rockets or certain other sparkly effects, the gpu hangs. This is dmesg of when it happens:
https://pastebin.com/VBtc5nxE

My specs are

CPU: A8 2.3ghz quadcore

RAM: 8GB

Video: Radeon R5 M240 with 1gb "dedicated VRAM" AKA southern island "Mullins" GCN1.0

I am currently using the radeon driver, which works fine (actually very well - I have vdpau and most other relevant packages installed, and glxinfo tells me I have OpenGL core profile 4.5 working). I cant get amdgpu or vulkan to work sadly, so this issue makes overwatch unplayable. I use the stock ARCH kernel 4.18
Comment 17 GitLab Migration User 2019-09-25 18:00:32 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1284.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.