Bug 103725 - [skl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg with Plasma compositor enable
Summary: [skl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg with Plasma compositor enable
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-13 21:36 UTC by Grzegorz Kowzan
Modified: 2019-09-25 19:05 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (41.82 KB, text/plain)
2017-11-13 21:36 UTC, Grzegorz Kowzan
Details
dmesg with drm.debug=0x1e (1009.34 KB, text/x-log)
2017-11-15 16:16 UTC, Grzegorz Kowzan
Details
/sys/class/drm/card0/error 2 (41.94 KB, text/plain)
2017-11-15 16:17 UTC, Grzegorz Kowzan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz Kowzan 2017-11-13 21:36:17 UTC
Created attachment 135441 [details]
/sys/class/drm/card0/error

A 30 s hang and then a crash of X server occurred while running KDE Plasma 5 with enabled compositor on an up-to-date Ubuntu 7.10.  Running apps: Firefox, Thunderbird, Emacs, Okular, Zotero, LibreOffice Writer, Yakuake.  System information:
- dell latitude 5480,
- no external monitors,
- kernel version - 4.13.0-16-generic.

The pertinent part of journalctl -b output is reproduced below:

lis 13 15:57:05 oto kernel: [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [924], reason: Hang on rcs0, action: reset
lis 13 15:57:05 oto kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
lis 13 15:57:05 oto kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
lis 13 15:57:05 oto kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
lis 13 15:57:05 oto kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
lis 13 15:57:05 oto kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
lis 13 15:57:05 oto kernel: drm/i915: Resetting chip after gpu hang
lis 13 15:57:05 oto kernel: [drm] RC6 on
lis 13 15:57:13 oto kernel: drm/i915: Resetting chip after gpu hang
lis 13 15:57:13 oto kernel: [drm] RC6 on
lis 13 15:57:16 oto kernel: asynchronous wait on fence i915:kwin_x11[1362]/1:deeb timed out
lis 13 15:57:21 oto kernel: drm/i915: Resetting chip after gpu hang
lis 13 15:57:21 oto kernel: [drm] RC6 on
lis 13 15:57:29 oto kernel: drm/i915: Resetting chip after gpu hang
lis 13 15:57:29 oto kernel: [drm] RC6 on
lis 13 15:57:37 oto kernel: drm/i915: Resetting chip after gpu hang
lis 13 15:57:37 oto kernel: [drm] RC6 on
lis 13 15:57:37 oto org.kde.kuiserver[1163]: The X11 connection broke (error 1). Did the X11 server die?
lis 13 15:57:37 oto org.kde.KScreen[1163]: The X11 connection broke (error 1). Did the X11 server die?
lis 13 15:57:37 oto org.kde.kglobalaccel[1163]: The X11 connection broke (error 1). Did the X11 server die?
Comment 1 Grzegorz Kowzan 2017-11-15 16:16:36 UTC
Created attachment 135492 [details]
dmesg with drm.debug=0x1e
Comment 2 Grzegorz Kowzan 2017-11-15 16:17:40 UTC
Created attachment 135493 [details]
/sys/class/drm/card0/error 2
Comment 3 Grzegorz Kowzan 2017-11-15 16:21:01 UTC
The bug occurred again. I added the drm.debug=0x1e flag to kernel per recommendations in the meantime. The output of dmesg and the new crash dump is attached to the bug.
Comment 4 Elizabeth 2017-12-04 23:37:48 UTC
Hello Kowzan, could you share your Mesa version? Is there any specific steps to reproduce besides open all the applications listed on comment #1 ??
Comment 5 Grzegorz Kowzan 2017-12-05 08:02:53 UTC
My Mesa version is 17.2.2-0ubuntu1.  There aren't any specific steps that I could discern leading to the hang up.  The hang ups do not occur when the Plasma compositor is disabled.
Comment 6 Elizabeth 2017-12-07 23:42:23 UTC
(In reply to Grzegorz Kowzan from comment #5)
> My Mesa version is 17.2.2-0ubuntu1.  There aren't any specific steps that I
> could discern leading to the hang up.  The hang ups do not occur when the
> Plasma compositor is disabled.
How can I disable/enable compositor? Will try to replicate on a SKL, meanwhile you should try new mesa 17.3 one of the improvements may help.
Comment 7 Grzegorz Kowzan 2017-12-08 08:52:03 UTC
(In reply to Elizabeth from comment #6)
> (In reply to Grzegorz Kowzan from comment #5)
> > My Mesa version is 17.2.2-0ubuntu1.  There aren't any specific steps that I
> > could discern leading to the hang up.  The hang ups do not occur when the
> > Plasma compositor is disabled.
> How can I disable/enable compositor? Will try to replicate on a SKL,
> meanwhile you should try new mesa 17.3 one of the improvements may help.

After you run plasmasettings it's under Hardware->Display and Monitor->Compositor->Enable compositor on startup.

Ok, I''ll try the new Mesa and report back.
Comment 8 Grzegorz Kowzan 2017-12-09 13:01:24 UTC
(In reply to Grzegorz Kowzan from comment #7)
> (In reply to Elizabeth from comment #6)
> > (In reply to Grzegorz Kowzan from comment #5)
> > > My Mesa version is 17.2.2-0ubuntu1.  There aren't any specific steps that I
> > > could discern leading to the hang up.  The hang ups do not occur when the
> > > Plasma compositor is disabled.
> > How can I disable/enable compositor? Will try to replicate on a SKL,
> > meanwhile you should try new mesa 17.3 one of the improvements may help.
> 
> After you run plasmasettings it's under Hardware->Display and
> Monitor->Compositor->Enable compositor on startup.
> 
> Ok, I''ll try the new Mesa and report back.

I have some new information.  I was mistaken about the compositor being at fault. With the compositor disabled the crash occurred just after starting LibreOffice Writer (5.4.2-0ubuntu0.17.10.1).  I don't use it often so disabling of compositor simply coincided with me refraining from using LibreOffice for a while.
Comment 9 cribari 2017-12-09 16:48:49 UTC
It could be related to this bug: https://bugs.freedesktop.org/show_bug.cgi?id=103934
Comment 10 Hector Velazquez 2017-12-12 15:53:34 UTC
Hi, I tried to replicate this issue and couldn't reproduce it with the following conditions...

kernel version             : 4.13.0-19-generic x86_64
os version                 : Ubuntu 17.10 artful
kernel driver              : i915
hardware acceleration      : disabled
Xorg                       : X Server 1.19.5
mesa version               : OpenGL ES 3.2 Mesa 17.2.2
libdrm                     : 2.4.83
libva                      : 1.8.3-2
vaapi (intel-driver)       : 1.8.3
platform                   : Skylake
motherboard model          : Inspiron15-7568
cpu information            : Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
gpu card                   : Intel Corporation HD Graphics 520 (rev 07) (prog-if 00 [VGA controller])
memory ram                 : 8 GB
displays connected         : eDP-1
Comment 11 Elizabeth 2018-01-05 21:00:23 UTC
If you got some time could you try https://cgit.freedesktop.org/mesa/mesa/?
Comment 12 Elizabeth 2018-03-06 20:40:56 UTC
This should be fixed on mesa 17.3.6, someone could test it? Thank you.
Comment 13 Denis 2018-04-28 09:45:53 UTC
hello. I also tried to reproduce this issue with this config:

plasmashell 5.12.4
ubuntu 16.04 Bionic Beaver
kernel 4.13.0-041300-generic
Mesa 18.0.0-rc4
SKL (520GT)

I didn't reproduce the issue during opening a lot of windows and apps (mentioned on the original topic) and switching between them.

Grzegorz - how fast you face this issue usually?
Comment 14 GitLab Migration User 2019-09-25 19:05:41 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1651.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.