Bug 103934 - [skl] GPU HANG in XorgPU HANG: ecode 9:0:0x86dffffd, in Xorg [500], libreoffice
Summary: [skl] GPU HANG in XorgPU HANG: ecode 9:0:0x86dffffd, in Xorg [500], libreoffice
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: cribari
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-27 10:42 UTC by cribari
Modified: 2017-12-18 21:21 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
gpu crash dump (29.23 KB, application/gzip)
2017-11-27 10:42 UTC, cribari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cribari 2017-11-27 10:42:11 UTC
Created attachment 135734 [details]
gpu crash dump

I run Manjaro Linux, KDE Plasma and kernel 4.14.2. I experienced a GPU crash today. The dmesg dump is available at 

https://pastebin.com/kw5VzstG

The output of xrandr --verbose is available 

https://pastebin.com/pMQczUZk

I am attaching the GPU crash dump. 

Hardware: 

[cribari@darwin5 ~]$ inxi -Fxzc0
System:    Host: darwin5 Kernel: 4.14.2-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
           Desktop: KDE Plasma 5.11.3 (Qt 5.9.2) Distro: Manjaro Linux
Machine:   Device: laptop System: SAMSUNG product: 900X3L v: P05AFN serial: N/A
           Mobo: SAMSUNG model: NP900X3L-KW1BR v: SGL8776A06-C01-G001-S0001+10.0.10586 serial: N/A
           UEFI [Legacy]: American Megatrends v: P05AFN.035.160331.PS date: 03/31/2016
Battery    BAT1: charge: 29.6 Wh 100.0% condition: 29.6/30.0 Wh (99%)
           model: SAMSUNG SR Real status: Full
CPU:       Dual core Intel Core i7-6500U (-HT-MCP-)
           arch: Skylake rev.3 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10372
           clock speeds: max: 3100 MHz 1: 2600 MHz 2: 2600 MHz 3: 2600 MHz
           4: 2600 MHz
Graphics:  Card: Intel HD Graphics 520 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.5 ) driver: modesetting
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           version: 4.5 Mesa 17.2.5 Direct Render: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.14.2-1-MANJARO
Network:   Card-1: Intel Wireless 8260 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 256.1GB (24.1% used)
           ID-1: /dev/sda model: LITEON_CV1 size: 256.1GB
Partition: ID-1: / size: 108G used: 50G (49%) fs: ext4 dev: /dev/sda3
           ID-2: swap-1 size: 9.44GB used: 0.03GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 42.0C mobo: 42.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 216 Uptime: 1 day Memory: 2916.3/7899.8MB
           Init: systemd Gcc sys: 7.2.0 Client: Shell (bash 4.4.121) inxi: 2.3.43
Comment 1 Elizabeth 2017-11-30 23:37:02 UTC
Hello Cribari, is this easily reproducible? If so, what steps need to be executed? Is this reproducible with a different desktop?? Using SNA makes any difference?

Last action executed before ring hang:

0xfffb2c60:      0x79000002: 3DSTATE_DRAWING_RECTANGLE
0xfffb2c64:      0x00000000:    top left: 0,0
0xfffb2c68:      0x03d1057b:    bottom right: 1403,977
0xfffb2c6c:      0x00000000:    origin: 0,0
 
Thanks for your time.
Comment 2 cribari 2017-11-30 23:46:40 UTC
Hello Elizabeth: It happens once in a while, I cannot precise how often. It only happens on my Samsung notebook which runs Manjaro Linux (+ KDE Plasma). The notebook has an Intel GPU (Intel HD Graphics 520) and I use the modesetting driver.
Comment 3 Elizabeth 2017-11-30 23:48:55 UTC
*** Bug 103849 has been marked as a duplicate of this bug. ***
Comment 4 Elizabeth 2017-12-01 22:33:28 UTC
So it's a rarely one. In that case could you try with Mesa 17.3 to see if it still appears? Thank you.
Comment 5 cribari 2017-12-02 00:15:50 UTC
@Elizabeth It's not that rare. Sometimes it happens once or even twice a week. Unfortunately, Mesa 17.3 hasn't landed on Arch (or on Manjaro).
Comment 6 cribari 2017-12-07 10:30:32 UTC
The DRM crash happened again today. The dmesg dump is available at 

https://pastebin.com/w9Z9yTcw

The error.gz file is available at 

https://www.dropbox.com/s/ed5zvwg0upgmisp/error_20171207-01.gz?dl=0

The output of xrandr --verbose

https://pastebin.com/7PB12H5A
Comment 7 Elizabeth 2017-12-08 17:55:58 UTC
So the hang occurred just after suspend?
Comment 8 cribari 2017-12-08 20:52:28 UTC
(In reply to Elizabeth from comment #7)
> So the hang occurred just after suspend?

The problem occurs in a notebook. I suspend to RAM and resume quite often. I haven't paid attention to whether the crashes only happen after a suspend to RAM and resume. Since I suspend and resume quite often this may well be the case.
Comment 9 cribari 2017-12-09 16:27:17 UTC
Another crash today. See 

https://www.dropbox.com/s/8e0ffjzy5ngjax1/error_20171209_01.gz?dl=0

dmesg dump: 

https://pastebin.com/CbTa2vjh
Comment 10 cribari 2017-12-09 16:50:14 UTC
A related bug: https://bugs.freedesktop.org/show_bug.cgi?id=103725 

Comment: I too noticed that most crashes occur when I am using LibreOffice.
Comment 11 Mark Janes 2017-12-09 19:28:07 UTC
cribari: Mesa devs were able to reproduce modesetting/glamor 2D gpu hangs using KiCad, and resolved that issue in mesa 17.3 which was just released.

We have not been able to reproduce libreoffice hangs ourselves, but are hopeful that the root cause is the same as the KiCad issue.

If you can easily reproduce a libreoffice hang, please try Mesa 17.3, and report back whether it is fixed.  It will help us to address the bug.
Comment 12 cribari 2017-12-18 13:00:02 UTC
@Mark Janes and @Elizabeth I've been using Mesa 17.3 for the past couple of days and so far so good (no crashes). I will keep testing.
Comment 13 Mark Janes 2017-12-18 21:20:49 UTC
Please reopen if you see this with mesa 17.3.
Comment 14 Mark Janes 2017-12-18 21:21:42 UTC
*** Bug 104322 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.