Bug 103818 - [bdw] GPU HANG: ecode 8:0:0x84dfffc4, in Tropico 5
Summary: [bdw] GPU HANG: ecode 8:0:0x84dfffc4, in Tropico 5
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-19 20:20 UTC by tsm414
Modified: 2019-07-15 12:58 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (72.13 KB, text/plain)
2017-11-19 20:21 UTC, tsm414
Details
card0_error (234.81 KB, text/plain)
2017-11-19 20:25 UTC, tsm414
Details
hang screenshot (3.97 MB, image/png)
2017-12-10 08:40 UTC, tsm414
Details
compile_mesa (600 bytes, text/plain)
2018-01-03 17:16 UTC, Elizabeth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tsm414 2017-11-19 20:20:24 UTC
GPU Hanged while I was playing Tropico 5 on an up to date Fedorara 26 (4.13.12-200.fc26.x86_64). It didn't happen on previous versions of Fedora.

This is the third time I had this error and always occurs during the first 30 minutes of playing. Error occurs randomly there isn't any specific action that triggers it.

Machine specs are:
MSI GP62 2QE Leopard PRO (GPE62 2QE-202XES)
Processor: intel core i7
GPU: Nvidia GTX950M
Comment 1 tsm414 2017-11-19 20:21:00 UTC
Created attachment 135589 [details]
dmesg
Comment 2 tsm414 2017-11-19 20:25:00 UTC
Created attachment 135590 [details]
card0_error
Comment 3 Elizabeth 2017-12-04 23:05:02 UTC
Hello TSM, could you share your Mesa version?
Comment 4 tsm414 2017-12-07 07:33:07 UTC
(In reply to Elizabeth from comment #3)
> Hello TSM, could you share your Mesa version?

Hi Elizabeth,

I updated fedora and kernel version but the error still happens (Now i'm running 4.13.16-300.fc27.x86_64 (mockbuild@bkernel01.phx2.fedoraproject.org) (gcc version 7.2.1 20170915 (Red Hat 7.2.1-2) (GCC)) #1 SMP Mon Nov 27 18:19:43 UTC 2017
). My current mesa config is the following:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5600 (Broadwell GT2) 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.2.4
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.2.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.2.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

Best Regards,

Toni
Comment 5 Elizabeth 2017-12-08 17:50:34 UTC
Thanks for the information TSM, I know it can be hard but could you try to find a way to reproduce more reliably, like "selecting bunch of this and moving around certain time will trigger" or "certain animation repeated N times" or the kind. Also new Mesa 17.3 have been released, could you please try to reproduce with this version?
Comment 6 tsm414 2017-12-10 08:39:56 UTC
(In reply to Elizabeth from comment #5)
> Thanks for the information TSM, I know it can be hard but could you try to
> find a way to reproduce more reliably, like "selecting bunch of this and
> moving around certain time will trigger" or "certain animation repeated N
> times" or the kind. Also new Mesa 17.3 have been released, could you please
> try to reproduce with this version?

Hi Elizabeth, I couldn't install mesa 17.3 because I got this error while executing configure:

    configure: error: --enable-llvm is required when building r300

But I found a way to easily reproduce the hang: Start a new game and build a wharf next to the dock. Soon after construction is finished GPU hangs. A thing I didn't mention earlier and may be significant is that I play Tropico 5 on Steam (without any launch options). 

I tried launching it with the option DRI_PRIME=1 %command% to force it to use nvidia card and error didn't reproduce. So it must be something specific of intel card.
Comment 7 tsm414 2017-12-10 08:40:40 UTC
Created attachment 136064 [details]
hang screenshot
Comment 8 Elizabeth 2017-12-11 22:01:47 UTC
You may want to try https://01.org/linuxgraphics/documentation/build-guide-0, the sections PREPARING BUILD ENVIRONMENT and BUILDING 3D - MESA, (don't remember if --enble-dri3 can be omitted). And for dependencies, take a look at https://www.mesa3d.org/install.html, in section 1. Prerequisites for building.
Comment 9 tsm414 2017-12-13 20:57:45 UTC
(In reply to Elizabeth from comment #8)
> You may want to try
> https://01.org/linuxgraphics/documentation/build-guide-0, the sections
> PREPARING BUILD ENVIRONMENT and BUILDING 3D - MESA, (don't remember if
> --enble-dri3 can be omitted). And for dependencies, take a look at
> https://www.mesa3d.org/install.html, in section 1. Prerequisites for
> building.

Hi, finally I reinstalled mesa. But it doesn't seem to work properly. I tried launching the game and it was very slow. I executed glxinfo and I got this:
$ glxinfo | grep OpenGL
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  43
  Current serial number in output stream:  42
Comment 10 Elizabeth 2017-12-13 23:10:10 UTC
(In reply to tsm414 from comment #9)
> ... finally I reinstalled mesa. But it doesn't seem to work properly. I
> tried launching the game and it was very slow... 
I'm assuming you mean the 17.3 version, isn't it?
Comment 11 tsm414 2017-12-14 09:22:07 UTC
(In reply to Elizabeth from comment #10)
> (In reply to tsm414 from comment #9)
> > ... finally I reinstalled mesa. But it doesn't seem to work properly. I
> > tried launching the game and it was very slow... 
> I'm assuming you mean the 17.3 version, isn't it?

Yes, I tried with 17.3 version
Comment 12 tsm414 2017-12-14 22:25:50 UTC
I've been testing with different parameters and if I add swrast or nouveau in drivers list i get the following error:

error: cannot install 'es1api/libGLESv1_CM.la' to a directory not ending in /usr/lib64

And if I add --prefix=$MY_DISTRO_PREFIX --libdir=$MY_DISTRO_LIBDIR to configure i've get

error: cannot install 'libEGL.la' to a directory not ending in /usr/local/lib mesa nvidia
Comment 13 Elizabeth 2018-01-03 17:16:52 UTC
Created attachment 136531 [details]
compile_mesa

May be of some help.
Comment 14 Paul 2019-04-25 09:53:26 UTC
Hello guys
I've just run Tropico 5 on my machine with BDW (Intel® HD Graphics 5500) with mesa 17.2.4; 19.0.3; latest master version and wasn’t able to reproduce the issue on my side.
So, TSM, could you please check the issue on your side?
Since the issue is old, it can be not reproducible on the newest version of the game and of the mesa.
Thanks
Comment 15 Paul 2019-07-15 12:58:08 UTC
Since there is no answer, I'm closing the ticket.
Fill free to reopen it if the issue is still actual.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.