Bug 104195 - [i915] [Device 591b] Backlight not working - wake from suspend not turning on monitor.
Summary: [i915] [Device 591b] Backlight not working - wake from suspend not turning on...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-10 17:25 UTC by Michael
Modified: 2018-01-05 17:27 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: display/backlight, power/suspend-resume


Attachments
dmesg with logging (111.07 KB, text/plain)
2017-12-21 23:54 UTC, Michael
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2017-12-10 17:25:44 UTC
Hello.

i have a Thinkpad T470-P which is equipped with Intel HD graphics 630

00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)

I tried upgrading graphics drivers with intel graphics update tool 2.06: https://01.org/linuxgraphics/downloads/intel-graphics-update-tool-linux-os-v2.0.6

But it caused waking up from suspend to not work, seems the screen is not enabled, 

Also the adjusting of the backlight stops working. 

/sys/class/backlight is empty. Default there was a link to intel_backlight, after playing with kernel option parameter backlight= set to "vendor" i get a link to lenovo_backlight, but it does not work.



Backround info:

I have installed Kubuntu 17.04, It works almost fine out of the box.

The size of everything on the screen was very small so i scaled it to 1.1 in KDE settings. Increased fonts sizes and forced DPI to 120.

I have a big issue with text getting corrupt, complete rows get messed up,  most problem in Qtcreator but also noticed it in Konsole.

kernel module loaded for the graphics card is i915.

Xorg is default using fbdevhw when booting stock kernel and with kernel 4.14.4-041404.
 it is using modesetting driver with submodule fb.

I tried changing font, changing font settings like anti aliasing, sub pixel rendering e.t.c. without any luck.

I tried upgrading the kernel to 4.14.4-041404, upgrading the bios. 

So what needs to be done?

What is the correct setup? i.e:
    -which kernel module and version to use for intel HD graphics 630?
    - Any special kernel option parameter to set during boot?
    - which Xorg driver to use ?
    - Any special Xorg config options?
    - Any special KDE settings for fonts e.t.c. ?


Thank you.

// Michael
Comment 1 Elizabeth 2017-12-13 17:18:28 UTC
Hello Michael, 
First to all could you attach a dmesg log with debug information, drm.debug=0xe on grub, as mentioned here: https://01.org/linuxgraphics/documentation/how-report-bugs
You mentioned you updated to 4.14, are you using any firmware? https://01.org/linuxgraphics/downloads/firmware
so, are you facing also a corruption issue with the display scaled only with KDE? Have you tried another desk like gnome?
Thank you.
Comment 2 Michael 2017-12-21 23:54:57 UTC
Created attachment 136356 [details]
dmesg with logging

Solved.

Solution found.

For future reference if any other people have problems with this chipset.

Graphics works perfectly for intel 591b, backlight working fine and wake from supsend. No tearing etc.

update to Kernel 4.14.04.
Update intel drivers with intel driver update tool.
Add manual xorg conf file: /usr/share/X11/xorg.conf.d/20-intel.conf
Section "Device"
        Identifier      "Card0"
        Driver          "intel"        
        BusID           "PCI:0:2:0"
EndSection


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.