Bug 104198 - [i915] [device 591b] Xorg with framebuffer driver corrupt text / font
Summary: [i915] [device 591b] Xorg with framebuffer driver corrupt text / font
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/fbdev (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-10 18:34 UTC by Michael
Modified: 2018-08-10 20:41 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features:


Attachments
Xorg log file with standard Kubuntu 17.04 (20.54 KB, text/plain)
2017-12-16 19:51 UTC, Michael
no flags Details
dmesg output with updated kernel 4.14.04 (111.21 KB, text/plain)
2017-12-16 20:05 UTC, Michael
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2017-12-10 18:34:04 UTC
i have a Thinkpad T470-P which is equipped with Intel HD graphics 630

00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)

I have a big issue with text getting corrupt, complete rows get messed up,  most problem in Qtcreator but also noticed it in Konsole.

kernel module loaded for the graphics card is i915.

Xorg is default using fbdevhw when booting stock kernel and with kernel 4.14.4-041404 it is using modesetting driver with submodule fb.

I tried changing font, changing font settings like anti aliasing, sub pixel rendering e.t.c. without any luck.

I tried upgrading the kernel to 4.14.4-041404, upgrading the bios. 





Misc info:

I have installed Kubuntu 17.04, It works almost fine out of the box.

The size of everything on the screen was very small so i scaled it to 1.1 in KDE settings. Increased fonts sizes and forced DPI to 120.

I tried upgrading graphics drivers with intel graphics update tool 2.06: https://01.org/linuxgraphics/downloads/intel-graphics-update-tool-linux-os-v2.0.6

But it caused waking up from suspend to not work, seems the screen is not enabled, also the adjusting of the backlight stoped working. 


Thank you.

// Michael
Comment 1 Chris Wilson 2017-12-10 18:47:05 UTC
fbdev? Are you serious? Please attach Xorg.log and dmesg.
Comment 2 Elizabeth 2017-12-13 17:44:48 UTC
(In reply to Chris Wilson from comment #1)
> fbdev? Are you serious? Please attach Xorg.log and dmesg.
And a screen shot of the corrupted image, thank you.
Comment 3 Michael 2017-12-16 19:51:41 UTC
Created attachment 136225 [details]
Xorg log file with standard Kubuntu 17.04

Standard Kubuntu 17.04, no changes to Xorg config, Log file attached.

11.554] (II) LoadModule: "fbdevhw"
[    11.554] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    11.555] (II) Module fbdevhw: vendor="X.Org Foundation"
[    11.555]    compiled for 1.19.3, module version = 0.0.2
[    11.555]    ABI class: X.Org Video Driver, version 23.0
[    11.555] (II) FBDEV(0): using default device
Comment 4 Michael 2017-12-16 20:05:48 UTC
Created attachment 136228 [details]
dmesg output with updated kernel 4.14.04

Attaching dmesg output from updated kernel 4.14.04

Note: I'm having problems getting a screenshot of the issues, seems the screen corruption / tearing cannot be captured with printscreen or shutter. The image captured is not corrupt. So i guess i will have to capture it with an external camera photographing the laptop screen.

Thank you. 

// Michael
Comment 5 Chris Wilson 2017-12-18 20:47:20 UTC
Your -intel has been crippled and -modesetting isn't configured to support that chipset; leaving -fbdev. Either of the first two will provide a [better] working Xorg.
Comment 6 Michael 2017-12-18 21:18:46 UTC
(In reply to Chris Wilson from comment #5)
> Your -intel has been crippled and -modesetting isn't configured to support
> that chipset; leaving -fbdev. Either of the first two will provide a
> [better] working Xorg.

Thank you very much for you analysis.

I don't understand exactly what you concluded here.

For future reference and for other people having issues with this chipset, could you please elaborate a bit.


Are you saying kernel driver i915 is working fine and is the correct driver to use for this chipset?

Are you saying that the intel xorg driver is the preferred xorg driver? In what way is it crippled and why is that in a stock Kubuntu 17.04 ? 

Are you saying modesetting does not support this chipset but is still one of the preferred two drivers to use? 

How to fix the crippled intel xorg driver?
 
Should the intel driver update utility be used?

I did ran into problems with backlight and wake from suspend with the intel driver in the kernel version shipped with Kubuntu 17.04. But i could try updating intel drivers with the intel driver update utility while using this kernel 4.14.04 instead.

Thank you so much.

// Michael
Comment 7 Michael 2017-12-18 21:27:01 UTC

Should the firmware be manually downloaded and installed from intel page as well?
https://01.org/linuxgraphics/downloads/firmware


If so, is this HD graphics 630 (591B) the intel platform they call Kabylake? And is GUC, DMC, HUC firmware all to be updated?

Thanks again!

// Michael
Comment 8 Michael 2017-12-21 23:50:57 UTC
Workaround solution found.

For future reference if any other people have problems with this chipset.

Graphics works perfectly for intel 591b, backlight working fine and wake from supsend. No tearing etc.


update to Kernel 4.14.04.
Update intel drivers with intel driver update tool.
Add manual xorg conf file: /usr/share/X11/xorg.conf.d/20-intel.conf
Section "Device"
        Identifier      "Card0"
        Driver          "intel"        
        BusID           "PCI:0:2:0"
EndSection
Comment 9 GitLab Migration User 2018-08-10 20:41:50 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-fbdev/issues/6.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.