Bug 104394 - [kbl] GPU hang, 9:0:0x85dffffb, in Xorg
Summary: [kbl] GPU hang, 9:0:0x85dffffb, in Xorg
Status: RESOLVED DUPLICATE of bug 104411
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.3
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 103477 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-27 13:18 UTC by J. Ansorg
Modified: 2018-03-08 07:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Content of /sys/class/drm/card0/error (46.02 KB, text/plain)
2017-12-27 13:18 UTC, J. Ansorg
Details
Output of dmesg (63.02 KB, text/plain)
2017-12-27 13:18 UTC, J. Ansorg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J. Ansorg 2017-12-27 13:18:35 UTC
Created attachment 136401 [details]
Content of /sys/class/drm/card0/error

"uname -a":
Linux islandLinux 4.14.8-1-ARCH #1 SMP PREEMPT Wed Dec 20 21:27:44 UTC 2017 x86_64 GNU/Linux   

Thinkpad T470p
Mesa 17.3.0-2 (Arch package)

I experienced a GPU hang today. I've attached the logs as requested in the dmesg output.

Installed mesa packages:
-------
local/glu 9.0.0-4
    Mesa OpenGL Utility library

local/lib32-glu 9.0.0-3
    Mesa OpenGL utility library (32 bits)

local/lib32-libtxc_dxtn 1.0.1-5
    S3 Texture Compression (S3TC) library for Mesa (32-bit)

local/lib32-mesa 17.3.0-2
    an open-source implementation of the OpenGL specification (32-bit)

local/lib32-mesa-vdpau 17.3.0-2
    Mesa VDPAU drivers (32-bit)

local/lib32-vulkan-intel 17.3.0-2
    Intel's Vulkan mesa driver (32-bit)

local/libtxc_dxtn 1.0.1-6
    S3 Texture Compression (S3TC) library for Mesa

local/mesa 17.3.0-2
    an open-source implementation of the OpenGL specification

local/mesa-demos 8.3.0-4
    Mesa demos and tools incl. glxinfo + glxgears

local/mesa-vdpau 17.3.0-2
    Mesa VDPAU drivers

local/vulkan-intel 17.3.0-2
    Intel's Vulkan mesa driver


Xorg.conf snippet about graphics adapter:
Section "Device"
    Identifier  "Intel Graphics"
    Driver "modesetting"
EndSection
Comment 1 J. Ansorg 2017-12-27 13:18:54 UTC
Created attachment 136402 [details]
Output of dmesg
Comment 2 J. Ansorg 2017-12-27 13:21:36 UTC
I'm using the KDE desktop.
Comment 3 Elizabeth 2017-12-27 16:10:18 UTC
Hello J. Ansorg,
Any hint in what triggered this? Are you able to reproduce? 
Thank you.
Comment 4 J. Ansorg 2017-12-27 16:24:39 UTC
Hello Elizabeth,
I think that I was working in IntelliJ (Java Swing based IDE) and was clicking on a menu item. It happened twice in about 20 minutes but unfortunately I'm not able to reproduce this so far.
Comment 5 Elizabeth 2017-12-27 20:21:36 UTC
Ok, in that case if you find a way to easily reproduce, please let us know.
Comment 6 J. Ansorg 2018-01-02 17:38:43 UTC
Hello Elizabeth, 
I just got this again (still unsure how to reproduce, I was using VirtualBox at that time)

Is there anything I could do / test / configure / run to help to find the cause of this? My system is a bit unreliable with this...
Comment 7 Elizabeth 2018-01-05 22:18:37 UTC
(In reply to J. Ansorg from comment #6)
> Hello Elizabeth, 
> I just got this again (still unsure how to reproduce, I was using VirtualBox
> at that time)
> 
> Is there anything I could do / test / configure / run to help to find the
> cause of this? My system is a bit unreliable with this...
If we can't reproduce the issue it will be really hard to point to the root-cause or any fix. For now, you could try this branch https://cgit.freedesktop.org/mesa/mesa/ has the latest changes made to mesa, though not yet released.
Comment 8 J. Ansorg 2018-02-21 10:38:46 UTC
About two weeks ago I switched to the xorg-intel driver (using the git master branch). After this my system is stable now and has not blocked once.

Before I was using the xorg modesetting driver and it was quite unstable.
I think that it may have happened more oftern after wakup from suspend mode but I wasn't able to reproduce this.
Comment 9 Kenneth Graunke 2018-02-21 18:35:12 UTC
Hello, I suspect that modesetting + Mesa 18.0 (or the latest RC) would solve this.
Comment 10 J. Ansorg 2018-03-05 12:15:18 UTC
Hi,
I'm now using Mesa 17.3.6 and I think that my system is back to stable now.
Thanks for the work on this!

If there are no objections I'd close this issue...
Comment 11 Mark Janes 2018-03-05 15:00:13 UTC

*** This bug has been marked as a duplicate of bug 104411 ***
Comment 12 J. Ansorg 2018-03-08 07:39:04 UTC
*** Bug 103477 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.