Bug 105298 - pdftocairo: missing text: failed to load truetype font
Summary: pdftocairo: missing text: failed to load truetype font
Status: RESOLVED DUPLICATE of bug 92048
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-28 19:46 UTC by Jason Crain
Modified: 2018-03-26 03:14 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Page 69 of ORelly-Running Linux 4th Edition.pdf (242.22 KB, application/pdf)
2018-02-28 19:46 UTC, Jason Crain
Details
pdftocairo rendering (187.22 KB, image/png)
2018-02-28 19:52 UTC, Jason Crain
Details
pdftoppm rendering is correct (259.89 KB, image/png)
2018-02-28 19:54 UTC, Jason Crain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Crain 2018-02-28 19:46:43 UTC
Created attachment 137700 [details]
Page 69 of ORelly-Running Linux 4th Edition.pdf

Forwarding from https://bugzilla.gnome.org/show_bug.cgi?id=741681 and https://bugs.launchpad.net/ubuntu/+source/evince/+bug/846873.

There is some missing text on page 69 of this PDF when rendered with `pdftocairo -png`. A section near the bottom of the page should show "# fdisk /dev/sda" but only the "#" is rendered. When run, pdftocairo prints the following warning messages:

Syntax Error: Couldn't find trailer dictionary
Syntax Error (5853): Bad dynamic code table in flate stream
Syntax Error (5853): Bad block header in flate stream
Syntax Error: failed to load truetype font<0a>
some font thing failed
Syntax Error (5853): Bad dynamic code table in flate stream
Syntax Error (5853): Bad block header in flate stream
Syntax Error: failed to load truetype font<0a>
some font thing failed

pdftoppm renders the document correctly, though it also prints a warning that it couldn't create a font. There seems to be a problem with a font in this document and pdftoppm handles the error better than pdftocairo does.
Comment 1 Jason Crain 2018-02-28 19:52:47 UTC
Created attachment 137701 [details]
pdftocairo rendering

Output from `pdftocairo -png`. I've outlined the area with missing text.
Comment 2 Jason Crain 2018-02-28 19:54:10 UTC
Created attachment 137703 [details]
pdftoppm rendering is correct

Output from `pdftoppm -png`. Document is rendered correctly.
Comment 3 Jason Crain 2018-03-26 03:14:32 UTC

*** This bug has been marked as a duplicate of bug 92048 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.