Bug 92048 - PDF rendered incompletely
Summary: PDF rendered incompletely
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
: 92017 105298 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-19 15:22 UTC by Pastafarianist
Modified: 2018-08-20 22:00 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
File with broken rendering (2.67 MB, text/plain)
2015-09-19 15:22 UTC, Pastafarianist
Details
Screenshot of Chrome rendering (620.62 KB, image/png)
2015-09-19 17:45 UTC, Pastafarianist
Details
Invalidates an embedded font and use an external font (3.38 KB, patch)
2015-09-27 09:55 UTC, Thomas Freitag
Details | Splinter Review
CairoFontEngine: Try external font if embedded font fails (1.22 KB, patch)
2018-03-26 03:30 UTC, Jason Crain
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Pastafarianist 2015-09-19 15:22:39 UTC
Created attachment 118361 [details]
File with broken rendering

See the attachment. The summary block isn't rendered, unlike in Chrome.
Comment 1 Pastafarianist 2015-09-19 15:24:15 UTC
I note that the bug shows up in Okular under Kubuntu 15.04, so I'm not sure that I've chosen the frontend correctly.
Comment 2 Albert Astals Cid 2015-09-19 16:08:41 UTC
Since i don't have Chrome, please provide a rendering of how you think this should look like.
Comment 3 Pastafarianist 2015-09-19 17:45:51 UTC
Created attachment 118363 [details]
Screenshot of Chrome rendering
Comment 4 Thomas Freitag 2015-09-21 07:39:10 UTC
Adobe reader, either unix or windows, tells:
Cannot extract the embedded font 'Arial,Bold'. Some characters may not display or print correctly.
So I would guess the PDF is not welformed!
Comment 5 Albert Astals Cid 2015-09-21 17:48:45 UTC
Yeah the font stream is empty so the file is defenitely malformed.

Doesn't mean we could try actally rendering it, i thought we had a "if freetype can not open font default to doing font substitution", but it seems not?
Comment 6 Albert Astals Cid 2015-09-21 17:49:33 UTC
Probably a patch to fix this would also fix https://bugs.freedesktop.org/show_bug.cgi?id=92017
Comment 7 Thomas Freitag 2015-09-27 09:55:34 UTC
Created attachment 118464 [details] [review]
Invalidates an embedded font and use an external font

This patch solves it in the splash backend: if it encounters a problem with an embedded font it invalidates it and tries to find a matching external file.

It's probably such easy to solve it in the cairo backend, too.
Comment 8 Albert Astals Cid 2015-09-27 13:44:18 UTC
*** Bug 92017 has been marked as a duplicate of this bug. ***
Comment 9 Albert Astals Cid 2015-09-27 13:45:18 UTC
Pushed Thomas' patch + a leak fix from me.

Reassigning to cairo.
Comment 10 Jason Crain 2018-03-26 03:14:32 UTC
*** Bug 105298 has been marked as a duplicate of this bug. ***
Comment 11 Jason Crain 2018-03-26 03:30:39 UTC
Created attachment 138352 [details] [review]
CairoFontEngine: Try external font if embedded font fails

Some documents fail to render because the embedded font doesn't load.
If loading the embedded font fails, try with an external font.

Attached is a version of the patch for the cairo backend.
Comment 12 GitLab Migration User 2018-08-20 22:00:29 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/153.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.