Bug 10535 - Strange reflections on xscreensaver 4.24's flying toasters
Summary: Strange reflections on xscreensaver 4.24's flying toasters
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-05 14:48 UTC by Chris Rankin
Modified: 2019-09-18 18:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Flying toasters from xscreensaver 4.24 (40.26 KB, image/png)
2007-04-05 14:52 UTC, Chris Rankin
Details
Another shot of the strange toaster reflections (68.63 KB, image/png)
2007-04-06 05:48 UTC, Chris Rankin
Details
Viewed from the right (31.60 KB, image/png)
2007-04-06 05:49 UTC, Chris Rankin
Details
Strange happenings with R100 as well. (35.57 KB, image/png)
2007-04-07 10:47 UTC, Chris Rankin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Rankin 2007-04-05 14:48:43 UTC
I am running Mesa 6.5.3-got on Linux 2.6.19.7-SMP-PREEMPT, dual P4 Xeon HT, Radeon 9200, and the reflections on the sides of these flying toasters don't look right to me. (P.S. This also happens with a Radeon 7000 card that I have in a different machine.)
Comment 1 Chris Rankin 2007-04-05 14:52:17 UTC
Created attachment 9490 [details]
Flying toasters from xscreensaver 4.24

The reflections on these sides of the toasters seem oddly geometrical, although the other sides look OK.
Comment 2 Chris Rankin 2007-04-06 05:48:38 UTC
Created attachment 9497 [details]
Another shot of the strange toaster reflections

Viewed from the left.
Comment 3 Chris Rankin 2007-04-06 05:49:23 UTC
Created attachment 9498 [details]
Viewed from the right

The reflections look OK from this side.
Comment 4 Chris Rankin 2007-04-07 10:47:16 UTC
Created attachment 9514 [details]
Strange happenings with R100 as well.

The toasters with the radeon_dri.so module (Radeon 7000, R100) flash brown for some reason.
Comment 5 Chris Rankin 2007-04-18 12:51:53 UTC
The problem is still happening with Mesa-git. It is also a lot more noticeable with R100 based hardware, because the toasters are constantly flashing brown.
Comment 6 Michel Dänzer 2007-04-18 23:16:42 UTC
I suspect these are separate issues. Do they go away with either driver if you run the app with the environment variable tcl_mode=0?
Comment 7 Chris Rankin 2007-04-19 01:42:25 UTC
(In reply to comment #6)
> I suspect these are separate issues. Do they go away with either driver if you
> run the app with the environment variable tcl_mode=0?

My R100 card doesn't have TCL hardware in the first place, so I don't see how this could help. And when you say "environment variable", do you mean a LIBGL_DEBUG value, or are you really meaning a setting in my .drirc file(s)?
Comment 8 Roland Scheidegger 2007-04-19 03:43:45 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > I suspect these are separate issues. Do they go away with either driver if you
> > run the app with the environment variable tcl_mode=0?
> 
> My R100 card doesn't have TCL hardware in the first place, so I don't see how
> this could help. And when you say "environment variable", do you mean a
> LIBGL_DEBUG value, or are you really meaning a setting in my .drirc file(s)?
I get the brown flashing too with a radeon 9000 if tcl_mode is set to 0.
With sw mesa, no brown flashing happens, but the reflections just look the same as far as I can tell.
Comment 9 Chris Rankin 2007-04-19 13:56:34 UTC
(In reply to comment #8)
> I get the brown flashing too with a radeon 9000 if tcl_mode is set to 0.
> With sw mesa, no brown flashing happens, but the reflections just look the same
> as far as I can tell.

The toasters flash brown on my R200 as well, with tcl_mode = 0. (It was 1 originally.)

Comment 10 Chris Rankin 2007-04-26 16:42:40 UTC
git Mesa still has flashing-brown flying toasters on my R200 with tcl_mode=0 (software TCL).
Comment 11 Adam Jackson 2009-08-24 12:26:21 UTC
Mass version move, cvs -> git
Comment 12 GitLab Migration User 2019-09-18 18:39:21 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/265.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.