Bug 105555 - [CI] igt@gem_exec_big - incomplete - Softdog
Summary: [CI] igt@gem_exec_big - incomplete - Softdog
Status: RESOLVED DUPLICATE of bug 107936
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: prathap.kumar.valsan
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 107775 107937 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-16 12:48 UTC by Marta Löfstedt
Modified: 2019-03-08 15:43 UTC (History)
3 users (show)

See Also:
i915 platform: BSW/CHT, BYT
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Chris Wilson 2018-03-16 12:54:44 UTC
Let it run to completion and then tell me if there's a bug. Doing a few million execbufs with ranges from 4KiB to 4GiB touching all pages does take some time.
Comment 2 Chris Wilson 2018-03-16 12:55:52 UTC
Imo, this is a bug in CI for using owatch.
Comment 3 Marta Löfstedt 2018-03-16 12:58:59 UTC
(In reply to Chris Wilson from comment #2)
> Imo, this is a bug in CI for using owatch.

We have to limit the runtime if your test can't make it in the timing budget they belong to the blacklist
Comment 4 Chris Wilson 2018-03-16 13:02:30 UTC
(In reply to Marta Löfstedt from comment #3)
> (In reply to Chris Wilson from comment #2)
> > Imo, this is a bug in CI for using owatch.
> 
> We have to limit the runtime if your test can't make it in the timing budget
> they belong to the blacklist

That is not a bug in the test or kernel though. That is a limitation imposed by CI and needs to be reported as such, or rather handled entirely by CI since that wants to redefine tests to suite itself rather than the intent of the test.

In this case owatch is entirely the wrong tool; nothing is expected to be on the output yet the test is still running perfectly fine. As a watchdog, owatch fails for this test.
Comment 5 Marta Löfstedt 2018-03-16 13:07:41 UTC
(In reply to Chris Wilson from comment #4)
> (In reply to Marta Löfstedt from comment #3)
> > (In reply to Chris Wilson from comment #2)
> > > Imo, this is a bug in CI for using owatch.
> > 
> > We have to limit the runtime if your test can't make it in the timing budget
> > they belong to the blacklist
> 
> That is not a bug in the test or kernel though. That is a limitation imposed
> by CI and needs to be reported as such, or rather handled entirely by CI
> since that wants to redefine tests to suite itself rather than the intent of
> the test.
> 
> In this case owatch is entirely the wrong tool; nothing is expected to be on
> the output yet the test is still running perfectly fine. As a watchdog,
> owatch fails for this test.

Feedback to owatch would have come if the test had finished within the time-buget which in this case is 410 seconds.
Comment 6 Francesco Balestrieri 2019-02-12 09:27:05 UTC
Possibly related to bug 107937 ?
Comment 7 Chris Wilson 2019-02-12 09:36:35 UTC
This is not a bug, but a test case that takes a long time to run as it really does want to exercise every page in a very, very large batch buffer. You may want to replace the test with another that only looks at some combinations of pages + total size, that would be a different non-exhaustive test.
Comment 8 Chris Wilson 2019-02-12 10:57:02 UTC
*** Bug 107937 has been marked as a duplicate of this bug. ***
Comment 9 Chris Wilson 2019-02-12 18:46:36 UTC
*** Bug 107775 has been marked as a duplicate of this bug. ***
Comment 10 Chris Wilson 2019-02-15 15:37:33 UTC
Let's join the conversation in #107936

*** This bug has been marked as a duplicate of bug 107936 ***
Comment 11 CI Bug Log 2019-03-08 15:43:48 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.