Bug 105827 - splash slower than cairo at rendering a pdf
Summary: splash slower than cairo at rendering a pdf
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: splash backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-30 23:22 UTC by Kevin
Modified: 2018-08-21 10:36 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2018-03-30 23:22:25 UTC
Okular renders some pdfs much slower than Evince, even though both use Poppler for the pdf backend. Apparently, this is because Evince uses the cairo backend of Poppler, while Okular must use splash.

For example, the second page of this pdf
https://arxiv.org/pdf/1701.07837v2
takes over 3 seconds for Okular to render. However, Evince renders it almost instantly.

Or when quickly scrolling through a large pdf, Evince seems to render the pages almost instantly, while Okular renders slower than I can (quickly) scroll. Here is an example large pdf:
https://arxiv.org/pdf/1508.02595v4

I'm using Okular 1.3.3, Evince 3.26.0, and poppler 0.61.1 on Archlinux (with an Intel i7-3720QM @ 2.6GHz).

I initially submitted this bug at
https://bugs.kde.org/show_bug.cgi?id=391972
bug was asked to submit it here instead. I apologize if this bug is considered to be a duplicate of some similar bugs:
https://bugs.freedesktop.org/show_bug.cgi?id=23991
https://bugs.freedesktop.org/show_bug.cgi?id=78728
https://bugs.freedesktop.org/show_bug.cgi?id=81211
Comment 1 GitLab Migration User 2018-08-21 10:36:39 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/285.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.