Bug 10586 - Switching to vga VT while using 3d composite manager locks up computer
Summary: Switching to vga VT while using 3d composite manager locks up computer
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-09 15:09 UTC by Martin Pärtel
Modified: 2007-12-09 18:44 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
X log file (150.83 KB, text/plain)
2007-04-09 15:10 UTC, Martin Pärtel
no flags Details
gdb output (13.38 KB, text/plain)
2007-10-08 17:41 UTC, Juan Pablo Salazar Bertin
no flags Details
gdb output with packages from debian unstable (15.38 KB, text/plain)
2007-10-09 21:05 UTC, Juan Pablo Salazar Bertin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Pärtel 2007-04-09 15:09:51 UTC
The computer sometimes freezes when I do a Ctrl+Alt+F1 or simply quit X while running compiz or beryl.
I was testing the following debian experimental packages:
xorg-core 1.2.99.903 and xorg-video-intel 1.9.93 with mesa 6.5.2 

xorg 1.2.0, intel 1.7.2, mesa 6.5.2 did not have this issue.

It looks like some sort of a memory corruption issue. One of the messages posted in X's log while switching VTs got a bit messed up after switching to tty1 and back for the third time:
(II) intel(0): Modeline "PèÊ Ë"x60.0   65.00  1024 .....

The entire logfile for that session is attached. As far as I could tell the system was completely locked up after it froze (no hdd activity, no network response) so I couldn't get any log messages after that.


Hardware:
Thinkpad T60
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)



Related debian bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=396037

As a side note, some of beryl's emerald window decorations were rendered incorrectly with the experimental packages. Colors were missing in some parts and some themes had title bar text highlights in the wrong place.
Comment 1 Martin Pärtel 2007-04-09 15:10:38 UTC
Created attachment 9535 [details]
X log file
Comment 2 Eric Anholt 2007-05-01 12:57:17 UTC
Could you try again with the released server/driver?
Comment 3 Martin Pärtel 2007-05-01 13:23:41 UTC
Still crashes with the latest debian unstable i.e. xorg-core 1.3.0, intel 2.0.0, mesa 6.5.2.

Also briefly tried VT switching while running xcompmgr. That seemed to work fine.
Comment 4 Martin Pärtel 2007-07-06 22:51:39 UTC
I found a workaround!
It seems the bug can only be reproduced with vga (as opposed to framebuffer) terminals. With the kernel using vesafb, I can't make it crash anymore.

I'm now using xorg-core 1.3.0, intel 2.1.0, mesa 6.5.3, kernel 2.6.22-rc7.
With the regular vga terminals, the same crash occured every once in a while, even if any GL apps hadn't been used.
Comment 5 Juan Pablo Salazar Bertin 2007-08-15 15:46:51 UTC
Martin,

I've reported a similar bug at launchpad: https://bugs.launchpad.net/bugs/127101
There's even a video there showing how the screen looks when my laptop hangs, do you think it's the same bug?
Thanks.
Comment 6 Martin Pärtel 2007-08-15 21:54:27 UTC
Yes, that's exactly what it looks like!

Also, I said earlier that vesafb seemed to help. Actually it does still hang occasionally. With vesafb the screen just stops (no blinking).
Comment 7 Gordon Jin 2007-08-28 20:10:56 UTC
I'm not seeing this issue on:
-- Ubuntu Feisty 7.04 (xserver 1.2.0, intel 1.9.94, Mesa 6.5.2) on 965GM
-- Fedora 7 (xserver 1.3.0, intel 2.0.0, Mesa 6.5.2) on 965G
Comment 8 Eric Anholt 2007-08-30 14:03:14 UTC
Gordon: 3/3 reporters whose hardware I checked were using a 945GM, so I wouldn't expect testing on a G/GM965 to show the issue.
Comment 9 Sitsofe Wheeler 2007-08-31 15:14:19 UTC
I'm seeing this too. It happens randomly and when the hang happens the blocks on the screen are pretty much as in the video on the launchpad bug. The laptop is a Lenovo T60 running at 1024x768.

lspci output is:
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

It seems to happen more often when a composite manager is being used but I have also had this happen when logging out of sessions that have only been using metacity. It does not seem to happen every time. I am currently trailing whether this happens when DRI is disabled.

Version information:
xorg 1:7.2-5ubuntu7
xserver-xorg-video-intel 2:2.1.1-0ubuntu2
Comment 10 unggnu 2007-09-16 10:41:42 UTC
I am experiencing the same issue with Intel driver 2:2.1.1-0ubuntu3 and i915GM on Ubuntu Gutsy Gibbon.
This doesn't happen with i810 driver.

Hardware:
Sony Vaio TX2
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
Comment 11 Sitsofe Wheeler 2007-09-21 01:04:31 UTC
This seems to be fairly reproducible using steps mentioned by Brian inhttps://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/127101 - basically start/stop video and switch back and forth to VTs. 
Comment 12 unggnu 2007-09-28 08:49:05 UTC
It seems that this issue has something to do with bug report http://bugs.freedesktop.org/show_bug.cgi?id=10809 . The patch seems to fix the issue at least for me after some tests.
Comment 13 Bryce Harrington 2007-09-28 19:37:50 UTC
Btw, I've uploaded the patch to fix this in Ubuntu today:

https://bugs.launchpad.net/ubuntu/+bug/127101

Comment 14 Juan Pablo Salazar Bertin 2007-10-08 17:41:57 UTC
Created attachment 11945 [details]
gdb output

Unfortunately, the patch in bug #10809 doesn't fix this bug.
I'm attaching gdb output when trying to reproduce this bug. I was able to reproduce it after my second attempt.

Steps I did to reproduce it:
1. Disable compiz and enable compiz again.
2. Switch to VT1 and switch back to VT7.
3. Repeat steps 1 and 2 several times.

You can replace step 1 with playing some video file using xv, but sometimes you get a SIGABRT and end up with bug #12437.

After the last "step" in the output attached, you can see the gray blocks and the whole laptop hangs (no networking, sysrq, etc.).

I was using:
xserver-xorg-video-intel                   2:2.1.1-0ubuntu5
xserver-xorg-core                          2:1.3.0.0.dfsg-12ubuntu8
Comment 15 Juan Pablo Salazar Bertin 2007-10-09 21:05:49 UTC
Created attachment 11964 [details]
gdb output with packages from debian unstable

I've installed latest -core and -intel packages from Debian unstable to test this again. gdb output attached. Package versions are:

xserver-xorg-core                          2:1.4-3
xserver-xorg-video-intel                   2:2.1.1-4

The laptop hangs in the following loop at lines 1959-1961 (file i830_driver.c):

   for(i = 0; i < 256; i++) {
      OUTREG(PALETTE_A + (i << 2), pI830->savePaletteA[i]);
   }
Comment 16 x 2007-10-16 11:51:22 UTC
*** Bug 10768 has been marked as a duplicate of this bug. ***
Comment 17 Michael Fu 2007-10-23 00:27:41 UTC
could you please try the patch in bug# 10768 comment# 23?
Comment 18 Gordon Jin 2007-11-14 23:35:31 UTC
There have been some VT fixes committed in the git recently, which do fix some VT bug reports.
Could anyone retest this bug with the git tip or 2.2 release?
Comment 19 Gordon Jin 2007-12-09 18:44:19 UTC
Feedback timed out. I'm assuming it's fixed by the recent VT-related patches. Please reopen if you still see it with 2.2.x driver or git tip.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.