Bug 106035 - Corruption with Firefox after upgrade to 18.0.0
Summary: Corruption with Firefox after upgrade to 18.0.0
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 18.0
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-13 12:24 UTC by Timo Aaltonen
Modified: 2019-09-25 19:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Aaltonen 2018-04-13 12:24:57 UTC
I've recently upgraded my devel desktop to Ubuntu bionic (~18.04) which comes with Mesa 18.0.0. Now I'm seeing some corruption with Firefox, like the white blobs on this video:

https://www.youtube.com/watch?v=u9EMkuZ9Frk

I also get it sometimes when playing youtube videos, and then the blobs are more colorful..

I didn't have this with 17.2.8 before upgrade. Also, I haven't seen this on my KBL laptop, while this desktop is SKL.. both running same versions of everything.
Comment 1 Mark Janes 2018-04-13 20:02:26 UTC
You need to disable gpu rendering for firefox

layers.acceleration.force-enabled;false

If you have a web page that reproduces this 100% of the time, then we can bisect.  As it stands, this is a dup of bug 104890, which after investigation appears to be due to a FF context synchronization bug.
Comment 2 Timo Aaltonen 2018-04-20 06:34:43 UTC
yes, I had that on.. after disabling it I haven't seen the corruption anymore
Comment 3 GitLab Migration User 2019-09-25 19:10:35 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1715.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.