Bug 10612 - LibGL i915 Driver do not support visual 0x49
Summary: LibGL i915 Driver do not support visual 0x49
Status: RESOLVED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: libGL (show other bugs)
Version: DRI git
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-11 07:18 UTC by Song Yuanle
Modified: 2007-04-14 04:59 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Song Yuanle 2007-04-11 07:18:11 UTC
DRI is well except the warning by glxinfo:
libGL warning: 3D driver claims to not support visual 0x49

Addtion infomation
1.Hardware
Intel(R) Pentium(R) M processor 1.50GHz
Intel Corporation Mobile 915GM/PM/GMS/910GML

2.Linux system (Fedora 6)
kernel 2.6.20-1.2933.fc6 i686
X Window System Version 7.1.1
X Protocol Version 11, Revision 0, Release 7.1.1
xorg-x11-server 1.1.1-47.7.fc6

3.DRI relative packages
libdrm 2.3.1
mesa and drm are download by git rencently, I don't know their version
server glx version string: 1.2
client glx version string: 1.4
GLX version: 1.2
OpenGL version string: 1.3 Mesa 6.5.3
Comment 1 Michel Dänzer 2007-04-11 07:20:08 UTC

*** This bug has been marked as a duplicate of bug 6689 ***
Comment 2 Song Yuanle 2007-04-12 03:18:12 UTC
Something new:
  the "XVideo" didn't work.

1.XVideo support can't be enable in order to use X server
When I add 
  Option      "XVideo" true
in Section "Device" of xorg.conf,
X server fails to start, saying it can't find screen 0 or something like that.
I can't find any reason in /var/log/Xorg.0.log, this only logs the last time X server starts? 

2.Desktop Effects didn't work
I can't Enable Desktop Effects in GNOME.

3.MPlayer(GUI) start with a error
[ws]Sorry, your system does not support the XShape extension.
Comment 3 Song Yuanle 2007-04-14 04:59:23 UTC
This problem due to lack of 
Load        "extmod"
in xorg.conf

probably have no relationship with DRI/Mesa driver.

Though, after adding that line, warning information by glxinfo change from
libGL warning: 3D driver claims to not support visual 0x49
to
libGL warning: 3D driver claims to not support visual 0x5b

The problem is I can't find any information on visual 0xHH.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.