Bug 6689 - libGL warning: 3D driver claims to not support visual 0x51
libGL warning: 3D driver claims to not support visual 0x51
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: GLX
git
x86 (IA32) Linux (All)
: high minor
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 21:58 UTC by Diego
Modified: 2009-08-24 12:23 UTC (History)
10 users (show)

See Also:


Attachments
disable-libGL-warning.diff (622 bytes, patch)
2007-08-12 02:13 UTC, Stefan Dirsch
Details | Splinter Review
patch for filtering warnings about non-conformant visuals (643 bytes, patch)
2007-08-12 16:30 UTC, Roland Scheidegger
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Diego 2006-04-21 21:58:37 UTC
i'm running X on a 

VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]

Upon startup the X log contains this:

(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28
(WW) AIGLX: 3D driver claims to not support visual 0x29
(WW) AIGLX: 3D driver claims to not support visual 0x2a
(WW) AIGLX: 3D driver claims to not support visual 0x2b
(WW) AIGLX: 3D driver claims to not support visual 0x2c
(WW) AIGLX: 3D driver claims to not support visual 0x2d
(WW) AIGLX: 3D driver claims to not support visual 0x2e
(WW) AIGLX: 3D driver claims to not support visual 0x2f
(WW) AIGLX: 3D driver claims to not support visual 0x30
(WW) AIGLX: 3D driver claims to not support visual 0x31
(WW) AIGLX: 3D driver claims to not support visual 0x32

glxgears, also reports this:
libGL warning: 3D driver claims to not support visual 0x4b

the strange thing is that glxinfo reports that there is a 0x4b visual. Here is
the output (i'm running the server with a default color depth of 16).

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x24 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  8  0  0  0  0  0 0 Slow
0x25 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16  0  0 0 Slow
0x26 16 tc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 Slow
0x27 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x28 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  8  0  0  0  0  0 0 Slow
0x29 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16  0  0 0 Slow
0x2a 16 tc  0 16  0 r  .  .  5  6  5  0  0 16  8 16 16 16  0  0 0 Slow
0x2b 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x2c 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  8  0  0  0  0  0 0 Slow
0x2d 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  0 16 16 16  0  0 0 Slow
0x2e 16 dc  0 16  0 r  y  .  5  6  5  0  0 16  8 16 16 16  0  0 0 Slow
0x2f 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  0  0  0  0  0  0 0 None
0x30 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  8  0  0  0  0  0 0 Slow
0x31 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  0 16 16 16  0  0 0 Slow
0x32 16 dc  0 16  0 r  .  .  5  6  5  0  0 16  8 16 16 16  0  0 0 Slow
0x4b 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
Comment 1 Erik Andren 2006-04-22 15:53:21 UTC

*** This bug has been marked as a duplicate of 6624 ***
Comment 2 Michel Dänzer 2006-08-26 05:38:55 UTC
Reopening for the client side warning. It's caused by the visual being marked
non-conformant by AIGLX. A solution is being discussed on the mesa3d-dev mailing
list.

Note that this is completely cosmetic and has no functional impact.
Comment 3 Michel Dänzer 2007-04-11 07:20:08 UTC
*** Bug 10612 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Dirsch 2007-08-08 21:49:17 UTC
Since I still see this issue with Mesa 7.0. Anyone who can at least give me a pointer to the mentioned discussion on mesa-dev? I couldn't find it. :-(
Comment 5 Michel Dänzer 2007-08-09 01:44:34 UTC
(In reply to comment #4)
> Anyone who can at least give me a pointer to the mentioned discussion on
> mesa-dev? I couldn't find it. :-(

I'm not sure, but I think I was referring to http://www.mail-archive.com/mesa3d-dev@lists.sourceforge.net/msg01301.html . Some experiments of mine indicate the caveat isn't the only problem though. Another approach might be to add an entry corresponding to the AIGLX visual on the client side, either in each driver or libGL itself.
Comment 6 Stefan Dirsch 2007-08-09 01:51:32 UTC
Thanks, Michael. Strangely I get this message even when AIGLX is disabled.
Comment 7 Stefan Dirsch 2007-08-09 02:04:26 UTC
> Another approach might be to add an entry corresponding to the AIGLX visual
> on the client side, either in each driver or libGL itself.

Any ideas where thes are defined in Mesa sources?
Comment 8 Stefan Dirsch 2007-08-12 02:13:13 UTC
Created attachment 11107 [details] [review]
disable-libGL-warning.diff

braindead patch
Comment 9 Roland Scheidegger 2007-08-12 07:39:33 UTC
(In reply to comment #8)
> Created an attachment (id=11107) [details]
> disable-libGL-warning.diff
> 
> braindead patch
Hmm. I don't think the id as such has any inherent meaning (so it could potentially change), I think though it's always the last mode. Maybe it would be better to filter the GLX_NON_CONFORMANT_CONFIG bit in the VisualRating instead, I don't think those are used anywhere else (and even if they were it would only suppress the warning if the driver can't support it anyway).
Comment 10 Stefan Dirsch 2007-08-12 11:46:41 UTC
Thanks for the proposal. Unfortunately I can't say. I have exactly no idea of Mesa sources. Maybe you can provide an appropriate patch?
Comment 11 Roland Scheidegger 2007-08-12 16:30:57 UTC
Created attachment 11112 [details] [review]
patch for filtering warnings about non-conformant visuals

What about this patch instead. Just filters warnings about unsupported non-conformant visuals instead of relying on the visual id.
Not sure though it's a good solution neither...
Comment 12 Stefan Dirsch 2007-08-12 18:08:39 UTC
Thanks. This is definitely a better patch.
Comment 13 Stefan Dirsch 2007-08-12 18:12:30 UTC
Hmm. Shouldn't it be

  if (m->visualRating != GLX_NON_CONFORMANT_CONFIG)
                      ^^

? 
Comment 14 Roland Scheidegger 2007-08-13 01:18:50 UTC
(In reply to comment #13)
> Hmm. Shouldn't it be
> 
>   if (m->visualRating != GLX_NON_CONFORMANT_CONFIG)
>                       ^^
Oops. Yes of course...
Comment 15 Stefan Dirsch 2007-08-13 02:32:51 UTC
Can you commit the patch into git and/or discuss it with Brian Paul? I'm afraid otherwise this issue will never get fixed upstream. :-( The warning is *very* confusing for users ...
Comment 16 Brian Paul 2007-08-13 02:53:04 UTC
I've been tempted to simply disable the warning for quite a while.  It's annoying and misleading.  I think Ian's the only person that knows the whole story behind it.
Comment 17 Juan Pablo Salazar Bertin 2007-08-15 15:00:30 UTC
*** Bug 6624 has been marked as a duplicate of this bug. ***
Comment 18 Michel Dänzer 2007-08-16 02:03:12 UTC
Roland pushed his patch to Mesa GIT.
Comment 19 Stefan Dirsch 2007-08-16 02:17:31 UTC
Thanks a lot!
Comment 20 wilson 2007-10-08 10:09:14 UTC
my video card is a 865g intel
my linux distro is slackware 12
Comment 21 ajax at nwnk dot net 2009-08-24 12:23:50 UTC
Mass version move, cvs -> git