Bug 106157 - [Tracker] Mesa 18.1 release tracker
Summary: [Tracker] Mesa 18.1 release tracker
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/X11 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on: 105906 105938 106180
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-20 17:41 UTC by Dylan Baker
Modified: 2018-10-23 16:12 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dylan Baker 2018-04-20 17:41:53 UTC
This is a tracker for all regressions from 18.0 to 18.1
Comment 1 Darek 2018-04-24 12:37:42 UTC
Description:
Some apps crash on startup (chromium, thunderbird, glxgears, eglgears_x11)

Additional info:
* package version(s)
mesa-18.1.0rc1 (tested also with mesa-git-18.2.0_devel.101822.4559aefb5c)-meson build
xorg-server 1.19.99.904
xf86-video-nouveau-git 1.0.15.r5.gac8f7b9

* config and/or log files etc.
$ glxgears
X Error of failed request:  BadImplementation (server does not implement operation)
  Major opcode of failed request:  149 ()
  Minor opcode of failed request:  7
  Serial number of failed request:  41
  Current serial number in output stream:  42
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  149 ()
  Minor opcode of failed request:  4
  Resource id in failed request:  0xc00006
  Serial number of failed request:  42
  Current serial number in output stream:  42

Downgrading to mesa-18.0.1 works as workaround.
Comment 2 Daniel Stone 2018-04-24 12:46:53 UTC
See https://lists.freedesktop.org/archives/xorg-devel/2018-April/056760.html and replies.
Comment 3 Darek 2018-04-24 13:21:03 UTC
Tested: 
mesa 18.1.0rc1
xorg-server 1.19.99.904 + xserver-dri3-Fix-DRI3.2-support-for-drivers-other-than-modesetting-ddx.patch

Everything works as it should. Thank you!
Comment 4 mercuriete 2018-04-28 09:10:06 UTC
Sorry for the noise,
I need help to know how make useful logs
I have this bug: https://bugs.freedesktop.org/show_bug.cgi?id=106180

I can't use any vulkan application when using PRIME. (amd+intel)
Comment 5 Dylan Baker 2018-10-23 16:08:25 UTC
18.1 is EOL, no new bugs will be addressed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.