Bug 106224 - "Medieval 2 Total War" will sometimes crash system on a R9 270 card
Summary: "Medieval 2 Total War" will sometimes crash system on a R9 270 card
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 18.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2018-04-24 21:35 UTC by LunarG
Modified: 2019-07-03 17:53 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LunarG 2018-04-24 21:35:29 UTC
Overview:
After rebooting the machine and starting the game "Medieval 2:total war", and not giving any input from the keyboard after the game starts, the game will crash the system.

Steps to Reproduce:
While I wasn't able to reproduce this on my machine using my AMD RX480 card, my co-workers machine using an AMD R9 270 seemed pretty consistent. 

As stated above to reproduce the issue: after a reboot of the machine, if the game is started through steam and left alone with no input from the keyboard the machine will freeze.

Additional Info:
I've been having trouble getting any log messages or output as the machine will freeze completely needing a hard reboot. If I can get any I will post it here.
Comment 1 Timothy Arceri 2019-07-03 02:51:26 UTC
Is this still happening with a more recent version of Mesa?
Comment 2 LunarG 2019-07-03 17:53:47 UTC
Started the game with Mesa 18.3.6 on an R9 270 card and was not able to reproduce the issue. Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.