Bug 106326 - openchrome git failed on xubuntu 18.04
Summary: openchrome git failed on xubuntu 18.04
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/openchrome (show other bugs)
Version: git
Hardware: All Linux (All)
: medium normal
Assignee: Kevin Brace
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-30 18:43 UTC by sebastien
Modified: 2018-11-22 15:01 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg log (23.31 KB, text/x-log)
2018-04-30 18:43 UTC, sebastien
no flags Details
Xorg.0.log 2 screen working (59.63 KB, text/x-log)
2018-05-02 11:14 UTC, sebastien
no flags Details
dump via reg before standbye (18.15 KB, text/plain)
2018-05-03 10:45 UTC, sebastien
no flags Details
dump via reg after standbye (18.15 KB, text/plain)
2018-05-03 10:47 UTC, sebastien
no flags Details
NC20 lspci dump (12.47 KB, text/plain)
2018-05-04 07:11 UTC, sebastien
no flags Details
Samsung NC20 FP Fix (2.06 KB, patch)
2018-05-04 07:50 UTC, Kevin Brace
no flags Details | Splinter Review
picture after standbye vga + fp (2.70 MB, image/jpeg)
2018-05-04 10:38 UTC, sebastien
no flags Details
before standbye 2 dump (18.15 KB, text/plain)
2018-05-06 09:35 UTC, sebastien
no flags Details
dump after boot, standbye don't working (18.15 KB, text/plain)
2018-05-06 09:36 UTC, sebastien
no flags Details
before turning off (18.15 KB, text/plain)
2018-05-13 07:57 UTC, sebastien
no flags Details
after turning_off (18.15 KB, text/plain)
2018-05-13 07:58 UTC, sebastien
no flags Details
After turning on (18.15 KB, text/plain)
2018-05-13 07:58 UTC, sebastien
no flags Details
Xorg.0.log (92.32 KB, text/x-log)
2018-05-13 07:59 UTC, sebastien
no flags Details
dump log by ssh after standbye (18.15 KB, text/plain)
2018-05-14 16:21 UTC, sebastien
no flags Details
VX800 chipset standby resume fix to try 1 (2.35 KB, patch)
2018-05-31 16:57 UTC, Kevin Brace
no flags Details | Splinter Review
dump via reg before standbye (without patch) (18.15 KB, text/plain)
2018-06-30 18:55 UTC, sebastien
no flags Details
dump via reg after standbye (without patch) (18.15 KB, text/plain)
2018-06-30 18:56 UTC, sebastien
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description sebastien 2018-04-30 18:43:54 UTC
Created attachment 139233 [details]
xorg log

I have made update with latest version of git openchrome (0 .6.174)
the module openchrome failed to load

"(EE) openchrome: module ABI major version (20) doesn't match the server's version (23)
[    14.251] (II) UnloadModule: "openchrome"
[    14.251] (II) Unloading openchrome
[    14.251] (EE) Failed to load module "openchrome" (module requirement mismatch, 0)"
Comment 1 Kevin Brace 2018-05-01 05:38:03 UTC
Hi sebastien,

You probably did an upgrade installation of Xubuntu 18.04.
DDX ABI is not matching and this happens if the old DDX is left behind from the previous version of the OS / X Server.
Canonical no longer installs non-KMS DDX by default since Ubuntu 16.04 LTS, so you will likely have to install OpenChrome DDX manually, then install the latest upstream OpenChrome DDX.
Follow the following procedure.

sudo apt-get install xserver-xorg-video-openchrome
sudo apt-get build-dep xserver-xorg-video-openchrome
("Compile and install the upstream latest code.")

You will need to rebuild the OpenChrome DDX compilation script, then compile the DDX code.
I hope it works.

Kevin Brace
Brace Computer Laboratory blog
https://bracecomputerlab.com


(In reply to sebastien from comment #0)
> Created attachment 139233 [details]
> xorg log
> 
> I have made update with latest version of git openchrome (0 .6.174)
> the module openchrome failed to load
> 
> "(EE) openchrome: module ABI major version (20) doesn't match the server's
> version (23)
> [    14.251] (II) UnloadModule: "openchrome"
> [    14.251] (II) Unloading openchrome
> [    14.251] (EE) Failed to load module "openchrome" (module requirement
> mismatch, 0)"
Comment 2 sebastien 2018-05-01 17:33:57 UTC
I reinstall, xserver-xorg-video-openchrome 6.0, it's working
after i have compiled latest git version with : 


./autogen.sh --prefix=/usr --enable-debug --enable-xv-debug --enable-viaregtool 
make
make install

after reboot, xorg not working 

my hardware is a samsung nc20 (vx800)
Comment 3 Kevin Brace 2018-05-01 18:12:15 UTC
Okay, it is likely that there is a regression that involves VX800 chipset flat panel.
I did change the code because it used to detect two FPs, but now I am trying to limit it to one FP.
I do not have Samsung NC20, so I was not able to test it.
If you can connect the computer to a VGA monitor and upload the Xorg.0.log, that might help me understand where the code went wrong.


 (In reply to sebastien from comment #2)
> I reinstall, xserver-xorg-video-openchrome 6.0, it's working
> after i have compiled latest git version with : 
> 
> 
> ./autogen.sh --prefix=/usr --enable-debug --enable-xv-debug
> --enable-viaregtool 
> make
> make install
> 
> after reboot, xorg not working 
> 
> my hardware is a samsung nc20 (vx800)
Comment 4 sebastien 2018-05-02 11:14:08 UTC
Created attachment 139269 [details]
Xorg.0.log 2 screen working

xorg.0.log, 2 screen working
Comment 5 sebastien 2018-05-02 11:27:19 UTC
i join xorg.0.log 
my samsung nc20 working with vga screen plugged (2 screen working)
Comment 6 Kevin Brace 2018-05-03 00:00:07 UTC
sebastien, does it now work w/o VGA attached to the computer? (FP only)
Does standby resume work for you? (except VT screen after standby resume)
Comment 7 sebastien 2018-05-03 05:31:33 UTC
its working with vga screen plugged on my netbook
fp and vga

stanbye resume working but only vga screen work
after resume, fp don't working
Comment 8 Kevin Brace 2018-05-03 06:00:50 UTC
sebastien, does the netbook work without VGA?
Can you also do a register dump for before and after standby?
Since you already built OpenChrome DDX with its debug tool, it should be fairly easy to obtain the register dump.

(From OpenChrome DDX root directory.)
cd tools
sudo ./via_regs_dump -d > Before_standby_regs.txt
(Put the computer into standby.)
sudo ./via_regs_dump -d > After_standby_regs.txt

If you can upload the data, that might help me fix the issue since I do not own a VX800 chipset laptop.


(In reply to sebastien from comment #7)
> its working with vga screen plugged on my netbook
> fp and vga
> 
> stanbye resume working but only vga screen work
> after resume, fp don't working
Comment 9 sebastien 2018-05-03 10:45:34 UTC
Created attachment 139298 [details]
dump via reg before standbye
Comment 10 sebastien 2018-05-03 10:47:01 UTC
Created attachment 139299 [details]
dump via reg after standbye
Comment 11 sebastien 2018-05-03 10:49:05 UTC
ok I join dump log before and after standbye

My netbook doesn't work without vga branched with latest git version.
With vga screen branched, flat panel and vga work before standbye
After standbye only vga work
Comment 12 Kevin Brace 2018-05-04 06:13:22 UTC
sebastien, thank you for the before and after register dump.
It was very helpful in understanding the underlying hardware configuration Samsung used.
It appears that Samsung hooked up LVDS2 (LVDS channel 2) to the FP rather than the more logical LVDS1.
I think I will need to use quirk code to handle this special case.
As for why OpenChrome DDX works with a VGA monitor attached, LVDS2 happens to have IGA2 (think of it as display controller #2) selected as its display source (very likely set by the VGA BIOS), although the current code "thinks" LVDS1 has the FP connected.
The current code is setting everything right except LVDS2 since it thinks LVDS1 has the FP attached.
When VGA and FP are both used simultaneously, X Server almost always assigns VGA to IGA1 and FP to IGA2.
If you only use FP, it assigns FP to IGA1, but the VGA BIOS appears to be setting IGA2 as LVDS2's display source, hence, you do not see anything on the screen because IGA2 is not in use.
    Ever since I got involved in developing OpenChrome graphics stack (starting roughly 3 years ago), I have extensively rewritten display mode setting code.
What the previous developers did not do very well is to proactively assign display source for the display output type used by the end user.
It was almost always relying on VGA BIOS to set this (essentially relying on "left over" register bits), but the problem with this approach is that it just cannot handle standby resume since the register bits get erased when coming out of standby.
Although I myself did not handle your case correctly in your situation due to lack of having the actual hardware in front of me, I now think I know what is going on, and all I will have to do is to write you a small patch that handles Samsung NC20 netbook as a special case.
For this, I will need lspci dump to figure out the PCI subvendor ID and subdevice ID.

lspci -vvnn > Samsung_NC20_lspci_dump.txt

I do not personally like this approach, but I already do this for Sylvania g netbook (VX700 chipset) and Quanta IL1 netbook (VX800 chipset), so I do not mind doing it for another hardware.
OpenChrome used to have a huge table (close to 300 entry) of known devices to handle this, but it was not well designed (cannot really handle your situation anyway), was a maintenance nightmare, and the approach is contrary to a good graphics device driver programming practice, so I got rid of it.

https://cgit.freedesktop.org/openchrome/xf86-video-openchrome/commit/?id=9822064f0cf2675fbaa1390b86a83e5bdd61fbf2

There were a few side effects doing this, but as far as I know, almost all issues are now resolved, and I think OpenChrome handles mode setting far better today, especially standby resume.
So please provide me with the lspci dump and upload the data.
It will take a day or two for the patch to be ready.
When the patch is ready, I will give you how to test OpenChrome DDX with the patch applied.
    If the code works, I will obviously commit the code into the OpenChrome DDX upstream repository, but variant of the code will also make it into the upcoming OpenChrome DRM.
OpenChrome DRM will finally support KMS (Kernel Mode Setting), and considering the lack of corporate financial backing of OpenChrome Project (several Nouveau developers work for RedHat, one works for Intel, but uses his spare time on it, etc.), I think this is quite an achievement.
I wrote this reply on a pretty buggy KN400 chipset laptop (Averatec 3250) with OpenChrome DRM performing KMS.
I got Lubuntu 18.04 and Firefox 52 ESR (Extended Service Release) running on this laptop (AMD Athlon XP does not support SSE2 instruction, hence, I need to use Firefox 52), with two displays running (FP + VGA).
I also figured out how to get standby resume working on this really buggy laptop (the laptop itself is not that bad hardware wise, but standby related part of ACPI BIOS is broken, however, I found a workaround that allows me to enter / exit standby fairly reliably).
I am trying to get OpenChrome DRM to work as reliably as the existing legacy OpenChrome DDX's mode setting code (UMS or User Mode Setting), so any help I can get in improving the reliability of OpenChrome is appreciated.


(In reply to sebastien from comment #11)
> ok I join dump log before and after standbye
> 
> My netbook doesn't work without vga branched with latest git version.
> With vga screen branched, flat panel and vga work before standbye
> After standbye only vga work
Comment 13 sebastien 2018-05-04 07:11:30 UTC
Created attachment 139334 [details]
NC20 lspci dump
Comment 14 sebastien 2018-05-04 07:18:17 UTC
ok thanks for your work, i joint lspci dump log 
Its a pity to add special code for my netbook. 
but yes, bug under linux are often linked to bios. (acpi etc)
sorry for my bad english, i'm french ...

so i have also a via artigo a1150 (vx900 vga and hdmi) and via epia (vx900 vga and hdmi)

I will test the openchrome code on this hardware
Comment 15 Kevin Brace 2018-05-04 07:50:11 UTC
Created attachment 139339 [details] [review]
Samsung NC20 FP Fix

Samsung NC20 FP Fix Patch
Comment 16 Kevin Brace 2018-05-04 08:05:05 UTC
sebastien, here is the patch.
I hope it works.
Assuming that FP solo (i.e., FP only w/o VGA) works, test FP + VGA.
Try turning off FP and / or VGA via Display panel of the Xubuntu settings (I forgot the official name since I am writing this reply from a Lubuntu 18.04 computer.).
If the basic functionality is working, try standby resume for all kinds of configurations (FP, FP + VGA, FP only boot, then attach VGA after boot).
I hope this patch fixes the Samsung NC20 netbook issues for once and for all.


(In reply to sebastien from comment #14)
> ok thanks for your work, i joint lspci dump log 
> Its a pity to add special code for my netbook. 
> but yes, bug under linux are often linked to bios. (acpi etc)
> sorry for my bad english, i'm french ...
> 
> so i have also a via artigo a1150 (vx900 vga and hdmi) and via epia (vx900
> vga and hdmi)
> 
> I will test the openchrome code on this hardware
Comment 17 Kevin Brace 2018-05-04 09:26:51 UTC
In case you are not sure how to apply the patch, this is how you do it.

(From xf86-video-OpenChrome root directory)
patch -p 1 < OpenChrome_DDX_Version_0_6_174_Samsung_NC20_FP_Fix.patch

Then compile and install the DDX.
Comment 18 sebastien 2018-05-04 10:37:26 UTC
ok so i have apply your patch
autogen + make + make install + reboot

after reboot : 

fp only working
fp + vga working

standbye resume working for fp only 
standbye resume doesn't working for vga + flat panel (vga working, but flat panel are graphic error, see picture)

when vga et fp branched
i was able to shutdown vga, but impossible to restart vga screen

when only flat panel working
i have branched vga screen but its doesn't working 

hotplug vga dont working
Comment 19 sebastien 2018-05-04 10:38:04 UTC
Created attachment 139343 [details]
picture after standbye vga + fp
Comment 20 sebastien 2018-05-04 12:31:54 UTC
when i boot with vga and flat panel 
i was also able to disable flat panel, but impossible after to restart flat panel
Comment 21 Kevin Brace 2018-05-05 01:18:14 UTC
sebastien, currently there is no support for VX900 chipset HDMI within OpenChrome DDX UMS (User Mode Setting).
It might happen eventually, but certainly not for OpenChrome DDX Version 0.7 release.
VGA for VX900 chipset works since I have tested it with ECS VX900-I mainboard.


(In reply to sebastien from comment #14)
> ok thanks for your work, i joint lspci dump log 
> Its a pity to add special code for my netbook. 
> but yes, bug under linux are often linked to bios. (acpi etc)
> sorry for my bad english, i'm french ...
> 
> so i have also a via artigo a1150 (vx900 vga and hdmi) and via epia (vx900
> vga and hdmi)
> 
> I will test the openchrome code on this hardware
Comment 22 Kevin Brace 2018-05-05 01:32:08 UTC
sebastien, while the patch is not perfect, I will commit the code into the upstream repository since it improves the situation on your end.
The following message will be added to the commit.

Tested-by: sebastien <lacsebastien@gmail.com>

If you want to alter it, let me know.
We will continue to analyze the problem since the displays are not working 100% correctly at this point.
Comment 23 Kevin Brace 2018-05-05 01:43:05 UTC
It appears that when the FP is assigned to IGA2, standby is not working well.
What we can do is to do the same register dump with FP + VGA configuration for before and after standby.

> when vga et fp branched

What do you mean by the above sentence?


(In reply to sebastien from comment #18)
> ok so i have apply your patch
> autogen + make + make install + reboot
> 
> after reboot : 
> 
> fp only working
> fp + vga working
> 
> standbye resume working for fp only 
> standbye resume doesn't working for vga + flat panel (vga working, but flat
> panel are graphic error, see picture)
> 
> when vga et fp branched
> i was able to shutdown vga, but impossible to restart vga screen
> 
> when only flat panel working
> i have branched vga screen but its doesn't working 
> 
> hotplug vga dont working
Comment 24 sebastien 2018-05-05 07:24:09 UTC
when fp and vga screens are plugged.



yes I know for the outputs hdmi, but I wanted to say that I will be able to test this when the hdmi code will be done
Comment 25 sebastien 2018-05-05 19:07:12 UTC
hmm, I have retest suspend/resume
its appear suspend/resume not working with flat panel only
Comment 26 Kevin Brace 2018-05-06 01:47:07 UTC
sebastien, can you reply to Comment #22?

https://bugs.freedesktop.org/show_bug.cgi?id=106326#c22

Also, I will like to have before and after register dump for FP + VGA configuration.
Comment 27 sebastien 2018-05-06 09:35:25 UTC
Created attachment 139388 [details]
before standbye 2 dump
Comment 28 sebastien 2018-05-06 09:36:15 UTC
Created attachment 139389 [details]
dump after boot, standbye don't working
Comment 29 sebastien 2018-05-06 09:39:21 UTC
standbye/resume don't working with vga and flat panel or with flat panel only.
I was wrong, my netbook was not really on standbye and I had to reboot computer.
i joint dump before and reboot after suspend failed
Comment 30 sebastien 2018-05-06 09:39:45 UTC
yeah its ok for comment 22
Comment 31 Kevin Brace 2018-05-13 02:27:50 UTC
sebastien, a lot of my time got taken for various time consuming tasks this week (the week of May 6th, 2018).
For example,I had to replace my main development computer's (HP 2133 mini-note) SSD which just died after one year of use.
I will have limited time to work on OpenChrome for the week of May 13th, 2018, but I will still try to make some progress.
I upgraded the OpenChrome DDX version to 0.6.175.
It contains the initial fix for Samsung NC20 netbook, so you do not need the patch anymore if you pull, compile, and install the latest
Since I do not have the actual hardware in front of me, I will need to rely on you to fix issues.
Let's start with turming FP or VGA via Display settings of Xubuntu.
Can you turn FP on / off reliability via Display settings?
Please attach these register dumps.

- Before turning off the FP
- After turning off the FP
- After turning on the FP

You will likely need to have VGA running all the time.
I will also need to have the associated Xorg.0.log.


(In reply to sebastien from comment #30)
> yeah its ok for comment 22
Comment 32 sebastien 2018-05-13 07:57:28 UTC
Created attachment 139539 [details]
before turning off
Comment 33 sebastien 2018-05-13 07:58:05 UTC
Created attachment 139540 [details]
after turning_off
Comment 34 sebastien 2018-05-13 07:58:36 UTC
Created attachment 139541 [details]
After turning on
Comment 35 sebastien 2018-05-13 07:59:54 UTC
Created attachment 139542 [details]
Xorg.0.log
Comment 36 sebastien 2018-05-13 08:00:26 UTC
ok i join log
Comment 37 Kevin Brace 2018-05-14 08:42:17 UTC
Okay, I compared the register dump and I did not see any issues when comparing before FP off versus after FP on.
The right registers are being turned on, I think.
Are you able to turn FP on / off from Display setting of Xubuntu?
For now, I am not talking about standby resume; just merely turn FP on and off via Display setting while VGA is connected so that you still have one screen to normally control the computer.


(In reply to sebastien from comment #20)
> when i boot with vga and flat panel 
> i was also able to disable flat panel, but impossible after to restart flat
> panel
Comment 38 sebastien 2018-05-14 10:21:36 UTC
yes, i was able to disable and enable the flat panel in dual screen mode.

suspend/resume don't work
Comment 39 sebastien 2018-05-14 10:22:37 UTC
ho, and hotplug vga working
Comment 40 Kevin Brace 2018-05-14 14:06:54 UTC
Okay, that's good that at least the basic functionality is working.
Regarding standby, after you resume the computer, is the computer still running?
There are models where the computer completely locks up.
You can tell this by pressing Caps Lock or Number Lock to see if the LED toggles.
If the LED toggles, then the computer is still running.
What you can do is you can ssh into the computer to collect the register dump data.
To be honest, I do not know how to do this.
The lazy method I use to collect the register dump data by copying via_reg_tool to /home/("Your user name"), and run via_reg_tool from there.
If the screen is dead after resume but the computer is running, you can switch to the VT (Virtual Terminal) by pressing Alt + F1, enter your user name and password, then run via_reg_tool.
In this case, you will have to enter it by the keyboard while the screen is dead, so it is a little hard to pull this off.
If VGA is alive then you life is much easier since you have that screen to collect the register dump data.
The data I want here is the before and after standby resume register dump data.
I already have the before standby data, so all you need to collect is the after standby data.


(In reply to sebastien from comment #38)
> yes, i was able to disable and enable the flat panel in dual screen mode.
> 
> suspend/resume don't work
Comment 41 Kevin Brace 2018-05-14 14:11:38 UTC
If the VGA hotplugging is not working, this might be because I changed the detection method between OpenChrome DDX Version 0.6 (0.6.0) and 0.6.175.
Does it happen occasionally?
If this is the case, then you are being affected by the code change.
I might change the code to go back to the original detection method.


(In reply to sebastien from comment #39)
> ho, and hotplug vga working
Comment 42 sebastien 2018-05-14 15:39:34 UTC
VGA hotplugging work.

my netbook standbye correctly but the screen don't resume after, it is dead.
the netbook working because i was able to pressing caps lock and the led working.

so, I press ctrl+f1/2/3/4/6, and the screen still dead but ctrl+f7 work and display a lock up screen of xubuntu, but touchpad or keyboard not working.

i search a way for collect dump log...
Comment 43 Kevin Brace 2018-05-14 16:06:18 UTC
sebastien, can you activate VGA and FP, then enter standby?
I assume you are doing this, but if you are just merely hooking up VGA after resume, I will assume nothing will display since it was disconnected prior to entering standby.
Unfortunately, there is no support for automatic hotplugging modesetting, and I wish I can implement this (some of the newer VIA hardware might be capable of this, but only OpenChrome DRM has the interrupt support needed to support this).
    Regarding VT after resume, OpenChrome DDX does not really have the code to reinitialize VT screen at this point.
When the computer enters standby, all the relevant registers lose their values, hence the blank screen.
GUI desktop is not affected since it has the code to reinitialize all the relevant registers (Of course, I am not doing something right, so your Samsung NC20's FP is not currently working after resume.).
If there is a way to reinitialize VT screen's display engine (CRTC is the more traditional term), then I will like to implement this eventually.
OpenChrome DRM has the fix implemented for this issue (KMS has built-in VT screen support.), but it won't be available for a while.


(In reply to sebastien from comment #42)
> VGA hotplugging work.
> 
> my netbook standbye correctly but the screen don't resume after, it is dead.
> the netbook working because i was able to pressing caps lock and the led
> working.
> 
> so, I press ctrl+f1/2/3/4/6, and the screen still dead but ctrl+f7 work and
> display a lock up screen of xubuntu, but touchpad or keyboard not working.
> 
> i search a way for collect dump log...
Comment 44 Kevin Brace 2018-05-14 16:10:18 UTC
Is VGA totally dead after resume when you have VGA + FP running prior to entering standby?
This attachment shows that VGA is working whereas FP is severely distorted.

https://bugs.freedesktop.org/attachment.cgi?id=139343
(attachment #7 [details] [review])
Comment 45 Kevin Brace 2018-05-14 16:13:16 UTC
Regarding Comment #44, just click the direct link.

https://bugs.freedesktop.org/attachment.cgi?id=139343
Comment 46 sebastien 2018-05-14 16:20:50 UTC
i was able to collect dump log after standbye via ssh
i join log
Comment 47 sebastien 2018-05-14 16:21:25 UTC
Created attachment 139559 [details]
dump log by ssh after standbye
Comment 48 sebastien 2018-05-14 16:38:40 UTC
(In reply to Kevin Brace from comment #45)
> Regarding Comment #44, just click the direct link.
> 
> https://bugs.freedesktop.org/attachment.cgi?id=139343

yes but now it display black screen; xubuntu update cause ?
Comment 49 Kevin Brace 2018-05-14 20:25:21 UTC
Are you saying that VGA is also dead?
I am wondering how you got that screen capture picture since it appears to be somewhat similar to the screen of you FP in the picture.

https://lists.freedesktop.org/archives/openchrome-devel/2017-March/003236.html
https://lists.freedesktop.org/archives/openchrome-devel/attachments/20170312/de3ef29d/attachment-0002.jpg

sebastien, you mentioned that the computer was not entering standby, but the picture you uploaded appears to be very similar to the above poster's (Thomas Schlichter) picture.


(In reply to sebastien from comment #48)
> 
> yes but now it display black screen; xubuntu update cause ?
Comment 50 Kevin Brace 2018-05-14 20:50:58 UTC
You might have gotten hit by the VGA connector detection problem.
Can you try a few more times?
Some of them might work differently.
When you get the blank screen, if you grab the Xorg.0.log.old during the next boot, that will be Xorg.0.log from the previous boot.
If this happens, go ahead and upload the Xorg.0.log.old.
The log will indicate whether or not VGA connector detection succeeded or not somewhere in the log.


(In reply to sebastien from comment #48)
>
> yes but now it display black screen; xubuntu update cause ?
Comment 51 sebastien 2018-05-17 13:31:03 UTC
(In reply to Kevin Brace from comment #49)
> Are you saying that VGA is also dead?
> I am wondering how you got that screen capture picture since it appears to
> be somewhat similar to the screen of you FP in the picture.
> 
> https://lists.freedesktop.org/archives/openchrome-devel/2017-March/003236.
> html
> https://lists.freedesktop.org/archives/openchrome-devel/attachments/20170312/
> de3ef29d/attachment-0002.jpg
> 
> sebastien, you mentioned that the computer was not entering standby, but the
> picture you uploaded appears to be very similar to the above poster's
> (Thomas Schlichter) picture.
> 
> 
> (In reply to sebastien from comment #48)
> > 
> > yes but now it display black screen; xubuntu update cause ?
HI
sorry for time, I can not tell you what is happening in English... so I made a video dropbox.
Can I give you a link by email?
Comment 52 Kevin Brace 2018-05-17 19:05:54 UTC
Due to various activities unrelated to OpenChrome development, I will not have time until Saturday or Sunday to spend time on OpenChrome, but go ahead and send me the e-mail.


(In reply to sebastien from comment #51)
> (In reply to Kevin Brace from comment #49)
> > Are you saying that VGA is also dead?
> > I am wondering how you got that screen capture picture since it appears to
> > be somewhat similar to the screen of you FP in the picture.
> > 
> > https://lists.freedesktop.org/archives/openchrome-devel/2017-March/003236.
> > html
> > https://lists.freedesktop.org/archives/openchrome-devel/attachments/20170312/
> > de3ef29d/attachment-0002.jpg
> > 
> > sebastien, you mentioned that the computer was not entering standby, but the
> > picture you uploaded appears to be very similar to the above poster's
> > (Thomas Schlichter) picture.
> > 
> > 
> > (In reply to sebastien from comment #48)
> > > 
> > > yes but now it display black screen; xubuntu update cause ?
> HI
> sorry for time, I can not tell you what is happening in English... so I made
> a video dropbox.
> Can I give you a link by email?
Comment 53 Kevin Brace 2018-05-25 21:04:41 UTC
Unrelated, but I recently finished adding VT1632(A) DVI transmitter support to OpenChrome DRM.
As a result, I have more time to deal with your issue.
Comment 54 sebastien 2018-05-26 06:42:34 UTC
ok, did you see the video?
Comment 55 Kevin Brace 2018-05-26 09:27:19 UTC
What video?
I did not receive a link for it.


(In reply to sebastien from comment #54)
> ok, did you see the video?
Comment 56 sebastien 2018-05-26 10:34:58 UTC
your email is kevinbrace gmx.com ?
Comment 57 Kevin Brace 2018-05-26 11:37:02 UTC
Yes.


(In reply to sebastien from comment #56)
> your email is kevinbrace gmx.com ?
Comment 58 sebastien 2018-05-30 17:24:17 UTC
I wanted to share the video on dropbox but it does not work with your email.
so I put it on youtube.
https://youtu.be/XdMRUgU3SKU
Comment 59 Kevin Brace 2018-05-31 16:57:10 UTC
Created attachment 139892 [details] [review]
VX800 chipset standby resume fix to try 1

The patch was tested on VIA EPIA-M830 mainboard.
Comment 60 Kevin Brace 2018-05-31 17:09:39 UTC
sebastien, I saw the video.
It has been known to me for about a year that VIA EPIA-M830 mainboard (VX800 chipset) has a standby resume issue, but I did not know what to do about it.
What happens is that the screen becomes totally corrupted after standby resume.
This affects even VGA.
I spent about 4 to 5 hours yesterday analyzing what was going on, and finally found the registers that were getting corrupted when the computer comes out of standby resume.
There were registers I did not really think about them, hence, I did not know how important they were to VX800 chipset.
The interesting thing is that these registers do exist with VX855 and VX900 chipsets, but for the models I tested (Wyse Cx0 thin client and ECS VX900-I mainboard), they do not get corrupted after exiting standby resume.
Apply the patch to Version 0.6.175.
I hope it improves your standby resume situation.


(In reply to sebastien from comment #58)
> I wanted to share the video on dropbox but it does not work with your email.
> so I put it on youtube.
> https://youtu.be/XdMRUgU3SKU
Comment 61 sebastien 2018-06-02 08:18:20 UTC
I try the patch, but no it doesn't working :(
Comment 62 sebastien 2018-06-02 08:19:13 UTC
it's the same as before
Comment 63 Kevin Brace 2018-06-02 15:26:58 UTC
I am starting to think this bug as "not our bug."
Since your computer appears to lose complete control (i.e., keyboard capslock not toggling), maybe some other device driver is locking up the system.
You can try to remove LAN and WLAN before standby.

$ sudo rmmod ath5k
$ sudo rmmod sky2
(Enter standby)
(Leave standby)
$ sudo modprobe sky2
$ sudo modprobe ath5k

I have seen VIA Velocity LAN device driver interfering with standby resume in the course of testing OpenChrome DRM.
Furthermore, Thomas Schlichter reported the same bug, but did not appear to indicate a complete lockup (merely corrupted screen).
He used Kubuntu 16.10 (Linux 4.8).
If you can, you may want to install Xubuntu 16.04 in another partition, install the compiled latest OpenChrome DDX (possibly with appropriate patches), and test standby resume.




(In reply to sebastien from comment #62)
> it's the same as before
Comment 64 sebastien 2018-06-02 16:04:39 UTC
hmm, i have disabled network with your command, same, the suspend/resume don't working.

BUT, it seems that my netbook has another behavior when it is on battery.
I have to make a video, it will be better ...
I said that I did the test without vga plugged there
Comment 65 sebastien 2018-06-16 15:41:08 UTC
ok, i did not make any video, but i kept looking for where the problem might come from.
I disable in the bios the option "resume on usb device" and now the netbook seems to suspend correctly.
when I press the power button to wake up, I see the led of the wifi turned on, the key lock maj works again, but the screen stay black ....

but when I press ctrl + alt + f7, the screen turns on and shows me the lock screen but I have no access to it (the mouse or the keyboard does not work) so I have to reboot .

I also tried disabling wifi and ethernet, it does not change anything.

(I did the test without the second vga screen)

(ctrl + alt + f1/2/3 etc does not working, just f7)
Comment 66 sebastien 2018-06-24 09:20:10 UTC
hm, today i use command:

sudo pm-suspend (with pm-utils) for suspend/resume and ..... its WORKING 

so actually the problem comes from xubuntu 18.04 and I think mostly of systemD.

I have to try again with the connected vga screen
Comment 67 Kevin Brace 2018-06-25 22:16:53 UTC
I am glad there is a workaround.
More questions.

1) Is the working standby resume with the patch applied?

2) Does the working standby resume method work without the patch?

3) Using the working standby resume method, are you able to resume from standby more than once?

4) Is the FP and VGA also working after standby resume?


I will also like to obtain register dump data for the before and after standby resume.


(In reply to sebastien from comment #66)
> hm, today i use command:
> 
> sudo pm-suspend (with pm-utils) for suspend/resume and ..... its WORKING 
> 
> so actually the problem comes from xubuntu 18.04 and I think mostly of
> systemD.
> 
> I have to try again with the connected vga screen
Comment 68 Kevin Brace 2018-06-25 22:21:26 UTC
The reason Ctrl + Alt + F1 etc. is not working is due to the VGA registers not getting restored after standby resume.
At this point, OpenChrome DDX does not have the code to properly restore VGA registers for VT.
OpenChrome DRM with KMS will resolve this when it is mainlined.



(In reply to sebastien from comment #65)
> ok, i did not make any video, but i kept looking for where the problem might
> come from.
> I disable in the bios the option "resume on usb device" and now the netbook
> seems to suspend correctly.
> when I press the power button to wake up, I see the led of the wifi turned
> on, the key lock maj works again, but the screen stay black ....
> 
> but when I press ctrl + alt + f7, the screen turns on and shows me the lock
> screen but I have no access to it (the mouse or the keyboard does not work)
> so I have to reboot .
> 
> I also tried disabling wifi and ethernet, it does not change anything.
> 
> (I did the test without the second vga screen)
> 
> (ctrl + alt + f1/2/3 etc does not working, just f7)
Comment 69 sebastien 2018-06-30 18:53:05 UTC
ok 

1) yes
2) yes
3) yes i try three time
4) yes fp and vga working (clone mode)

i join reg dump
Comment 70 sebastien 2018-06-30 18:55:26 UTC
Created attachment 140404 [details]
dump via reg before standbye (without patch)

via reg dump before without your patch
Comment 71 sebastien 2018-06-30 18:56:20 UTC
Created attachment 140405 [details]
dump via reg after standbye (without patch)

dump via reg after standbye without your patch
Comment 72 Kevin Brace 2018-07-01 23:47:12 UTC
Okay, I did a register dump comparison, and everything looks good.
sebastien, do you think the bug here was Xubuntu 18.04's standby entry script's bug and not OpenChrome DDX's fault?
If you think so, you may want to contact Canonical and / or Xubuntu developers to let them know that standby works via pm-suspend but not through Start Menu's Log Out button.
You can close the bug if you want to.
The patch itself will be committed with some enhancements since VIA EPIA-M830 mainboard needs the fix for standby resume to have a chance to work.
Comment 73 sebastien 2018-07-02 07:23:15 UTC
I think Canonical is already aware of the problem
I saw the solution on the ubuntu wiki
https://doc.ubuntu-fr.org/veille_et_hibernation#mise_en_veille  (3.3.9)

others on the Ubuntu-Fr forum also have standby issues on 18.04
for me it's more of a problem of SystemD

and we will have to wait for evolutions of SystemD to see if it corrects the problem
Comment 74 sebastien 2018-11-22 15:01:02 UTC
I have update openchrome git on my samsung nc20/xubuntu 18.10

suspend/resume working

thanks :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.