Bug 10662 - Кeyboard layout change on hotkeys press instead of release, inconsistency with app's shortcuts
Summary: Кeyboard layout change on hotkeys press instead of release, inconsistency wit...
Status: RESOLVED DUPLICATE of bug 865
Alias: None
Product: xorg
Classification: Unclassified
Component: * Other (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-17 07:48 UTC by Sergey Sinitsa
Modified: 2007-04-17 08:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Sinitsa 2007-04-17 07:48:28 UTC
I have Ctrl+Shift set to layout switch and press ctrl+shift+N (to open new Terminal or new tab in Opera) -- as a result I have my keyboard layout switched. This happens because Ubuntu (or XOrg?) change layout on key press instead of release and do not match layout hotkeys with application shortcuts. MS Windows do. If layout change hotkeys is pressed with another key this must be treated as application shortcut and layout must not be changed.

I've added this bug report about about a year ago to Ubuntu bugtrack:
https://bugs.launchpad.net/ubuntu/+source/control-center/+bug/36812

Now it  was commented by Gnome developer that "that's the way X
works".
Comment 1 Daniel Stone 2007-04-17 08:25:24 UTC

*** This bug has been marked as a duplicate of bug 865 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.