Bug 106724 - [CI] igt@kms_flip@*flip* - fail - Failed assertion: fabs((elapsed - expected) / expected) <= 0.005
Summary: [CI] igt@kms_flip@*flip* - fail - Failed assertion: fabs((elapsed - expected)...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-30 13:10 UTC by Martin Peres
Modified: 2019-04-23 14:00 UTC (History)
1 user (show)

See Also:
i915 platform: GLK, ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-05-30 13:10:11 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_flip@flip-vs-absolute-wf_vblank.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_flip@plain-flip-ts-check-interruptible.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_flip@plain-flip-fb-recreate-interruptible.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_flip@plain-flip-ts-check.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_53/fi-glk-j4005/igt@kms_flip@plain-flip-fb-recreate.html

(kms_flip:2633) CRITICAL: Test assertion failure function check_state, file ../tests/kms_flip.c:530:
(kms_flip:2633) CRITICAL: Failed assertion: fabs((elapsed - expected) / expected) <= 0.005
(kms_flip:2633) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_flip:2633) CRITICAL: inconsistent flip ts/seq: last 300.493953/7533, current 300.591026/7537: elapsed=97073.0us expected=66670.5us
Subtest plain-flip-fb-recreate failed.
Comment 1 Martin Peres 2018-05-30 13:10:53 UTC
This seems to be a regression introduced in drmtip_53, bumping the priority. See also https://bugs.freedesktop.org/show_bug.cgi?id=106723
Comment 2 Martin Peres 2018-05-31 09:25:40 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4262/fi-glk-j4005/igt@kms_flip@basic-flip-vs-wf_vblank.html

(kms_flip:3486) CRITICAL: Test assertion failure function check_state, file ../tests/kms_flip.c:530:
(kms_flip:3486) CRITICAL: Failed assertion: fabs((elapsed - expected) / expected) <= 0.005
(kms_flip:3486) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_flip:3486) CRITICAL: inconsistent flip ts/seq: last 405.138609/757, current 405.348146/769: elapsed=209537.0us expected=200009.2us
Subtest basic-flip-vs-wf_vblank failed.
Comment 3 Martin Peres 2018-06-05 07:38:10 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_56/fi-glk-j4005/igt@kms_flip@flip-vs-absolute-wf_vblank-interruptible.html

(kms_flip:1451) CRITICAL: Test assertion failure function check_state, file ../tests/kms_flip.c:530:
(kms_flip:1451) CRITICAL: Failed assertion: fabs((elapsed - expected) / expected) <= 0.005
(kms_flip:1451) CRITICAL: Last errno: 4, Interrupted system call
(kms_flip:1451) CRITICAL: inconsistent flip ts/seq: last 370.659160/6855, current 370.868326/6867: elapsed=209166.0us expected=200013.0us
Subtest flip-vs-absolute-wf_vblank-interruptible failed.
Comment 4 Lakshmi 2018-09-05 18:53:29 UTC
This issue wasn't seen since 1 month 1 week. Before that it used to fail very frequently. Looking at the history, this issue needs to be kept under observation at least for the next 1 month.
Comment 5 CI Bug Log 2019-01-10 11:05:34 UTC
A CI Bug Log filter associated to this bug has been updated:

{- GLK: igt@kms_flip@*flip* - fail - Failed assertion: fabs((elapsed - expected) / expected) &lt;= 0.005 -}
{+ GLK ICL: igt@kms_flip@*flip* - fail - Failed assertion: fabs((elapsed - expected) / expected) &lt;= 0.005 +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5386/shard-iclb3/igt@kms_flip@flip-vs-absolute-wf_vblank.html
* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5386/shard-iclb3/igt@kms_flip@plain-flip-fb-recreate.html
Comment 6 Lakshmi 2019-03-29 13:14:40 UTC
CI_DRM_5386_full (2 months, 2 weeks / 1511 runs ago). Dropping priority to Medium.
Comment 7 Jani Saarinen 2019-04-22 14:05:10 UTC
From Mika:
The test expects that we flip in a certain time frame. For yet unknown reasons, the flip may take longer than we anticipate. I suspect that user doesn't realize if flip took one or two milliseconds more time. Maybe we could relax a requirement a bit?
Comment 8 Jani Saarinen 2019-04-22 14:06:03 UTC
Now last seen 3 months ago, close?
Comment 9 Martin Peres 2019-04-23 14:00:34 UTC
(In reply to Jani Saarinen from comment #8)
> Now last seen 3 months ago, close?

Used to happen every other run in average, now not seen since drmtip_135 (128 runs ago). It however was seen once on ICL, 3 months ago. Closing now!
Comment 10 CI Bug Log 2019-04-23 14:00:45 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.