Bug 106958 - Mass Effect Andromeda renders correctly on RX480 POLARIS but BAD ON RX VEGA 64 on wine 3.10 stagingf with DXVK
Summary: Mass Effect Andromeda renders correctly on RX480 POLARIS but BAD ON RX VEGA 6...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-19 04:38 UTC by Giovanni ongaro
Modified: 2018-12-05 08:45 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
LOG of DXVK (2.84 MB, text/plain)
2018-06-19 04:38 UTC, Giovanni ongaro
Details
wine log (2.84 MB, text/plain)
2018-06-19 04:38 UTC, Giovanni ongaro
Details
pic of rx480 (2.20 MB, image/png)
2018-06-19 04:39 UTC, Giovanni ongaro
Details
pic ov vega with bad rendering issue (2.11 MB, image/png)
2018-06-19 04:40 UTC, Giovanni ongaro
Details
Screenshot with glitch (605.96 KB, image/png)
2018-12-04 16:14 UTC, egon2003
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giovanni ongaro 2018-06-19 04:38:14 UTC
Created attachment 140213 [details]
LOG of DXVK

Hi i have little information on this i can only send the winelog and DXVK logs and two pictures but mass effect andromeda seems to render bad on wine 3.10 with dxvk
Comment 1 Giovanni ongaro 2018-06-19 04:38:56 UTC
Created attachment 140214 [details]
wine log
Comment 2 Giovanni ongaro 2018-06-19 04:39:26 UTC
Created attachment 140215 [details]
pic of rx480
Comment 3 Giovanni ongaro 2018-06-19 04:40:10 UTC
Created attachment 140216 [details]
pic ov vega with bad rendering issue
Comment 4 Samuel Pitoiset 2018-06-19 10:23:23 UTC
Can you capture a trace with renderdoc?
Comment 5 Giovanni ongaro 2018-06-19 12:47:41 UTC
can you tell me the renderdoc command with options and arguments i am not so familiar with renderdoc
Comment 6 Samuel Pitoiset 2018-06-19 13:13:47 UTC
Launch the game with "export ENABLE_VULKAN_RENDERDOC_CAPTURE=1" and press F12 to record a trace.
Comment 7 Giovanni ongaro 2018-06-22 23:52:26 UTC
could not start the trace with f12 but i managed to get an apitrace under win7 and rx480 i wonder if this could be useful
Comment 8 Samuel Pitoiset 2018-06-25 08:41:57 UTC
Don't you see the renderdoc overlay?
Comment 9 Samuel Pitoiset 2018-07-05 17:03:45 UTC
Can you try this patch https://patchwork.freedesktop.org/series/46024/ please?

I'm not really not sure if that will fix your issue (I still don't have a renderdoc capture).
Comment 10 Giovanni ongaro 2018-07-20 15:41:31 UTC
it did not fix the issue but i managed to get an apitrace can the apitrace be useful?
Comment 11 Samuel Pitoiset 2018-07-20 15:44:14 UTC
Yeah, that patch can't fix the problem because DXVK doesn't use multiviews.

The apitrace doesn't replay correctly on my vega, it crashes at some point and I can't see the rendering problem.

Can you try to use renderdoc instead?
Comment 12 egon2003 2018-11-17 13:58:40 UTC
I have the same problem on my Vega 64. Mesa 18.3.0-rc3

I made an apitrace in Windows but I'm not sure if it works since I dont know how to replay it.
When I try to replay it in Linux I get error: failed to execute: d3dretrace.exe

Please let me know if the trace does not work and how I could provide a working trace.

https://www.dropbox.com/s/jf8m9banx2nufxo/MassEffectAndromeda.7z?dl=0
Comment 13 egon2003 2018-11-17 14:58:06 UTC
Realized I had to run it under wine but wine crashes for me before i reach where the glitches are.
Comment 14 Samuel Pitoiset 2018-11-27 08:43:30 UTC
The trace crashes for me as well. Can you record a renderdoc capture instead? I don't have that game, so can't do anything.
Comment 15 egon2003 2018-12-01 16:40:52 UTC
I have been trying to record a trace with renderdoc but I have been unsuccessful. Im not sure if I am doing something wrong or if it just does not work.

I have also been trying to get a new apitrace but I cant get it to work at all now unfortunately. I get a tracefile but I cant replay it. I could provide you with a key for the game if you want to take a look.
Comment 16 Samuel Pitoiset 2018-12-03 22:06:52 UTC
Yes, if you have a key please send me one to my personal email.
Comment 17 Samuel Pitoiset 2018-12-04 09:35:11 UTC
What mesa version are you using? Can you try with latest master? I wonder if https://cgit.freedesktop.org/mesa/mesa/commit/?id=08ea6b9d9bb047603c249468dfe00d7bb9603d5e has fixed the problem.

According to this video https://www.youtube.com/watch?v=K-BeOyJ6QeE , the game seems to work fine now.

Thanks!
Comment 18 egon2003 2018-12-04 10:02:40 UTC
I am using Mesa 18.3.0-rc5.

I will update Mesa to git master later today and report back.
Comment 19 Samuel Pitoiset 2018-12-04 10:10:34 UTC
18.3.0-rc5 contains that fix, hmm. The problem probably still persists with mesa master.
Comment 20 Samuel Pitoiset 2018-12-04 13:16:05 UTC
It took me a while but I installed the game. How do I reproduce the problem now?
Comment 21 egon2003 2018-12-04 16:00:33 UTC
Great!

I see the issue the first time I get control in the game after starting a new game when looking at certain objects. In the starting scene there is a doctor t perro and the head of the character i just a big white aura.
Comment 22 egon2003 2018-12-04 16:13:47 UTC
I forgot i had played a few minutes. When you start a new game the first time you get an option to choose something I see the issue the first time. See attached screenshot.
Comment 23 egon2003 2018-12-04 16:14:37 UTC
Created attachment 142721 [details]
Screenshot with glitch
Comment 24 Samuel Pitoiset 2018-12-04 16:54:24 UTC
Can't be reproduced on my side, what llvm are you using?
Comment 25 Samuel Pitoiset 2018-12-04 17:07:58 UTC
This is with mesa 18.2.5 and LLVM 7.0.1 on Vega 56.
Comment 26 egon2003 2018-12-04 21:36:28 UTC
I just tried it with LLVM and Mesa from git and the glitch is gone.

However I see the glitch with Mesa 18.2.5 compiled against LLVM 7.0.0 and LLVM 7.0.1. The glitch is also there with Mesa 18.3.0-rc5 and LLVM 7.0.0 and LLVM 7.0.1.

Thanks for looking into this.
Comment 27 Samuel Pitoiset 2018-12-05 08:45:06 UTC
Yes, I can confirm this too.

The issue has probably been fixed somewhere in LLVM 8 (master).

Thanks for being so responsive.

Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.