Bug 107175 - [CI][SKL][IOMMU] i915: probe of 0000:00:02.0 failed with error -25
Summary: [CI][SKL][IOMMU] i915: probe of 0000:00:02.0 failed with error -25
Status: CLOSED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: IGT (show other bugs)
Version: DRI git
Hardware: Other All
: lowest trivial
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-10 07:39 UTC by Tomi Sarvela
Modified: 2018-08-22 13:39 UTC (History)
1 user (show)

See Also:
i915 platform: SKL
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomi Sarvela 2018-07-10 07:39:10 UTC
Continuing with the series of "Initial findings" with Intel-GFX-CI and i915 selftests.

SKL with IOMMU enabled fail the following tests with:
i915: probe of 0000:00:02.0 failed with error -25

This is supposedly a great success and expected behaviour, so the bug is just a placeholder for CI filters.
Comment 1 Chris Wilson 2018-07-10 07:42:03 UTC
Not really IGT either since piglit isn't a part of IGT...
Comment 2 Chris Wilson 2018-07-28 15:59:42 UTC
The probe fail message isn't currently being flagged as an issue (and it shouldn't be), lets hope it continues.
Comment 3 Lakshmi 2018-08-22 13:39:48 UTC
This is not a bug and works as expected.

But, igt@drv_selftest@live_guc test is failing that needs fix from guc
Dmesg:
[  510.815692] i915: unknown parameter 'enable_guc_loading' ignored
[  510.815695] i915: unknown parameter 'enable_guc_submission' ignored
[  510.815697] Setting dangerous option enable_guc - tainting kernel
[  510.815701] Setting dangerous option live_selftests - tainting kernel
[  510.853939] [drm:intel_guc_send_mmio [i915]] *ERROR* MMIO: GuC action 0x10 failed with error -5 0xf000f000

For this issue there is a separate bug filed.
https://bugs.freedesktop.org/show_bug.cgi?id=107258

Closing this as works as expected.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.