Bug 107612 - [Vega10] Hard Lock [gfxhub] VMC page fault when opening Mario Kart 8 in Cemu under wine
Summary: [Vega10] Hard Lock [gfxhub] VMC page fault when opening Mario Kart 8 in Cemu ...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
: 108720 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-18 13:29 UTC by CheatCodesOfLife
Modified: 2019-05-22 15:06 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg log mdgpu 0000:0c:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000 (2.60 KB, text/x-log)
2018-08-18 13:29 UTC, CheatCodesOfLife
Details
glxinfo |greep OpenGL (799 bytes, text/x-log)
2018-08-18 23:50 UTC, CheatCodesOfLife
Details

Note You need to log in before you can comment on or make changes to this bug.
Description CheatCodesOfLife 2018-08-18 13:29:45 UTC
Created attachment 141181 [details]
dmesg log mdgpu 0000:0c:00.0: VM_L2_PROTECTION_FAULT_STATUS:0x00000000

Given
Trying to run Mario Kart 8 in Cemu under wine with a Vega 56 or 64,

When
Opening the game (US or EUR, I have EUR, other people have tested US),

Then
The system freezes once the Mario Kart 8 splash screen shows up. Keyboard/Mouse input is gone, only ssh sessions remain open until the system is hard-rebooted. There is no other way to recover from this.

This can be reproduced every time with a Vega64 or Vega56 card. It has been an issue since at least kernel 4.15, mesa 18.0.

I have tested on 2 systems, and several people with Vega cards get this issue (works for nobody).

uname -a
Linux nihonium2 4.18.1-arch1-1-ARCH #1 SMP PREEMPT Wed Aug 15 21:11:55 UTC 2018 x86_64 GNU/Linux

I'm running antergos with mesa-git, fully up to date.
dmesg, glxinfo are attached.
Comment 1 CheatCodesOfLife 2018-08-18 23:50:03 UTC
Created attachment 141192 [details]
glxinfo |greep OpenGL

forgot to attach this last night.
Comment 2 Xalphenos 2018-10-13 08:06:22 UTC
I too have this issue on vega 8(2200g).  It may be slightly interesting that a very similar problem happens on windows.  The emulator behaves the same way freezing at the same moment while sound continues playing.  The only difference is that windows itself remains operable.  On windows all Fiji, polaris, and vega cards have had this problem at one time or another.  It was fixed for polaris cards on 18.4.1.  If I recall correctly It was fixed for fiji on 18.9.1.  I don't believe it was ever fixed for vega.  For polaris and fiji it has never been an issue on linux.
Comment 3 CheatCodesOfLife 2019-01-30 11:30:33 UTC
*** Bug 108720 has been marked as a duplicate of this bug. ***
Comment 4 bibitocarlos 2019-04-18 19:42:05 UTC
I would like to help with this bug. I get it with Raven ridge 2400G.
All you have to do is play Mariokart 8 with CEMU.
Comment 5 coraxio 2019-04-28 00:14:04 UTC
As far as I can tell, I'm having a similar problem with Pac-Man Championship DX+. AMD Ryzen 5 2400G (Vega 11), AMDGPU drivers with up-to-date Arch software. Since Pac-Man is a Windows game, I've run it through both Wine and Proton, and each results in a hard lock with VMC page fault.

In particular, I can actually launch the game. But whenever I actually start a level (which is when the graphics, simple as they are, become more intense), my system locks up either instantly or within 5 seconds.
Comment 6 CheatCodesOfLife 2019-05-19 02:35:43 UTC
I jumpped ship to nvidia months ago so this doesn't help me, but for you guys following this thread, the Cemu developers managed to fix this issue. If you install the latest public release of Cemu, it will work with Vega + mesa under wine.

The latest mesa build also fixes the BOTW texture problem.

So latest Cemu + latest mesa works perfectly with Vega cards now.
Comment 7 bibitocarlos 2019-05-22 15:06:27 UTC
Yeah, it's fixed.
thanks


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.