Bug 107706 - [GEN8+] up to 10% perf drop on several 3D benchmarks
Summary: [GEN8+] up to 10% perf drop on several 3D benchmarks
Status: RESOLVED DUPLICATE of bug 107510
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-28 09:27 UTC by Eero Tamminen
Modified: 2018-10-24 07:26 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eero Tamminen 2018-08-28 09:27:04 UTC
There's up to 10% performance drop on *all* GEN8+ platforms, exactly same as in bug 107510.

On SKL GT2, the regressions are following:
- 10% GfxBench Tessellation (onscreen & offscreen)
- 5% SynMark2 GSCloth
- 2-3% GpuTest Julia FP64
- 1-2% Unigine Heaven (high quality with tessellation, no AA)
- 1% GfxBench ALU2 (onscreen & offscreen), SynMark PSPom

On other GEN8+ platforms the regressing cases are the same, but percentages differ somewhat.  Performance didn't improve in any test.

Setup:
- Mesa from git
- drm-tip kernel and X server git versions within couple of months
- Modifier support enabled (shouldn't matter as offscreen versions also regress)

Regressions happen between following Mesa git versions:
* 855af9a5a2: 2018-08-23 16:00:28 "travis: use python3 for the autoconf builds"
* 7f745c19c1: 2018-08-24 16:35:24 "docs: Update calendar, news, relnotes for 18.1.7"

(Jason's array splitting commits seems most likely thing affecting these.)
Comment 1 Mark Janes 2018-08-31 17:00:16 UTC
*** Bug 107743 has been marked as a duplicate of this bug. ***
Comment 2 Mark Janes 2018-08-31 17:00:40 UTC
8d8222461f9d7f497d657c2c0eff70820986429b is the first bad commit
commit 8d8222461f9d7f497d657c2c0eff70820986429b
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Mon Jul 23 22:20:41 2018 -0700
    intel/nir: Enable nir_opt_find_array_copies
Comment 3 Eero Tamminen 2018-10-04 10:52:00 UTC
Fix to bug 107223 hid this regression from few of the high FPS onscreen tests, but otherwise performance of these hasn't changed in past few months.

Is somebody working on fixing this regression?  (bug isn't assigned to anybody)
Comment 4 Jason Ekstrand 2018-10-09 18:59:22 UTC
How sure are we of that bisect?  None of the optimizations in that series affect gfxbench tessellation at all.  I'll keep digging a bit.
Comment 5 Mark Janes 2018-10-09 19:50:38 UTC
the regression is pretty clear:

http://otc-mesa-android.jf.intel.com/results/apps/gfxbench5_tess

I did bisect manually on my skl.  My recollection is that the delta was obvious at each iteration.
Comment 6 Timothy Arceri 2018-10-24 07:26:52 UTC

*** This bug has been marked as a duplicate of bug 107510 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.