Bug 107743 - GFXBench5 Tesselation benchmark: 10% perf regression
Summary: GFXBench5 Tesselation benchmark: 10% perf regression
Status: RESOLVED DUPLICATE of bug 107510
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2018-08-29 21:18 UTC by Mark Janes
Modified: 2019-01-30 13:25 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2018-08-29 21:18:58 UTC
bisect in progress between 	6027d354d1d and 	45b5f5fa25b
Comment 1 Mark Janes 2018-08-29 22:10:58 UTC
8d8222461f9d7f497d657c2c0eff70820986429b is the first bad commit
commit 8d8222461f9d7f497d657c2c0eff70820986429b
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Mon Jul 23 22:20:41 2018 -0700
    intel/nir: Enable nir_opt_find_array_copies
    
    We have to be a bit careful with this one because we want it to run in
    the optimization loop but only in the first brw_nir_optimize call.
    Later calls assume that we've lowered away copy_deref instructions and
    we don't want to introduce any more.
    
    Shader-db results on Kaby Lake:
    
        total instructions in shared programs: 15176942 -> 15176942 (0.00%)
        instructions in affected programs: 0 -> 0
        helped: 0
        HURT: 0
    
    In spite of the lack of any shader-db improvement, this patch completely
    eliminates spilling in the Batman: Arkham City tessellation shaders.
    This is because we are now able to detect that the temporary array
    created by DXVK for storing TCS inputs is a copy of the input arrays and
    use indirect URB reads instead of making a copy of 4.5 KiB of input data
    and then indirecting on it with if-ladders.
    
    Reviewed-by: Caio Marcelo de Oliveira Filho <caio.oliveira@intel.com>
Comment 2 Mark Janes 2018-08-31 17:00:16 UTC
Not sure how I missed that this was written up a bit earlier...

*** This bug has been marked as a duplicate of bug 107706 ***
Comment 3 Eero Tamminen 2019-01-30 13:25:52 UTC
Moving duplicate to a bug that's still open (Timothy closed newer and re-opened the older bug).

*** This bug has been marked as a duplicate of bug 107510 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.