Bug 107725 - [CI][DRMTIP] igt@kms_ccs@pipe-[abc]-crc-* - fail - Failed assertion: !mismatch
Summary: [CI][DRMTIP] igt@kms_ccs@pipe-[abc]-crc-* - fail - Failed assertion: !mismatch
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Dhinakaran Pandiyan
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 106510 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-28 15:34 UTC by Martin Peres
Modified: 2019-03-20 20:35 UTC (History)
2 users (show)

See Also:
i915 platform: BXT, CNL, ICL, KBL, SKL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 2 Lakshmi 2018-09-05 19:09:49 UTC
This issue happens to occur in every round of drmtip execution. Since this happens to occur only with drmtip changing the priority to medium. Priority can raised if it is seen in igt/CI DRM runs.
Comment 3 Martin Peres 2018-10-09 15:15:17 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_121/fi-whl-u/igt@kms_ccs@pipe-a-crc-primary-rotation-180.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_121/fi-bxt-dsi/igt@kms_ccs@pipe-a-crc-primary-rotation-180.html

Starting subtest: pipe-A-crc-primary-rotation-180
(kms_ccs:2233) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:392:
(kms_ccs:2233) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest pipe-A-crc-primary-rotation-180 failed.
Comment 4 Martin Peres 2018-10-30 16:26:08 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_134/fi-kbl-r/igt@kms_ccs@pipe-a-crc-primary-basic.html

Starting subtest: pipe-A-crc-primary-basic
(kms_ccs:1303) igt_debugfs-CRITICAL: Test assertion failure function igt_assert_crc_equal, file ../lib/igt_debugfs.c:419:
(kms_ccs:1303) igt_debugfs-CRITICAL: Failed assertion: !mismatch
Subtest pipe-A-crc-primary-basic failed.
Comment 5 Dhinakaran Pandiyan 2019-02-21 21:45:11 UTC
https://patchwork.freedesktop.org/series/57052/ should address ICL failures.
Comment 6 Jani Saarinen 2019-03-04 10:22:06 UTC
PW says series not complete, re-send?
Comment 7 Dhinakaran Pandiyan 2019-03-04 18:23:33 UTC
(In reply to Jani Saarinen from comment #6)
> PW says series not complete, re-send?
I had an extra patch on top, that I don't want to send quite yet.
Comment 8 Dhinakaran Pandiyan 2019-03-04 18:25:14 UTC
(In reply to Dhinakaran Pandiyan from comment #7)
> (In reply to Jani Saarinen from comment #6)
> > PW says series not complete, re-send?
> I had an extra patch on top, that I don't want to send quite yet.

Looks like I do have to re-send for CI to run the tests since there is no way to convince CI the series is indeed complete. :/
Comment 9 linawutida@web-experts.net (Spammer; Account disabled) 2019-03-06 07:55:51 UTC
BHai awaz aa rahi hay meri?
Comment 10 linawutida@web-experts.net (Spammer; Account disabled) 2019-03-06 08:00:16 UTC
Jai Hind
Comment 11 CI Bug Log 2019-03-08 15:35:10 UTC
A CI Bug Log filter associated to this bug has been updated:

{- BXT SKL KBL WHL CNL ICL: igt@kms_ccs@pipe-[abc]-crc-* - fail - Failed assertion: !mismatch -}
{+ BXT APL SKL KBL WHL CNL ICL: igt@kms_ccs@pipe-[abc]-crc-* - fail - Failed assertion: !mismatch +}

 No new failures caught with the new filter
Comment 12 Martin Peres 2019-03-08 15:35:26 UTC
*** Bug 106510 has been marked as a duplicate of this bug. ***
Comment 13 Jani Saarinen 2019-03-20 20:35:43 UTC
Fix now merged to IGT:
author	Juha-Pekka Heikkila <juhapekka.heikkila@gmail.com>
committer	Juha-Pekka Heikkila <juhapekka.heikkila@gmail.com>
commit	76a8f9cf7890969e8f2b4550600c6d3ee6913dd7


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.