Bug 107779 - Access violation with some games
Summary: Access violation with some games
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 18.1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-01 13:51 UTC by Levente Abrok
Modified: 2018-09-23 09:55 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Levente Abrok 2018-09-01 13:51:43 UTC
The Steam games Hero of the Kingdom II and III doesn't start on Ubuntu 18.04 due to access violation error with Intel cards (I have Haswell, but others also reported this). It is confirmed that this can be solved by replacing the /usr/lib/i386-linux-gnu/dri/i965_dri.so file with the one shipped in Ubuntu 16.04.
Will try to get more info if given some tips on how to do it.
Comment 1 Sergii Romantsov 2018-09-03 10:58:47 UTC
Bisected.
Requires mesa 32-bit.
Good commit is 20104f1926436e00171c8e64ca37fff9ffbd7096.

The next commit 314879f7fec07cedb5263681173a22d522a8ac9a breaks building with error "implicit declaration of function ‘__builtin_ia32_clflush’". That issue was fixed in BZ https://bugs.freedesktop.org/show_bug.cgi?id=101774 by commit 6b05c080f202c25531f59b547d5e6ba339cedd09.

Commits 314879f7fec07cedb5263681173a22d522a8ac9a + 6b05c080f202c25531f59b547d5e6ba339cedd09 fixes build but fails with:
"intel_batchbuffer.c:720: _intel_batchbuffer_flush_fence: Assertion `!brw->no_batch_wrap' failed"

Also applying of 6b05c080f202c25531f59b547d5e6ba339cedd09 to the last good commit 20104f1926436e00171c8e64ca37fff9ffbd7096 gives current issue.
So issue is combined in two commits: 6b05c080f202c25531f59b547d5e6ba339cedd09 and 314879f7fec07cedb5263681173a22d522a8ac9a
Comment 2 Sergii Romantsov 2018-09-04 10:52:51 UTC
Proposed patch: https://patchwork.freedesktop.org/patch/247065/
Levente, are you able to check it (requires clean and rebuild of mesa)?
Comment 3 Levente Abrok 2018-09-04 16:57:22 UTC
I wouldn't say I'm a newbie, but I don't have any experience in compiling Mesa for myself. I might look into it, but that will take a while.
Comment 4 Denis 2018-09-05 10:06:07 UTC
Hi, I sent instructions to your mail. They are 100% tested and valid for ubuntu 16.04

Please fill free to ask and provide your feedback
Comment 5 Levente Abrok 2018-09-08 20:09:27 UTC
With the help of Denis, I did some tests. Although I couldn't make Steam use the compiled libraries directly from the Mesa 18.3 development branch, I used the method of overwriting the i965_dri.so file with the one I compiled. It worked. So it seems that the bug was fixed somewhere along development. Before closing this report as solved, I would still like to wait some more time, just in case.
Comment 6 Juan A. Suarez 2018-09-21 10:34:10 UTC
The fix landed upstream. Please check if this fixes the issue.
Comment 7 Levente Abrok 2018-09-23 09:55:12 UTC
I tried it with padoka ppa (18.3 development version). The issue seems to be fixed, it works how it should be.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.