Bug 107956 - [CI][SHARDS] igt@kms_busy@extended_*_render-[abc] - dmesg-warn - Asynchronous wait on fence i915:kms_busy\[\d+\]/0:1 timed out \(hint:intel_atomic_commit_ready
Summary: [CI][SHARDS] igt@kms_busy@extended_*_render-[abc] - dmesg-warn - Asynchronous...
Status: CLOSED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high enhancement
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-17 07:04 UTC by Martin Peres
Modified: 2019-03-06 13:53 UTC (History)
1 user (show)

See Also:
i915 platform: BXT, GLK, HSW, KBL, SNB
i915 features: CI Infra


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-09-17 07:04:11 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl8/igt@kms_busy@extended-modeset-hang-newfb-with-reset-render-c.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl7/igt@kms_busy@extended-pageflip-modeset-hang-oldfb-render-a.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl6/igt@kms_busy@extended-pageflip-hang-newfb-render-b.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl6/igt@kms_busy@extended-modeset-hang-newfb-render-b.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl5/igt@kms_busy@extended-modeset-hang-newfb-render-a.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl5/igt@kms_busy@extended-pageflip-hang-newfb-render-a.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl5/igt@kms_busy@extended-pageflip-modeset-hang-oldfb-render-b.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl4/igt@kms_busy@extended-pageflip-hang-newfb-render-c.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl4/igt@kms_busy@extended-modeset-hang-newfb-with-reset-render-a.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl2/igt@kms_busy@extended-pageflip-modeset-hang-oldfb-render-c.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl2/igt@kms_busy@extended-modeset-hang-newfb-with-reset-render-b.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4826/shard-apl2/igt@kms_busy@extended-modeset-hang-newfb-render-c.html

[51.898780] Asynchronous wait on fence i915:kms_busy[959]/0:2 timed out (hint:intel_atomic_commit_ready+0x0/0x4c [i915])

And the same on GLK and KBL.
Comment 1 Martin Peres 2018-09-17 07:27:19 UTC
On HSW and SNB, the message is a little different:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4833/shard-snb6/igt@kms_busy@extended-modeset-hang-newfb-render-b.html

[48.567442] Asynchronous wait on fence i915:rcs0:f timed out (hint:intel_atomic_commit_ready+0x0/0x4c [i915])
Comment 2 Chris Wilson 2018-09-17 07:31:14 UTC
A bug in the test runner; it is mistaking KERN_NOTICE for a warning. I was expecting it to have been fixed.
Comment 3 Petri Latvala 2018-09-17 07:56:38 UTC
Not a bug, a feature. --piglit-style-dmesg was an explicitly requested feature and is in use in CI atm. To ween out the other differences first I suppose.

That will disappear when we can actually get to the point where we can remove that flag. Up to Tomi and Martin (?) when they can run enough test rounds to be confident pre-merge doesn't get more noisy.
Comment 5 Maarten Lankhorst 2019-02-06 17:53:49 UTC
Doing some more investigation. This is expected behavior. So the dmesg-warn in this case is invalid..
Comment 6 Jani Saarinen 2019-03-05 16:39:39 UTC
Then invalid as bug?
Comment 7 Martin Peres 2019-03-06 13:53:31 UTC
(In reply to Maarten Lankhorst from comment #5)
> Doing some more investigation. This is expected behavior. So the dmesg-warn
> in this case is invalid..

Thanks, closing as NOTABUG. I created https://bugs.freedesktop.org/show_bug.cgi?id=109921 for the IGT issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.