Bug 108608 - Blank screen after KMS with Linux 4.19.0 on Hawaii (R9 290)
Summary: Blank screen after KMS with Linux 4.19.0 on Hawaii (R9 290)
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-31 01:33 UTC by abortretryfail
Modified: 2018-12-04 13:59 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg spew (7.15 KB, text/plain)
2018-10-31 01:33 UTC, abortretryfail
no flags Details
Full dmesg output after crash (92.20 KB, text/plain)
2018-10-31 22:59 UTC, abortretryfail
no flags Details
dmesg after suspend/resume (104.09 KB, text/plain)
2018-11-05 23:33 UTC, abortretryfail
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description abortretryfail 2018-10-31 01:33:51 UTC
Created attachment 142294 [details]
dmesg spew

With radeon.cik_support=0 and amdgpu.cik_support=1, I get a blank screen on Linux 4.19.0. This worked fine on 4.18.16. Machine is still accessible via SSH, but will not shut down successfully.

Using radeon instead of amdgpu is a work-around.

By the function names I'm guessing it's UVD/PowerPlay related, but this is out of my realm of troubleshooting expertise. 

Attached dmesg snippet with traces and detailed error messages.
Comment 1 Alex Deucher 2018-10-31 15:48:50 UTC
Please attach your full dmesg output.  Can you bisect?
Comment 2 abortretryfail 2018-10-31 22:46:45 UTC
Sure. I'll see if I can turn off all this 'audit' nonsense that's filling dmesg with the names of files and users on my PC that I don't want all over the internet.

Haven't built a kernel from source in ages and never done a git bisect on one. I'll give it a try though.
Comment 3 abortretryfail 2018-10-31 22:59:15 UTC
Created attachment 142312 [details]
Full dmesg output after crash
Comment 4 Alex Deucher 2018-11-01 03:55:21 UTC
I think this patch should fix at least some of the issues:
https://patchwork.freedesktop.org/patch/259364/
Comment 5 abortretryfail 2018-11-05 23:33:31 UTC
It works! Mostly.

Everything seems to run fine until after a suspend/resume, after which i get scrambled gibberish on one monitor (DisplayPort-0) and nothing on the other two (DVI-D-0,1). 

xrandr --output DVI-D-0 --off --output DVI-D-1 --off gets things looking normal again on DisplayPort-0, but re-enabling either of those displays doesn't work and brings back the gibberish.
Comment 6 abortretryfail 2018-11-05 23:33:58 UTC
Created attachment 142377 [details]
dmesg after suspend/resume
Comment 7 abortretryfail 2018-12-04 13:59:51 UTC
I guess we might as well close this out, since it sort of works now and the display corruption is a different issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.