Bug 108671 - Massive Screen Artifacting on linux 4.19+
Summary: Massive Screen Artifacting on linux 4.19+
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-06 03:52 UTC by coolo1mc
Modified: 2018-12-11 07:16 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
photo of artifact (3.63 MB, image/jpeg)
2018-11-06 03:58 UTC, coolo1mc
no flags Details
dmesg (86.80 KB, text/plain)
2018-11-14 11:58 UTC, coolo1mc
no flags Details
xorg log (140.27 KB, text/plain)
2018-11-14 11:59 UTC, coolo1mc
no flags Details
photo of artifact 2 (5.59 MB, image/jpeg)
2018-11-17 22:02 UTC, Ivan_S
no flags Details
dmesg (93.66 KB, text/plain)
2018-11-17 22:32 UTC, Ivan_S
no flags Details
add xorg.log (86.49 KB, text/x-log)
2018-11-17 22:33 UTC, Ivan_S
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description coolo1mc 2018-11-06 03:52:33 UTC
Screen artifact with a horizontal strip through the screen that fuzzes and stretches display contents along it. Occurs with vega56 on 144hz screen. Occurs on amdgpu-drm-next as well as linux 4.19
Comment 1 coolo1mc 2018-11-06 03:58:21 UTC
Created attachment 142383 [details]
photo of artifact
Comment 2 Alex Deucher 2018-11-06 04:10:51 UTC
Please attach your dmesg output and xorg log.  Is this a regression?  If so, can you bisect?
Comment 3 coolo1mc 2018-11-06 05:08:01 UTC
It seems to have been fixed in the latest amd drm staging next. Not sure if this means it has already been addressed and can be closed.
Comment 4 coolo1mc 2018-11-14 11:49:00 UTC
This occurs on the latest official arch linux kernel update.
4.19.1-arch1-1-ARCH
Comment 5 coolo1mc 2018-11-14 11:58:02 UTC
Created attachment 142462 [details]
dmesg
Comment 6 coolo1mc 2018-11-14 11:59:51 UTC
Created attachment 142463 [details]
xorg log

the whole drm driver completely crashed and the system refused to even poweroff a few seconds before the last line (i tried to switch to a VT to escape the hang which did not work)
Comment 7 Ivan_S 2018-11-17 22:02:49 UTC
Created attachment 142502 [details]
photo of artifact 2

I have this bug too.
Kernel - 4.19.2
Distributive - Fedora 29
Comment 8 Ivan_S 2018-11-17 22:32:36 UTC
Created attachment 142503 [details]
dmesg

add dmesg
Comment 9 Ivan_S 2018-11-17 22:33:00 UTC
Created attachment 142504 [details]
add xorg.log
Comment 10 Alex Deucher 2018-11-19 19:26:16 UTC
Possibly a duplicate of bug 108704.  Does the patch there help?
Comment 11 Alex Deucher 2018-11-19 19:27:06 UTC
(In reply to Alex Deucher from comment #10)
> Possibly a duplicate of bug 108704.  Does the patch there help?

Nevermind, you have a vega10.
Comment 12 coolo1mc 2018-11-20 08:04:47 UTC
Extra info, two other screens are fine. One is connected via a displayport to dvi cable and the other is connected via hdmi. Switching the displayport ports does not change anything.
Comment 13 coolo1mc 2018-12-11 06:56:41 UTC
Seems fixed on 4.20rc5
Comment 14 coolo1mc 2018-12-11 07:16:22 UTC
Also working on 4.19.8
closing


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.