Bug 108733 - [CI][SHARDS] igt@kms_frontbuffer_tracking@psr-2p-scndscrn-shrfb-(ms|pl|pg)flip-blt - fail - Failed assertion: psr_wait_entry(drm.debugfs)
Summary: [CI][SHARDS] igt@kms_frontbuffer_tracking@psr-2p-scndscrn-shrfb-(ms|pl|pg)fli...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Maarten Lankhorst
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-13 16:22 UTC by Martin Peres
Modified: 2019-01-08 12:11 UTC (History)
3 users (show)

See Also:
i915 platform: CFL, ICL, SKL
i915 features: display/PSR


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-11-13 16:22:23 UTC
Forked from https://bugs.freedesktop.org/show_bug.cgi?id=107719.

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_131/fi-icl-u2/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-shrfb-msflip-blt.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_131/fi-icl-u2/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-shrfb-plflip-blt.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_131/fi-icl-u2/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-shrfb-pgflip-blt.html

Starting subtest: psr-2p-scndscrn-shrfb-plflip-blt
(kms_frontbuffer_tracking:2397) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1635:
(kms_frontbuffer_tracking:2397) CRITICAL: Failed assertion: psr_wait_entry(drm.debugfs)
(kms_frontbuffer_tracking:2397) CRITICAL: PSR still disabled
Subtest psr-2p-scndscrn-shrfb-plflip-blt failed.
Comment 1 Martin Peres 2018-11-13 16:24:40 UTC
Assigning José as per https://bugs.freedesktop.org/show_bug.cgi?id=107719#c6.
Comment 2 Martin Peres 2018-11-14 09:59:23 UTC
Also seen on CFL: https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_140/fi-cfl-s3/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-shrfb-msflip-blt.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_140/fi-cfl-s3/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-shrfb-pgflip-blt.html

Starting subtest: psr-2p-scndscrn-shrfb-pgflip-blt
(kms_frontbuffer_tracking:1186) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1635:
(kms_frontbuffer_tracking:1186) CRITICAL: Failed assertion: psr_wait_entry(drm.debugfs)
(kms_frontbuffer_tracking:1186) CRITICAL: PSR still disabled
Subtest psr-2p-scndscrn-shrfb-pgflip-blt failed.
Comment 3 Lakshmi 2018-11-21 16:23:51 UTC
Based on shards results priority is set to high.

Also seen on SKL
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5175/shard-skl5/igt@kms_frontbuffer_tracking@psr-rgb101010-draw-pwrite.html

	
Starting subtest: psr-rgb101010-draw-pwrite
(kms_frontbuffer_tracking:2297) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1635:
(kms_frontbuffer_tracking:2297) CRITICAL: Failed assertion: psr_wait_entry(drm.debugfs)
(kms_frontbuffer_tracking:2297) CRITICAL: PSR still disabled
Subtest psr-rgb101010-draw-pwrite failed.
Comment 5 Jose Roberto de Souza 2018-12-03 18:51:59 UTC
Hi Martin

fi-skl-6700hq have a panel that have some PSR issues so that is why after a error we are not enabling PSR in it anymore, so PSR errors in this machine should be ignored or the panel should be replaced.

<4>[  373.273763] [drm] [transcoder EDP] PSR aux error
<7>[  373.273861] [drm:intel_psr_disable_locked [i915]] Disabling PSR1

<7>[  374.517628] [drm:intel_dp_compute_config [i915]] PSR sink implementation is not reliable

I checked the other reports in here and they don't have this error above.
Comment 6 Lakshmi 2018-12-07 16:29:43 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_150/fi-whl-u/igt@kms_frontbuffer_tracking@psr-1p-primscrn-pri-indfb-draw-mmap-cpu.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_150/fi-kbl-r/igt@kms_frontbuffer_tracking@psr-1p-primscrn-pri-indfb-draw-mmap-cpu.html

Starting subtest: psr-1p-primscrn-pri-indfb-draw-mmap-cpu
(kms_frontbuffer_tracking:1747) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1635:
(kms_frontbuffer_tracking:1747) CRITICAL: Failed assertion: psr_wait_entry(drm.debugfs)
(kms_frontbuffer_tracking:1747) CRITICAL: PSR still disabled
Subtest psr-1p-primscrn-pri-indfb-draw-mmap-cpu failed.
Comment 7 Maarten Lankhorst 2018-12-11 15:43:23 UTC
Seems to be that the PSR wait is too short?

Changing psr_wait_entry from 500 to 2500 appears to make the test pass..
Comment 8 Maarten Lankhorst 2018-12-13 09:53:38 UTC
https://patchwork.freedesktop.org/series/53981/
Comment 9 Dhinakaran Pandiyan 2018-12-14 02:00:51 UTC
(In reply to Maarten Lankhorst from comment #8)
> https://patchwork.freedesktop.org/series/53981/

Tested the newest version of this patch on a KBL with two outputs, I can confirm the patch works.
Comment 10 Maarten Lankhorst 2018-12-15 07:47:27 UTC
commit 90c76cb9bb47a5a3ebb34ad6b1a557bc02d39713 (HEAD, origin/master, origin/HEAD)
Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Date:   Tue Dec 11 17:07:22 2018 +0100

    tests/kms_frontbuffer_tracking: Make sure GPU is quiescent before handling assertions, v2.
Comment 11 Jani Saarinen 2018-12-15 10:02:49 UTC
Waiting these results from shards:
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4748/runtimes-iclb.txt
Comment 14 Jose Roberto de Souza 2019-01-04 17:18:33 UTC
> Still reproduced AFAICT:
> 
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_179/fi-skl-6700hq/igt@kms_frontbuffer_tracking@fbcpsr-1p-primscrn-pri-shrfb-draw-mmap-wc.html

As I have commented here: https://bugs.freedesktop.org/show_bug.cgi?id=108733#c5 fi-skl-6700hq have a panel that do not have a reliable PSR implementation so after the first error we do not enable PSR anymore, the panel should be replaced or PSR related tests should be put in CI whitelist.

...
<4>[  152.916239] [drm] [transcoder EDP] PSR aux error
...
<7> [324.909519] [drm:intel_dp_compute_config [i915]] PSR sink implementation is not reliable
Comment 15 Francesco Balestrieri 2019-01-04 17:23:12 UTC
Sorry, I had missed that. Resolving again, Martin how do you want to handle the unreliable panel?
Comment 16 Martin Peres 2019-01-04 22:08:56 UTC
(In reply to Francesco Balestrieri from comment #15)
> Sorry, I had missed that. Resolving again, Martin how do you want to handle
> the unreliable panel?

Can you file a new bug stating that this machine's panel is unreliable, and then we can point all failures to that?
Comment 17 Jani Saarinen 2019-01-07 07:06:35 UTC
That is laptop so cannot change that panel
Comment 18 Jani Saarinen 2019-01-08 11:46:06 UTC
Martin, there is now new bug reported for skl-6700hq: https://bugs.freedesktop.org/show_bug.cgi?id=109247 please use that.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.