Bug 109247 - [CI][SHARDS] igt@kms_frontbuffer_tracking@*psr* - fail - Failed assertion: psr_wait_entry(drm.debugfs)
Summary: [CI][SHARDS] igt@kms_frontbuffer_tracking@*psr* - fail - Failed assertion: ps...
Status: CLOSED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 109355 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-08 11:45 UTC by Jani Saarinen
Modified: 2019-01-18 20:15 UTC (History)
4 users (show)

See Also:
i915 platform: CFL, SKL
i915 features: display/PSR


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jani Saarinen 2019-01-08 11:45:18 UTC
+++ This bug was initially created as a clone of Bug #108733 +++
Several tests still failing on skl-6700hq. This bug reported to that system only indicating issue on panel itself.
Comment 1 Jani Saarinen 2019-01-08 11:46:44 UTC
Martin change tools to reflect to this bug.
Comment 2 CI Bug Log 2019-01-08 12:08:54 UTC
A CI Bug Log filter associated to this bug has been updated:

{- SKL KBL CFL WHL ICL: all tests - fail - Failed assertion: psr_wait_entry(drm.debugfs) -}
{+ fi-skl-6700hq: all tests - fail - Failed assertion: psr_wait_entry(drm.debugfs) +}

 No new failures caught with the new filter
Comment 3 Martin Peres 2019-01-08 12:10:55 UTC
From https://bugs.freedesktop.org/show_bug.cgi?id=108733#c14

"As I have commented here: https://bugs.freedesktop.org/show_bug.cgi?id=108733#c5 fi-skl-6700hq have a panel that do not have a reliable PSR implementation so after the first error we do not enable PSR anymore, the panel should be replaced or PSR related tests should be put in CI whitelist.

...
<4>[  152.916239] [drm] [transcoder EDP] PSR aux error
...
<7> [324.909519] [drm:intel_dp_compute_config [i915]] PSR sink implementation is not reliable"
Comment 4 CI Bug Log 2019-01-16 11:04:04 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-skl-6700hq: all tests - fail - Failed assertion: psr_wait_entry(drm.debugfs) -}
{+ fi-skl-6700hq shard-iclb7: all tests - fail - Failed assertion: psr_wait_entry(drm.debugfs) +}

 No new failures caught with the new filter
Comment 5 Martin Peres 2019-01-16 11:06:23 UTC
*** Bug 109355 has been marked as a duplicate of this bug. ***
Comment 6 CI Bug Log 2019-01-18 20:14:00 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-skl-6700hq shard-iclb7: all tests - fail - Failed assertion: psr_wait_entry(drm.debugfs) -}
{+ fi-skl-6700hq fi-whl-u shard-iclb7: all tests - fail - Failed assertion: psr_wait_entry(drm.debugfs) +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_196/fi-whl-u/igt@kms_frontbuffer_tracking@fbcpsr-1p-pri-indfb-multidraw.html
* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_196/fi-whl-u/igt@kms_frontbuffer_tracking@psr-1p-primscrn-indfb-msflip-blt.html
* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_196/fi-whl-u/igt@kms_frontbuffer_tracking@psr-rgb101010-draw-mmap-wc.html
* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_196/fi-whl-u/igt@kms_frontbuffer_tracking@fbcpsr-rgb565-draw-mmap-gtt.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.