Bug 108974 - make check DispatchSanity_test regression
Summary: make check DispatchSanity_test regression
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords: bisected, regression
: 109002 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-08 00:17 UTC by Vinson Lee
Modified: 2018-12-10 23:22 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2018-12-08 00:17:18 UTC
FAIL: main-test
===============

Running main() from gtest_main.cc
[==========] Running 12 tests from 5 test cases.
[----------] Global test environment set-up.
[----------] 2 tests from EnumStrings
[ RUN      ] EnumStrings.LookUpByNumber
[       OK ] EnumStrings.LookUpByNumber (0 ms)
[ RUN      ] EnumStrings.LookUpUnknownNumber
[       OK ] EnumStrings.LookUpUnknownNumber (0 ms)
[----------] 2 tests from EnumStrings (0 ms total)

[----------] 6 tests from DispatchSanity_test
[ RUN      ] DispatchSanity_test.GL31_CORE
dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x55b1d895e230
To be equal to: table[i]
      Which is: 0x55b1d898e2d0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GL31_CORE (1 ms)
[ RUN      ] DispatchSanity_test.GL30
dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x55b1d895e230
To be equal to: table[i]
      Which is: 0x55b1d898e2d0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GL30 (1 ms)
[ RUN      ] DispatchSanity_test.GLES11
[       OK ] DispatchSanity_test.GLES11 (0 ms)
[ RUN      ] DispatchSanity_test.GLES2
dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x55b1d895e230
To be equal to: table[i]
      Which is: 0x55b1d898e2d0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GLES2 (0 ms)
[ RUN      ] DispatchSanity_test.GLES3
dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x55b1d895e230
To be equal to: table[i]
      Which is: 0x55b1d898e2d0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GLES3 (0 ms)
[ RUN      ] DispatchSanity_test.GLES31
dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x55b1d895e230
To be equal to: table[i]
      Which is: 0x55b1d898e2d0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GLES31 (1 ms)
[----------] 6 tests from DispatchSanity_test (3 ms total)

[----------] 2 tests from MesaFormatsTest
[ RUN      ] MesaFormatsTest.FormatTypeAndComps
[       OK ] MesaFormatsTest.FormatTypeAndComps (0 ms)
[ RUN      ] MesaFormatsTest.FormatSanity
[       OK ] MesaFormatsTest.FormatSanity (0 ms)
[----------] 2 tests from MesaFormatsTest (0 ms total)

[----------] 1 test from MesaExtensionsTest
[ RUN      ] MesaExtensionsTest.AlphabeticallySorted
[       OK ] MesaExtensionsTest.AlphabeticallySorted (0 ms)
[----------] 1 test from MesaExtensionsTest (0 ms total)

[----------] 1 test from program_state_string
[ RUN      ] program_state_string.depth_range
[       OK ] program_state_string.depth_range (0 ms)
[----------] 1 test from program_state_string (0 ms total)

[----------] Global test environment tear-down
[==========] 12 tests from 5 test cases ran. (3 ms total)
[  PASSED  ] 7 tests.
[  FAILED  ] 5 tests, listed below:
[  FAILED  ] DispatchSanity_test.GL31_CORE
[  FAILED  ] DispatchSanity_test.GL30
[  FAILED  ] DispatchSanity_test.GLES2
[  FAILED  ] DispatchSanity_test.GLES3
[  FAILED  ] DispatchSanity_test.GLES31

 5 FAILED TESTS
FAIL main-test (exit status: 1)


commit 1b331ae505e63033634d9f5267ca1949336f75d8
Author: Kristian H. Kristensen <hoegsberg@chromium.org>
Date:   Mon Nov 5 21:19:21 2018 -0800

    mesa: Add core support for EXT_multisampled_render_to_texture{,2}
    
    This also turns on EXT_multisampled_render_to_texture which is a
    subset of EXT_multisampled_render_to_texture2, allowing only
    COLOR_ATTACHMENT0.
    
    Reviewed-by: Eric Anholt <eric@anholt.net>
    Signed-off-by: Kristian H. Kristensen <hoegsberg@chromium.org>

:040000 040000 d6922bd08d46ab35b96e85798d34231cbe05956f 4b142ab99bc445d446373c316c7f9dde466e2219 M	src
bisect run success
Comment 1 Dylan Baker 2018-12-10 22:54:26 UTC
*** Bug 109002 has been marked as a duplicate of this bug. ***
Comment 2 Kristian Høgsberg 2018-12-10 23:22:43 UTC
commit c0de7c21a352dc5ea556df0397d0b34559bb89c2
Author: Kristian H. Kristensen <hoegsberg@gmail.com>
Date:   Mon Dec 10 18:14:34 2018 +0000

    glapi: fixup EXT_multisampled_render_to_texture dispatch
    
    There's a few missing and convoluted bits:
    
     - FramebufferTexture2DMultisampleEXT
    Missing sanity check, should be desktop="false"
    
     - RenderbufferStorageMultisampleEXT
    Missing sanity check, is aliased to RenderbufferStorageMultisample.
    Thus it's set only when desktop GL or GLES2 v3.0+, while the extension
    is GLES2 2.0+.
    
    If we flip the aliasing we'll break indirect GLX, so loosen the version
    to 2.0. Not perfect, yet this is the most sane thing I could think of.
    
    v2: [Emil] Fixup RenderbufferStorageMultisampleEXT, commmit message
    
    Cc: Kristian H. Kristensen <hoegsberg@gmail.com>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=108974
    Fixes: 1b331ae505e ("mesa: Add core support for EXT_multisampled_render_to_texture{,2}")
    Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
    Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
    Signed-off-by: Emil Velikov <emil.velikov@collabora.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.