Bug 109002 - [bisected] meson build test 'main-test' fails
Summary: [bisected] meson build test 'main-test' fails
Status: RESOLVED DUPLICATE of bug 108974
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Kristian Høgsberg
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-10 18:38 UTC by Clayton Craft
Modified: 2018-12-10 22:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clayton Craft 2018-12-10 18:38:44 UTC
Output from failing test:

1/1 mesa:mesa / main-test                   FAIL     0.01 s (exit status 1)

--- command ---
/home/clayton/repos/mesa/build_meson-buildtest_m64/src/mesa/main/tests/main_test
--- stdout ---
Running main() from gtest_main.cc
[==========] Running 12 tests from 5 test cases.
[----------] Global test environment set-up.
[----------] 2 tests from EnumStrings
[ RUN      ] EnumStrings.LookUpByNumber
[       OK ] EnumStrings.LookUpByNumber (0 ms)
[ RUN      ] EnumStrings.LookUpUnknownNumber
[       OK ] EnumStrings.LookUpUnknownNumber (0 ms)
[----------] 2 tests from EnumStrings (0 ms total)

[----------] 6 tests from DispatchSanity_test
[ RUN      ] DispatchSanity_test.GL31_CORE
../src/mesa/main/tests/dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x564e45719b40
To be equal to: table[i]
      Which is: 0x564e45747dc0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GL31_CORE (1 ms)
[ RUN      ] DispatchSanity_test.GL30
../src/mesa/main/tests/dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x564e45719b40
To be equal to: table[i]
      Which is: 0x564e45747dc0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GL30 (0 ms)
[ RUN      ] DispatchSanity_test.GLES11
[       OK ] DispatchSanity_test.GLES11 (0 ms)
[ RUN      ] DispatchSanity_test.GLES2
../src/mesa/main/tests/dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x564e45719b40
To be equal to: table[i]
      Which is: 0x564e45747dc0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GLES2 (1 ms)
[ RUN      ] DispatchSanity_test.GLES3
../src/mesa/main/tests/dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x564e45719b40
To be equal to: table[i]
      Which is: 0x564e45747dc0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GLES3 (0 ms)
[ RUN      ] DispatchSanity_test.GLES31
../src/mesa/main/tests/dispatch_sanity.cpp:174: Failure
      Expected: nop_table[i]
      Which is: 0x564e45719b40
To be equal to: table[i]
      Which is: 0x564e45747dc0
i = 1160 (FramebufferTexture2DMultisampleEXT)
[  FAILED  ] DispatchSanity_test.GLES31 (0 ms)
[----------] 6 tests from DispatchSanity_test (2 ms total)





The failure has been bisected to this commit:

commit 1b331ae505e63033634d9f5267ca1949336f75d8
Author: Kristian H. Kristensen <hoegsberg@chromium.org>
Date:   Mon Nov 5 21:19:21 2018 -0800

    mesa: Add core support for EXT_multisampled_render_to_texture{,2}

    This also turns on EXT_multisampled_render_to_texture which is a
    subset of EXT_multisampled_render_to_texture2, allowing only
    COLOR_ATTACHMENT0.

    Reviewed-by: Eric Anholt <eric@anholt.net>
    Signed-off-by: Kristian H. Kristensen <hoegsberg@chromium.org>
Comment 1 Dylan Baker 2018-12-10 22:54:26 UTC

*** This bug has been marked as a duplicate of bug 108974 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.