Bug 109151 - [KBL-G][vulkan] dEQP-VK.texture.explicit_lod.2d.sizes.31x55_nearest_linear_mipmap_nearest_repeat failed verification.
Summary: [KBL-G][vulkan] dEQP-VK.texture.explicit_lod.2d.sizes.31x55_nearest_linear_mi...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: 18.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
: 109147 109158 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-26 02:30 UTC by Hai
Modified: 2019-01-08 00:40 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
TestResults.qpa (20.40 KB, text/plain)
2018-12-26 02:32 UTC, Hai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hai 2018-12-26 02:30:08 UTC
When Use Kaby Lake-g(AMD Vega M GPU) to do the Vulkan CTS test, the case "
dEQP-VK.texture.explicit_lod.2d.sizes.31x55_nearest_linear_mipmap_nearest_repeat" will fail

Following is the environtment

Platform	KabyLake-G
CPU	Intel (R) Core (TM) i7-8809G CPU @3.10GHz
GPU	AMD(Radeon RX Vega M GH Graphics);
Memory	16G
OS	Ubutu18.04.1
Kernel	4.19.0
Mesa: 	mesa 18.3.1 (https://mesa.freedesktop.org/archive/mesa-18.3.1.tar.gz) 

VK-GL-CTS version	https://github.com/KhronosGroup/VK-GL-CTS
commit 54e546a1a0a6fa412ea4c3e3081bbc9518928a6e

How to reproduce
./deqp-vk -n dEQP-VK.texture.explicit_lod
.2d.sizes.31x55_nearest_linear_mipmap_nearest_repeat
Writing test log into TestResults.qpa
dEQP Core git-54e546a1a0a6fa412ea4c3e3081bbc9518928a6e (0x54e546a1) starting..
  target implementation = 'Default'

Test case 'dEQP-VK.texture.explicit_lod.2d.sizes.31x55_nearest_linear_mipmap_nearest_repeat'..
  Fail (Verification failed)

DONE!

Test run totals:
  Passed:        0/1 (0.0%)
  Failed:        1/1 (100.0%)
  Not supported: 0/1 (0.0%)
  Warnings:      0/1 (0.0%)
Comment 1 Hai 2018-12-26 02:32:01 UTC
Created attachment 142896 [details]
TestResults.qpa
Comment 2 Hai 2018-12-26 02:52:16 UTC
*** Bug 109147 has been marked as a duplicate of this bug. ***
Comment 3 Bas Nieuwenhuizen 2018-12-26 16:35:01 UTC
Is this a regression? If so what is the last working version of mesa for you?
Comment 4 Hai 2018-12-27 01:10:53 UTC
It's not an regression. I tried Mesa 18.2.2, it also failed, thanks.
Comment 5 Hai 2018-12-27 05:43:23 UTC
*** Bug 109158 has been marked as a duplicate of this bug. ***
Comment 6 Hai 2019-01-02 08:36:21 UTC
Any idea of this issue? Thanks.
Comment 7 Bas Nieuwenhuizen 2019-01-02 15:02:12 UTC
Hmm, I can actually reproduce (thought we would not be able to since we have a pretty much 100% pass-rate on the 1.1.3 mustpass list on a bunch of HW).

However I also noticed that it is not on the mustpass list?
Comment 8 Bas Nieuwenhuizen 2019-01-02 17:05:30 UTC
This should fix it:

https://gitlab.freedesktop.org/mesa/mesa/merge_requests/60
Comment 9 Hai 2019-01-07 03:27:51 UTC
Verified with this patch. This test case can pass with this patch, thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.