Bug 109250 - [kbl] GPU hang in gnome-shell
Summary: [kbl] GPU hang in gnome-shell
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 107911 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-08 21:38 UTC by Nikola
Modified: 2019-09-25 20:29 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg error log with debugging enabled (545.69 KB, text/x-log)
2019-01-08 21:38 UTC, Nikola
Details
GPU crash dump (19.54 KB, application/octet-stream)
2019-01-08 21:39 UTC, Nikola
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikola 2019-01-08 21:38:56 UTC
Created attachment 143021 [details]
dmesg error log with debugging enabled

System works fine until I log in via GDM and try to do anything in the desktop environment. Then it freezes, it may seem to work after a few minutes but again if I try to open anything it will stop working. Weird small rectangles may show up on the screen. 

dmesg shows that GPU is hanging. 

It works fine without a UI, and also works fairly well in Windows.

Hardware: Thinkpad X1 Carbon 5th Gen

Distro: ArchLinux (build 01.01.2019) but same issue on other distros (Ubuntu,Mate,CentOS,etc)

Kernel: 4.20.0, but same issue on any kernel since 4.14 (haven't tried the older ones)


The only thing that makes it work, barely, is nomodeset. But that's not really a solution.

The attached error log is from ArchLinux running kernel 4.20.0.

The GPU in question:

0:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02) (prog-if 00 [VGA controller])
	Subsystem: Lenovo ThinkPad X1 Carbon 5th Gen
	Flags: bus master, fast devsel, latency 0, IRQ 11
	Memory at eb000000 (64-bit, non-prefetchable) [size=16M]
	Memory at 60000000 (64-bit, prefetchable) [size=256M]
	I/O ports at e000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: [40] Vendor Specific Information: Len=0c <?>
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [ac] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [100] Process Address Space ID (PASID)
	Capabilities: [200] Address Translation Service (ATS)
	Capabilities: [300] Page Request Interface (PRI)
	Kernel modules: i915


I've spent countless hours trying to figure out where the issue is and have made zero progress. Would really appreciate some help on this as it renders my laptop unusable.
Comment 1 Nikola 2019-01-08 21:39:35 UTC
Created attachment 143022 [details]
GPU crash dump
Comment 2 Nikola 2019-01-08 21:41:30 UTC
*** Bug 107911 has been marked as a duplicate of this bug. ***
Comment 3 Lionel Landwerlin 2019-01-09 08:31:02 UTC
We recently fixed a hang on master : https://gitlab.freedesktop.org/mesa/mesa/commit/31e4c9ce400341df9b0136419b3b3c73b8c9eb7e

From what I can tell from the error state you attached, your version of Mesa does not have that fix.
This should make its way into Mesa 18.3.2, but in the meantime if you can try with Mesa at the commit above that would help us know if there is another issue.

Thanks.
Comment 4 GitLab Migration User 2019-09-25 20:29:20 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1782.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.