Bug 109294 - [CI][SHARDS] igt@prime_vgem@basic-fence-flip - skip - Test requirement: (crtc_id = set_fb_on_crtc(i915, 0, &bo[0], fb_id[0])), SKIP
Summary: [CI][SHARDS] igt@prime_vgem@basic-fence-flip - skip - Test requirement: (crtc...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: IGT (show other bugs)
Version: XOrg git
Hardware: Other All
: lowest normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard: ReadyForDev
Keywords:
: 110531 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-10 15:57 UTC by Martin Peres
Modified: 2019-05-09 12:16 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-01-10 15:57:31 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5388/shard-iclb6/igt@prime_vgem@basic-fence-flip.html

Test requirement: (crtc_id = set_fb_on_crtc(i915, 0, &bo[0], fb_id[0]))
Subtest basic-fence-flip: SKIP (0.142s)
Comment 1 CI Bug Log 2019-01-10 15:58:17 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* ICL: igt@prime_vgem@basic-fence-flip - skip - Test requirement: (crtc_id = set_fb_on_crtc(i915, 0, &bo[0], fb_id[0])), SKIP
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5388/shard-iclb6/igt@prime_vgem@basic-fence-flip.html
Comment 2 CI Bug Log 2019-02-01 08:56:27 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@prime_vgem@basic-fence-flip - skip - Test requirement: (crtc_id = set_fb_on_crtc(i915, 0, &bo[0], fb_id[0])), SKIP -}
{+ ICL: igt@prime_vgem@basic-fence-flip - skip - Test requirement: (crtc_id = set_fb_on_crtc(i915, 0, &bo[0], fb_id[0])), SKIP +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5519/fi-icl-y/igt@prime_vgem@basic-fence-flip.html
* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5520/fi-icl-y/igt@prime_vgem@basic-fence-flip.html
* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5521/fi-icl-y/igt@prime_vgem@basic-fence-flip.html
* https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5522/fi-icl-y/igt@prime_vgem@basic-fence-flip.html
Comment 3 Francesco Balestrieri 2019-03-19 07:47:56 UTC
Assigning to Tvrtko for investigation.
Comment 4 Maarten Lankhorst 2019-04-10 08:35:12 UTC
The test skips because the test is broken. It creates a 1024x768 BO and then looks for an output that has a 1024x768 or smaller mode. This is not the case on some machines with an internal panel because it only exposes a single mode that's greater than 1024x768.
This causes the test to skip
Comment 5 Chris Wilson 2019-04-10 08:37:34 UTC
(In reply to Maarten Lankhorst from comment #4)
> The test skips because the test is broken. It creates a 1024x768 BO and then
> looks for an output that has a 1024x768 or smaller mode. This is not the
> case on some machines with an internal panel because it only exposes a
> single mode that's greater than 1024x768.
> This causes the test to skip

s/broken/limited/

Working as designed :-p
Comment 6 Lakshmi 2019-04-10 11:14:46 UTC
Test has to be updated to avoid skip. Considering this issue as a feature enhancement, priority is set to lowest and component to IGT.
Comment 7 Tvrtko Ursulin 2019-04-11 06:50:36 UTC
Patch tested on CI: https://patchwork.freedesktop.org/series/59284/

Seems to have improved the coverage:

https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2838/

  * igt@prime_vgem@basic-fence-flip:
    - fi-glk-dsi:         SKIP [fdo#109271] -> PASS
    - fi-bxt-dsi:         SKIP [fdo#109271] -> PASS
    - fi-kbl-r:           SKIP [fdo#109271] -> PASS
    - fi-skl-6600u:       SKIP [fdo#109271] -> PASS
    - fi-icl-y:           SKIP [fdo#109294] -> PASS
    - fi-whl-u:           SKIP [fdo#109271] -> PASS

Need closure on whether or not to align fb width to 16 or go with it as is. (And review.)
Comment 8 Chris Wilson 2019-04-26 11:00:30 UTC
*** Bug 110531 has been marked as a duplicate of this bug. ***
Comment 9 Tvrtko Ursulin 2019-05-09 12:16:20 UTC
Pushed a test fix to probe the native display resolution.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.