Bug 109319 - [radeonsi] Two Point Hospital: rendered in mostly black on an Oland XT GPU
Summary: [radeonsi] Two Point Hospital: rendered in mostly black on an Oland XT GPU
Status: RESOLVED DUPLICATE of bug 108919
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords: have-backtrace
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2019-01-11 19:42 UTC by Kai
Modified: 2019-07-05 06:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Image showing the rendering issues of TPH with radeonsi on OLAND (608.29 KB, image/jpeg)
2019-01-11 19:42 UTC, Kai
Details
TPH graphics settings (pt. 1) (934.00 KB, image/jpeg)
2019-01-11 19:46 UTC, Kai
Details
TPH graphics settings (pt. 2) (931.48 KB, image/jpeg)
2019-01-11 19:46 UTC, Kai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai 2019-01-11 19:42:50 UTC
Created attachment 143074 [details]
Image showing the rendering issues of TPH with radeonsi on OLAND

A friend of mine for whom I'm doing the Linux tech support has trouble playing Two Point Hospital (TPH) on his Oland XT GPU with radeonsi. With older versions of Mesa the game locked up the GPU after a while, therefore I built him a Mesa from Git, linked against LLVM 8 (see below for details on the complete stack). But with the Git version the game becomes completely unplayable, because most of the screen is rendered in black. Menus and some outlines are shown. See the attached picture my friend sent me for details on how this looks. [NB: I've been able to play TPH on my HAWAII PRO based system without any issues so far.]
He uses the radeon stack, due to the limitations of amdgpu with this GPU generation.

At <https://c.1und1.de/@519917343397118178/ZZXLY27mRj-iQZQsH0GFmQ> you'll find an apitrace my friend recorded, which reproduces the issue on his system when played back.

The stack my friend uses is (Debian Stretch with backports as a base):
GPU: Oland XT [R7 250] (ChipID = 0x6610)
Mesa: Git:master/8847370424
libdrm: 2.4.95-1~bpo9+1
LLVM: SVN:trunk/r350064 (8.0 devel)
X.Org: 2:1.19.2-1+deb9u5
Linux: 4.20-1~exp1
Firmware: 20180825+dfsg-1~bpo9+1
DDX: 1:7.8.0-1+b1

Let me know, if you need anything else.
Comment 1 Kai 2019-01-11 19:46:05 UTC
Created attachment 143075 [details]
TPH graphics settings (pt. 1)
Comment 2 Kai 2019-01-11 19:46:34 UTC
Created attachment 143076 [details]
TPH graphics settings (pt. 2)
Comment 3 Timothy Arceri 2019-07-05 06:34:12 UTC
I believe this game has the same rendering problems as Parkitect. That is the same issues with the Unity engine.

*** This bug has been marked as a duplicate of bug 108919 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.