Bug 109824 - [CI][DRMTIP] igt@debugfs_test@read_all_entries_display_off - dmesg-warn - Unclaimed read from register 0x1e1110
Summary: [CI][DRMTIP] igt@debugfs_test@read_all_entries_display_off - dmesg-warn - Unc...
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 105588 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-04 08:42 UTC by Lakshmi
Modified: 2019-09-19 10:24 UTC (History)
2 users (show)

See Also:
i915 platform: BYT
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-03-04 08:42:34 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_234/fi-byt-n2820/igt@debugfs_test@read_all_entries_display_off.html

 ------------[ cut here ]------------
<4> [391.642549] Unclaimed read from register 0x1e1110
<4> [391.642703] WARNING: CPU: 1 PID: 1124 at drivers/gpu/drm/i915/intel_uncore.c:1093 __unclaimed_reg_debug+0x40/0x50 [i915]
<4> [391.642709] Modules linked in: vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic i915 btusb btrtl btbcm btintel coretemp crct10dif_pclmul crc32_pclmul snd_hda_intel ghash_clmulni_intel bluetooth snd_hda_codec snd_hwdep snd_hda_core ecdh_generic r8169 snd_pcm realtek lpc_ich prime_numbers i2c_hid
<4> [391.642747] CPU: 1 PID: 1124 Comm: debugfs_test Tainted: G     U            5.0.0-rc8-g348fd7b7fa65-drmtip_234+ #1
<4> [391.642752] Hardware name: \xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff \xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff/DN2820FYK, BIOS FYBYT10H.86A.0059.2017.0607.2130 06/07/2017
<4> [391.642847] RIP: 0010:__unclaimed_reg_debug+0x40/0x50 [i915]
<4> [391.642853] Code: 74 05 5b 5d 41 5c c3 45 84 e4 48 c7 c0 c2 30 79 c0 48 c7 c6 b8 30 79 c0 48 0f 44 f0 89 ea 48 c7 c7 cb 30 79 c0 e8 30 c0 a0 d0 <0f> 0b 83 2d 57 e3 1a 00 01 5b 5d 41 5c c3 66 90 41 56 41 55 41 89
<4> [391.642858] RSP: 0018:ffffa7ed8012fd20 EFLAGS: 00010082
<4> [391.642864] RAX: 0000000000000000 RBX: 0000000000000000 RCX: 0000000000000000
<4> [391.642869] RDX: 0000000000000007 RSI: ffffffff92084383 RDI: 00000000ffffffff
<4> [391.642873] RBP: 00000000001e1110 R08: 0000000000000000 R09: 0000000000000001
<4> [391.642878] R10: ffffa7ed8012fcb8 R11: 0000000000000000 R12: 0000000000000001
<4> [391.642882] R13: 0000000000000001 R14: 00000000ffffffff R15: 0000000000000202
<4> [391.642888] FS:  00007f871f05a980(0000) GS:ffff9e853bb00000(0000) knlGS:0000000000000000
<4> [391.642892] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
<4> [391.642897] CR2: 000055f27ef35058 CR3: 000000011a986000 CR4: 00000000001006e0
<4> [391.642901] Call Trace:
<4> [391.643000]  fwtable_read32+0x1e8/0x250 [i915]
<4> [391.643087]  i915_interrupt_info+0xa45/0xd30 [i915]
<4> [391.643103]  seq_read+0xdb/0x3c0
<4> [391.643114]  ? lockdep_hardirqs_off+0x94/0xd0
<4> [391.643121]  ? __slab_free+0x24e/0x4f0
<4> [391.643133]  full_proxy_read+0x51/0x80
<4> [391.643144]  __vfs_read+0x31/0x190
<4> [391.643159]  ? do_sys_open+0x13b/0x250
<4> [391.643165]  ? rcu_read_lock_sched_held+0x6f/0x80
<4> [391.643173]  vfs_read+0x9e/0x150
<4> [391.643182]  ksys_read+0x50/0xc0
<4> [391.643195]  do_syscall_64+0x55/0x190
<4> [391.643204]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
<4> [391.643211] RIP: 0033:0x7f871e9e534e
<4> [391.643217] Code: 00 00 00 00 48 8b 15 71 8c 20 00 f7 d8 64 89 02 48 c7 c0 ff ff ff ff c3 0f 1f 40 00 8b 05 ba d0 20 00 85 c0 75 16 31 c0 0f 05 <48> 3d 00 f0 ff ff 77 5a f3 c3 0f 1f 84 00 00 00 00 00 41 54 55 49
<4> [391.643222] RSP: 002b:00007ffee27a5c38 EFLAGS: 00000246 ORIG_RAX: 0000000000000000
<4> [391.643228] RAX: ffffffffffffffda RBX: 0000000000000000 RCX: 00007f871e9e534e
<4> [391.643233] RDX: 0000000000000200 RSI: 00007ffee27a5c80 RDI: 0000000000000008
<4> [391.643237] RBP: 00007ffee27a5e90 R08: 0000000000000000 R09: 0000000000000022
<4> [391.643242] R10: 0000000000000000 R11: 0000000000000246 R12: 000055f27ecf3390
<4> [391.643246] R13: 00007ffee27a6410 R14: 0000000000000000 R15: 0000000000000000
<4> [391.643268] irq event stamp: 165148
<4> [391.643275] hardirqs last  enabled at (165147): [<ffffffff919934c4>] _raw_spin_unlock_irq+0x24/0x50
<4> [391.643281] hardirqs last disabled at (165148): [<ffffffff919932fd>] _raw_spin_lock_irqsave+0xd/0x50
<4> [391.643287] softirqs last  enabled at (165144): [<ffffffff91c0033a>] __do_softirq+0x33a/0x4b9
<4> [391.643293] softirqs last disabled at (165059): [<ffffffff910b8f21>] irq_exit+0xd1/0xe0
<4> [391.643398] WARNING: CPU: 1 PID: 1124 at drivers/gpu/drm/i915/intel_uncore.c:1093 __unclaimed_reg_debug+0x40/0x50 [i915]
<4> [391.643403] ---[ end trace 15ab965459a30e04 ]---
Comment 1 CI Bug Log 2019-03-04 08:46:20 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* BYT : igt@debugfs_test@read_all_entries_display_off - dmesg-warn - Unclaimed read from register 0x1e1110
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_234/fi-byt-n2820/igt@debugfs_test@read_all_entries_display_off.html

* BYT : igt@runner@aborted - fail - Previous test: debugfs_test (read_all_entries_display_off)
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_234/fi-byt-n2820/igt@runner@aborted.html
Comment 2 CI Bug Log 2019-04-05 08:51:19 UTC
A CI Bug Log filter associated to this bug has been updated:

{- BYT : igt@debugfs_test@read_all_entries_display_off - dmesg-warn - Unclaimed read from register 0x1e1110 -}
{+ BYT : igt@debugfs_test@read_all_entries_display_off / igt@i915_pm_rpm@debugfs-read - dmesg-warn - Unclaimed read from register 0x1e1110 +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_248/fi-byt-clapper/igt@i915_pm_rpm@debugfs-read.html
* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_248/fi-byt-j1900/igt@i915_pm_rpm@debugfs-read.html
* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_248/fi-byt-n2820/igt@i915_pm_rpm@debugfs-read.html
Comment 4 Arek Hiler 2019-09-12 08:43:14 UTC
*** Bug 105588 has been marked as a duplicate of this bug. ***
Comment 5 Arek Hiler 2019-09-12 12:26:29 UTC
Seems like we have unclaimed read on 
('PORT_HOTPLUG_EN',		'0x61110', '0x180000')[1]

That happens here[2]:
	} else if (IS_VALLEYVIEW(dev_priv)) {
		/* ... */
		seq_printf(m, "Port hotplug:\t%08x\n",
			   I915_READ(PORT_HOTPLUG_EN));
		/* ... */
	} else if (!HAS_PCH_SPLIT(dev_priv)) {

We don't take any extra wakerefs for VLV but on CHV we do:
		intel_display_power_get(dev_priv, POWER_DOMAIN_INIT);

for this register and the following DP registers.

Keeping this as medium bacause:
 1. user impact is negligible - it's an error in the debugfs
 2. CI impact is medium - kernel taints and stops execution on this bug

[1]: https://gitlab.freedesktop.org/drm/igt-gpu-tools/blob/master/tools/registers/vlv_display_base.txt#L103
[2]: https://cgit.freedesktop.org/drm-tip/tree/drivers/gpu/drm/i915/i915_debugfs.c#n581
Comment 6 Arek Hiler 2019-09-12 12:55:23 UTC
https://patchwork.freedesktop.org/series/66604/
Comment 7 Chris Wilson 2019-09-12 20:00:32 UTC
commit 0c653722e6e669fae969c178f0d4a55d9c2dc922 (HEAD -> drm-intel-next-queued, drm-intel/drm-intel-next-queued)
Author: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Date:   Thu Sep 12 15:54:18 2019 +0300

    drm/i915: Get the correct wakeref for reading HOTPLUG_EN et al.
    
    Without it we get:
     Unclaimed read from register 0x1e1110
     WARNING: CPU: 2 PID: 1029 at drivers/gpu/drm/i915/intel_uncore.c:1101 __unclaimed_reg_debug+0x40/0x50 [i915]
     Call Trace:
      fwtable_read32+0x233/0x300 [i915]
      i915_interrupt_info+0xa73/0xd60 [i915]
      seq_read+0xdb/0x3c0
      full_proxy_read+0x51/0x80
      vfs_read+0x9e/0x160
      ksys_read+0x8f/0xe0
      do_syscall_64+0x55/0x1c0
      entry_SYSCALL_64_after_hwframe+0x49/0xbe
    
    Cc: Chris Wilson <chris@chris-wilson.co.uk>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=109824
    Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
    Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Link: https://patchwork.freedesktop.org/patch/msgid/20190912125418.23115-2-arkadiusz.hiler@intel.com
Comment 8 CI Bug Log 2019-09-19 10:24:08 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.