Bug 109925 - Age of Wonders 3 - Vertical lines on Main Menu (Linux native via Steam)
Summary: Age of Wonders 3 - Vertical lines on Main Menu (Linux native via Steam)
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 77449
  Show dependency treegraph
 
Reported: 2019-03-07 11:54 UTC by andrew.m.mcmahon
Modified: 2019-09-18 20:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
glxinfo (146.71 KB, text/plain)
2019-03-07 11:54 UTC, andrew.m.mcmahon
Details
steam system info (1.98 KB, text/plain)
2019-03-07 11:57 UTC, andrew.m.mcmahon
Details
xorg log (117.46 KB, text/plain)
2019-03-07 12:01 UTC, andrew.m.mcmahon
Details
glxinfo (corrected) (145.13 KB, text/plain)
2019-03-07 13:15 UTC, andrew.m.mcmahon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andrew.m.mcmahon 2019-03-07 11:54:05 UTC
Created attachment 143564 [details]
glxinfo

Age of Wonders 3 v1.802 Linux version via STEAM.

Some strange vertical lines can be observed on the Main Menu but otherwise the game appears to work correctly in all other areas (i.e battles, global map)
https://imgur.com/a/IVqewpN

It should obviously look more like this:
https://i.ytimg.com/vi/L-vPu2aeG2w/maxresdefault.jpg

Ubuntu 18.04 LTS, using oibaf's ppa for the latest Mesa packages.

A search highlighted this previous bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=106531

Running this in a terminal:
MESA_GL_VERSION_OVERRIDE=3.1COMPAT steam steam://226840

Or changing the game's launch options with didn't have any effect:
MESA_GL_VERSION_OVERRIDE=3.1COMPAT %command% 

I've captured an apitrace of the issue but it's a bit screwy when replaying it - what I see occurs offscreen:
https://drive.google.com/file/d/1cGTjw9qgXzAHXvUr_EfjUvFHSAlfARxi/view?usp=sharing

The playback window can be moved up beyond the limit of the screen by left clicking on the top left edge and choosing "Move"
Works best if you do that once the Main Menu is loaded.
https://i.imgur.com/pQPdukM.jpg
https://i.imgur.com/xtGD3Vz.jpg
Comment 1 andrew.m.mcmahon 2019-03-07 11:57:02 UTC
Created attachment 143565 [details]
steam system info
Comment 2 andrew.m.mcmahon 2019-03-07 12:01:05 UTC
Created attachment 143566 [details]
xorg log
Comment 3 andrew.m.mcmahon 2019-03-07 13:15:33 UTC
Created attachment 143569 [details]
glxinfo (corrected)

I must've exported MESA_GL_VERSION_OVERRIDE=3.1COMPAT then done a glxinfo in the same terminal window.
Comment 4 andrew.m.mcmahon 2019-03-08 20:08:52 UTC
The mesa packages provided by oibaf's ppa were updated to use LLVM 8 so I've made another trace:
https://drive.google.com/open?id=1wPvrwTBTSYG7f3AQh-oolAYeXYn81ZnB

The issue is still reproducible. Again, replaying the trace has the same quirky behaviour as before.
Comment 5 Timothy Arceri 2019-05-06 04:43:17 UTC
Moving to Mesa core as this happens on i965 also.

I was sure this was a regression but could only run the game as far back as the 17.3 branch point on i965 and it was still present there.
Comment 6 GitLab Migration User 2019-09-18 20:27:43 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1038.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.