Bug 110321 - [CI][SHARDS] igt@kms_content_protection@* - fail - KSV list failed to become ready (-110)
Summary: [CI][SHARDS] igt@kms_content_protection@* - fail - KSV list failed to become ...
Status: RESOLVED NOTABUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high normal
Assignee: Ramalingam C
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 110336 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-04 12:25 UTC by Martin Peres
Modified: 2019-08-09 09:43 UTC (History)
1 user (show)

See Also:
i915 platform: BXT, CFL, KBL, SKL
i915 features: display/HDCP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-04-04 12:25:27 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5865/shard-kbl4/igt@kms_content_protection@atomic.html

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5865/shard-apl6/igt@kms_content_protection@atomic.html

Starting subtest: atomic
(kms_content_protection:8396) CRITICAL: Test assertion failure function test_cp_enable_with_retry, file ../tests/kms_content_protection.c:215:
(kms_content_protection:8396) CRITICAL: Failed assertion: ret
(kms_content_protection:8396) CRITICAL: Last errno: 25, Inappropriate ioctl for device
(kms_content_protection:8396) CRITICAL: Content Protection not enabled
Subtest atomic failed.

<7> [1628.299736] [drm:intel_hdcp_auth [i915]] KSV list failed to become ready (-110)
Comment 1 CI Bug Log 2019-04-04 12:25:55 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* APL KBL: igt@kms_content_protection@* - fail - Content Protection not enabled, KSV list failed to become ready (-110) (No new failures associated)
Comment 2 Martin Peres 2019-04-04 13:02:47 UTC
+ Ram.

Can you check if this is platform- or machine-specific? I'll update the filter based on your feedback.
Comment 3 Ramalingam C 2019-04-04 13:28:23 UTC
Martin,

This debug log with failure will be observed when the connected repeater(LsPCON here) is not providing the KSV list in time. I915 can't fix this.
Comment 4 Ramalingam C 2019-04-11 10:36:42 UTC
*** Bug 110336 has been marked as a duplicate of this bug. ***
Comment 5 Ramalingam C 2019-04-11 10:40:10 UTC
This HDCP failure is caused due to the HDCP sink connected to the port. So this is not a bug in I915. Thanks
Comment 6 CI Bug Log 2019-04-30 10:31:24 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* CFL: igt@kms_content_protection@atomic-dpms - incomplete - KSV list failed to become ready (-110)
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_270/fi-cfl-8109u/igt@kms_content_protection@atomic-dpms.html
Comment 7 Lakshmi 2019-04-30 10:32:12 UTC
(In reply to CI Bug Log from comment #6)
> The CI Bug Log issue associated to this bug has been updated.
> 
> ### New filters associated
> 
> * CFL: igt@kms_content_protection@atomic-dpms - incomplete - KSV list failed
> to become ready (-110)
>   -
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_270/fi-cfl-8109u/
> igt@kms_content_protection@atomic-dpms.html

Result here is incomplete but on CFL.
Comment 8 CI Bug Log 2019-07-09 08:15:50 UTC
A CI Bug Log filter associated to this bug has been updated:

{- APL KBL: igt@kms_content_protection@* - fail - Content Protection not enabled, KSV list failed to become ready (-110) -}
{+ APL KBL: igt@kms_content_protection@* - fail - Content Protection not enabled, KSV list failed to become ready (-110) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_6431/shard-kbl2/igt@kms_content_protection@atomic.html
Comment 10 CI Bug Log 2019-08-09 08:28:11 UTC
A CI Bug Log filter associated to this bug has been updated:

{- APL KBL: igt@kms_content_protection@* - fail - Content Protection not enabled, KSV list failed to become ready (-110) -}
{+ APL SKL KBL: igt@kms_content_protection@* - fail - Content Protection not enabled, KSV list failed to become ready (-110) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_338/fi-skl-6770hq/igt@kms_content_protection@lic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_338/fi-skl-lmem/igt@kms_content_protection@lic.html
Comment 11 CI Bug Log 2019-08-09 08:43:02 UTC
A CI Bug Log filter associated to this bug has been updated:

{- APL KBL: igt@kms_content_protection@(lic|srm) fail - Failed assertion: ret, Content Protection not enabled -}
{+ APL KBL: igt@kms_content_protection@(lic|srm) fail - Failed assertion: ret, Content Protection not enabled +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_338/fi-skl-gvtdvm/igt@kms_content_protection@srm.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_338/fi-skl-lmem/igt@kms_content_protection@srm.html
Comment 12 CI Bug Log 2019-08-09 08:43:32 UTC
A CI Bug Log filter associated to this bug has been updated:

{- APL KBL: igt@kms_content_protection@(lic|srm) fail - Failed assertion: ret, Content Protection not enabled -}
{+ APL SKL KBL: igt@kms_content_protection@(lic|srm) fail - Failed assertion: ret, Content Protection not enabled +}


  No new failures caught with the new filter
Comment 13 CI Bug Log 2019-08-09 09:43:37 UTC
A CI Bug Log filter associated to this bug has been updated:

{- APL SKL KBL: igt@kms_content_protection@* - fail - Content Protection not enabled, KSV list failed to become ready (-110) -}
{+ APL SKL KBL: igt@kms_content_protection@* - fail - Content Protection not enabled, KSV list failed to become ready (-110) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_338/fi-cfl-8109u/igt@kms_content_protection@srm.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_338/fi-cfl-8109u/igt@kms_content_protection@lic.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.