Bug 110431 - Please add support for GL_EXT_gpu_shader4 (including on non-core profiles)
Summary: Please add support for GL_EXT_gpu_shader4 (including on non-core profiles)
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 18.3
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
: 110492 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-15 08:42 UTC by Michael
Modified: 2019-04-25 01:44 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2019-04-15 08:42:27 UTC
Certain applications (eg. most Minecraft shaders, Substance Painter, and probably a bunch of other games) tend to assume that GL_EXT_gpu_shader4 is supported everywhere. This makes Mesa (and particularly AMDGPU) users sad, as shaders won't work, instead filling logs with messages like "warning: extension `GL_EXT_gpu_shader4' unsupported in fragment shader" and "error: no function with name 'texelFetch2D'".

(Hopefully I tagged the right component...)
Comment 1 Timothy Arceri 2019-04-22 23:36:46 UTC
*** Bug 110492 has been marked as a duplicate of this bug. ***
Comment 2 Timothy Arceri 2019-04-23 00:39:51 UTC
Merge request for this extension:

https://gitlab.freedesktop.org/mesa/mesa/merge_requests/667
Comment 3 Timothy Arceri 2019-04-25 01:44:16 UTC
Should be fixed as of:

commit	e71936a731a93ddfb3325c41a5a9756175020ee9
author	Marek Olšák <marek.olsak@amd.com>

   st/mesa: expose EXT_gpu_shader4 if GLSL 1.40 is supported

   Tested-by: Dieter Nützel <Dieter@nuetzel-hh.de>
   Reviewed-by: Eric Anholt <eric@anholt.net>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.