Bug 110492 - Mesa reports old GLSL version to programms using an older OpenGL version
Summary: Mesa reports old GLSL version to programms using an older OpenGL version
Status: RESOLVED DUPLICATE of bug 110431
Alias: None
Product: Mesa
Classification: Unclassified
Component: glsl-compiler (show other bugs)
Version: 19.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-22 12:03 UTC by Alexmitter
Modified: 2019-04-22 23:36 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexmitter 2019-04-22 12:03:09 UTC
Sorry if I am in the wrong section here.
There is an old case that effects an old OpenGl Application, Minecraft to be precise with Shadermods that use an newer GLSL version. Unlike other OpenGL Stacks, Mesa seems to only report an GLSL to the application that matches the OpenGL version on release date. In this special case, overwriting the GLSL seems to do nothing, probably due to the new electron launcher as it seem to have worked with the older java based one.
Here in a thread about this issue on the shadermods bugtracker: https://github.com/sp614x/optifine/issues/420https://github.com/sp614x/optifine/issues/420
Comment 1 Timothy Arceri 2019-04-22 23:36:46 UTC

*** This bug has been marked as a duplicate of bug 110431 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.