Bug 110532 - [CI][BAT] igt@kms_chamelium@dp-hpd* - fail - Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT)
Summary: [CI][BAT] igt@kms_chamelium@dp-hpd* - fail - Failed assertion: igt_hotplug_de...
Status: CLOSED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: highest normal
Assignee: Imre Deak
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 110553 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-26 11:00 UTC by Martin Peres
Modified: 2019-04-30 10:47 UTC (History)
3 users (show)

See Also:
i915 platform: ICL
i915 features: display/DP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-04-26 11:00:43 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4967/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html

Starting subtest: dp-hpd-fast
(kms_chamelium:2921) CRITICAL: Test assertion failure function test_basic_hotplug, file ../tests/kms_chamelium.c:241:
(kms_chamelium:2921) CRITICAL: Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT)
Subtest dp-hpd-fast failed.
Comment 1 Martin Peres 2019-04-26 11:01:55 UTC
This issue is happening on fi-icl-u2, which now tests DP hotplugs by going through the type-C controler.

Assigning to Imre!
Comment 2 CI Bug Log 2019-04-26 11:02:09 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-icl-u2: igt@kms_chamelium@dp-hpd* - fail - Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT)
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12883/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2925/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12884/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4967/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12873/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2919/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12874/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12876/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4209/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_265/fi-icl-u2/igt@kms_chamelium@dp-hpd.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_265/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12878/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12879/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/IGTPW_2923/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Trybot_4210/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - http://gfx-ci.fi.intel.com/tree/drm-tip/CUSTOM_mupuf-1556197492/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/Patchwork_12881/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
  - http://gfx-ci.fi.intel.com/tree/drm-tip/CUSTOM_mupuf-1556198305/fi-icl-u2/igt@kms_chamelium@dp-hpd-fast.html
Comment 3 Martin Peres 2019-04-26 11:11:36 UTC
Could also be that Tomi forgot to change the configuration?
Comment 4 Imre Deak 2019-04-26 11:25:16 UTC
There looks to be an HDMI sink connected at least:

<7>[   11.242597] [drm:drm_add_edid_modes] ELD monitor AthenaDP
<7>[   11.242599] [drm:drm_add_edid_modes] ELD size 32, SAD count 1
<7>[   11.242602] [drm:drm_add_display_info] non_desktop set to 0
<7>[   11.242882] [drm:drm_helper_probe_single_connector_modes] [CONNECTOR:210:HDMI-A-2] probed modes

Then during the Chamelium test this same sink is disconnected:

<6> [470.747951] [IGT] kms_chamelium: starting subtest dp-hpd-fast
<7> [471.280403] [drm:gen8_de_irq_handler [i915]] hotplug event received, stat 0x01000000, dig 0x0000888a, pins 0x00000040, long 0x00000040
<7> [471.280512] [drm:intel_hpd_irq_handler [i915]] Received HPD interrupt on PIN 6 - cnt: 10
<7> [471.281116] [drm:i915_hotplug_work_func [i915]] running encoder hotplug functions
<7> [471.281527] [drm:i915_hotplug_work_func [i915]] Connector HDMI-A-2 (pin 6) received hotplug event.
<7> [471.281804] [drm:intel_hdmi_detect [i915]] [CONNECTOR:210:HDMI-A-2]

So yes, I believe Chamelium is plugged to the wrong connector.
Comment 5 Tomi Sarvela 2019-04-29 08:01:53 UTC
The configuration was:

[Chamelium:DP-2]
ChameliumPortID=1

I changed the configuration to following:

[Chamelium:DP-1]
ChameliumPortID=1

(ChameliumPortID=1 is the one beside Chamelium HDMI port. ID=2 is next to VGA port, not used in this configuration)
Comment 6 CI Bug Log 2019-04-29 11:43:58 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: igt@kms_chamelium@dp-hpd* - fail - Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT) -}
{+ fi-icl-u2: igt@kms_chamelium@dp-hpd* - fail - Failed assertion: igt_hotplug_detected(mon, HOTPLUG_TIMEOUT) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_267/fi-icl-u2/igt@kms_chamelium@dp-hpd-after-suspend.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_268/fi-icl-u2/igt@kms_chamelium@dp-hpd-after-suspend.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_269/fi-icl-u2/igt@kms_chamelium@dp-hpd-after-suspend.html
Comment 7 Imre Deak 2019-04-30 08:03:58 UTC
*** Bug 110553 has been marked as a duplicate of this bug. ***
Comment 8 Jani Saarinen 2019-04-30 10:46:57 UTC
Configuration was wrong on system. DP was disabled in BIOS. Should be now fixed


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.