Bug 110553 - [CI][DRMTIP] igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion: igt_hpd_storm_detected(data->drm_fd)
Summary: [CI][DRMTIP] igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion: igt_hp...
Status: RESOLVED DUPLICATE of bug 110532
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Imre Deak
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-30 06:19 UTC by Lakshmi
Modified: 2019-08-06 08:45 UTC (History)
1 user (show)

See Also:
i915 platform: ICL
i915 features: display/DP


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-04-30 06:19:01 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_269/fi-icl-u2/igt@kms_chamelium@dp-hpd-storm.html

	
Starting subtest: dp-hpd-storm
(kms_chamelium:1373) CRITICAL: Test assertion failure function test_hpd_storm_detect, file ../tests/kms_chamelium.c:1513:
(kms_chamelium:1373) CRITICAL: Failed assertion: igt_hpd_storm_detected(data->drm_fd)
Subtest dp-hpd-storm failed.
**** DEBUG ****
(kms_chamelium:1373) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(kms_chamelium:1373) igt_debugfs-DEBUG: Test requirement passed: fd > 0
(kms_chamelium:1373) igt_chamelium-DEBUG: Resetting the chamelium
(kms_chamelium:1373) DEBUG: Waiting for DP-2 to disconnect...
(kms_chamelium:1373) DEBUG: Reprobing DP-2...
(kms_chamelium:1373) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(kms_chamelium:1373) igt_debugfs-DEBUG: Setting HPD storm threshold to 1
(kms_chamelium:1373) igt_chamelium-DEBUG: Firing 10 HPD pulses with width of 100 msec on DP-2
(kms_chamelium:1373) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(kms_chamelium:1373) CRITICAL: Test assertion failure function test_hpd_storm_detect, file ../tests/kms_chamelium.c:1513:
(kms_chamelium:1373) CRITICAL: Failed assertion: igt_hpd_storm_detected(data->drm_fd)
(kms_chamelium:1373) igt_core-INFO: Stack trace:
(kms_chamelium:1373) igt_core-INFO:   #0 ../lib/igt_core.c:1476 __igt_fail_assert()
(kms_chamelium:1373) igt_core-INFO:   #1 ../tests/kms_chamelium.c:1515 test_hpd_storm_detect()
(kms_chamelium:1373) igt_core-INFO:   #2 ../tests/kms_chamelium.c:1617 __real_main1557()
(kms_chamelium:1373) igt_core-INFO:   #3 ../tests/kms_chamelium.c:1557 main()
(kms_chamelium:1373) igt_core-INFO:   #4 ../csu/libc-start.c:344 __libc_start_main()
(kms_chamelium:1373) igt_core-INFO:   #5 [_start+0x2a]
****  END  ****
Subtest dp-hpd-storm: FAIL (2.038s)
Comment 1 Lakshmi 2019-04-30 06:21:57 UTC
There is a similar Bug 109520 on KBL for igt@kms_chamelium@hdmi-hpd-storm.
Comment 3 Imre Deak 2019-04-30 08:03:58 UTC
Nothing seems to be connected to the DP connector. On the other hand there is something connected to the HDMI connector, so I suspect misconfiguration. As such it is a dup of bug 110532.

*** This bug has been marked as a duplicate of bug 110532 ***
Comment 4 CI Bug Log 2019-07-22 08:54:45 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ICL: igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion: igt_hpd_storm_detected(data->drm_fd) -}
{+ fi-icl-u4: igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion: igt_hpd_storm_detected(data->drm_fd) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_326/fi-icl-u4/igt@kms_chamelium@hdmi-hpd-storm.html
Comment 5 CI Bug Log 2019-07-22 08:55:09 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u4: igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion: igt_hpd_storm_detected(data->drm_fd) -}
{+ fi-icl-u4: igt@kms_chamelium@(hdmi|dp)-hpd-storm - fail - Failed assertion: igt_hpd_storm_detected(data->drm_fd) +}


  No new failures caught with the new filter
Comment 6 Lakshmi 2019-07-22 08:58:37 UTC
(In reply to CI Bug Log from comment #4)
> A CI Bug Log filter associated to this bug has been updated:
> 
> {- ICL: igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion:
> igt_hpd_storm_detected(data->drm_fd) -}
> {+ fi-icl-u4: igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion:
> igt_hpd_storm_detected(data->drm_fd) +}
> 
> New failures caught by the filter:
> 
>   *
> https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_326/fi-icl-u4/
> igt@kms_chamelium@hdmi-hpd-storm.html

This issue is still happening and Bug 110532 is closed as Invalid (there were no new failures recently related to Bug 110532).

@Imre, Should we reopen this bug?
Comment 7 Imre Deak 2019-08-05 13:26:52 UTC
(In reply to Lakshmi from comment #6)
> (In reply to CI Bug Log from comment #4)
> > A CI Bug Log filter associated to this bug has been updated:
> > 
> > {- ICL: igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion:
> > igt_hpd_storm_detected(data->drm_fd) -}
> > {+ fi-icl-u4: igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion:
> > igt_hpd_storm_detected(data->drm_fd) +}
> > 
> > New failures caught by the filter:
> > 
> >   *
> > https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_326/fi-icl-u4/
> > igt@kms_chamelium@hdmi-hpd-storm.html
> 
> This issue is still happening and Bug 110532 is closed as Invalid (there
> were no new failures recently related to Bug 110532).
> 
> @Imre, Should we reopen this bug?

This is a different issue from the one reported on the bug originally. The reason is the same as in bug 111045: on a USB-C connector with output enabled on it the HW won't deliver any interrupts after a plug-out interrupt (until the output gets disabled on the connector). Based on this I suggested adding this subtest (on fi-ucl-u4) to bug 111045 as well.
Comment 8 CI Bug Log 2019-08-06 08:45:44 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u4: igt@kms_chamelium@(hdmi|dp)-hpd-storm - fail - Failed assertion: igt_hpd_storm_detected(data->drm_fd) -}
{+ fi-icl-u4: igt@kms_chamelium@dp-hpd-storm - fail - Failed assertion: igt_hpd_storm_detected(data->drm_fd) +}


  No new failures caught with the new filter


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.