Bug 111147 - Processing of SPIR-V shader leads to display/machine freeze
Summary: Processing of SPIR-V shader leads to display/machine freeze
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/radeon (show other bugs)
Version: git
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-16 10:18 UTC by Alastair Donaldson
Modified: 2019-09-04 07:59 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
A (11.68 KB, text/plain)
2019-07-16 10:18 UTC, Alastair Donaldson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alastair Donaldson 2019-07-16 10:18:07 UTC
Created attachment 144796 [details]
A
Comment 1 Alastair Donaldson 2019-07-16 10:21:15 UTC
Running the attached test using Amber (https://github.com/google/amber):

amber -d unreachable-barrier-in-loops.amber

should lead to the test passing.

Instead, I find that my system immediately locks up.  I believe it is a whole system freeze, rather than just a display freeze.

Build: Mesa 19.2.0-devel (git-a110a8090d) (Debug)
Device: Radeon RX Vega
Comment 2 Samuel Iglesias Gonsálvez 2019-08-26 07:01:35 UTC
I can reproduce the failure with your Mesa HEAD, however current Mesa master branch (git-4379dcc12d) passes the test. Please re-test.

Operating System: Ubuntu 18.04
Linux kernel: 5.0.0-23-generic
Mesa: 19.3.0-devel (git-4379dcc12d)
GPU: AMD RADV POLARIS10 (LLVM 8.0.1)
Comment 3 Samuel Iglesias Gonsálvez 2019-08-26 07:02:47 UTC
(In reply to Alastair Donaldson from comment #1)
> Running the attached test using Amber (https://github.com/google/amber):
> 
> amber -d unreachable-barrier-in-loops.amber
> 
> should lead to the test passing.
> 
> Instead, I find that my system immediately locks up.  I believe it is a
> whole system freeze, rather than just a display freeze.
> 

Regarding this, it's probably a GPU hang in your computer. I have enabled amdgpu.gpu_recovery=1 functionality to avoid it.

> Build: Mesa 19.2.0-devel (git-a110a8090d) (Debug)
> Device: Radeon RX Vega
Comment 4 Alastair Donaldson 2019-09-04 07:59:17 UTC
I can confirm that the test passes for me on master, so I guess we should close this issue; I'll open another one if it turns out the issue still persists and can be exposed by a different test.

Thanks for the advice regarding GPU recovery.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.