Bug 111186 - [CI][DRMTIP] igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type)
Summary: [CI][DRMTIP] igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enabl...
Status: RESOLVED DUPLICATE of bug 110580
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-22 11:08 UTC by Lakshmi
Modified: 2019-09-11 05:29 UTC (History)
3 users (show)

See Also:
i915 platform: ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-07-22 11:08:41 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_326/fi-icl-u2/igt@i915_pm_rpm@modeset-non-lpsp.html

	
Runtime PM support: 1
PC8 residency support: 0
DMC: fw loaded: yes
i915_runtime_pm_status:
Runtime power status: enabled
GPU idle: yes
IRQs disabled: no
Usage count: 1
PCI device power state: D0 [0]
Wakeref last acquired:
   track_intel_runtime_pm_wakeref+0x14/0x90 [i915]
   intel_atomic_commit+0x32/0x2f0 [i915]
   drm_atomic_helper_set_config+0x61/0x90
   drm_mode_setcrtc+0x199/0x710
   drm_ioctl_kernel+0x83/0xf0
   drm_ioctl+0x2f3/0x3b0
   do_vfs_ioctl+0xa0/0x6e0
   ksys_ioctl+0x35/0x60
Wakeref last released:
   __untrack_all_wakerefs+0x67/0x70 [i915]
   __intel_wakeref_dec_and_check_tracking+0x61/0x80 [i915]
   __intel_runtime_pm_put+0x11a/0x260 [i915]
   intel_atomic_commit_tail+0x767/0x1520 [i915]
   intel_atomic_commit+0x273/0x2f0 [i915]
   drm_atomic_helper_set_config+0x61/0x90
   drm_mode_setcrtc+0x199/0x710
   drm_ioctl_kernel+0x83/0xf0
Wakeref count: 0
Starting subtest: modeset-non-lpsp
Test requirement not met in function modeset_subtest, file ../tests/i915/i915_pm_rpm.c:885:
Test requirement: enable_one_screen_with_type(&ms_data, type)
Last errno: 2, No such file or directory
Subtest modeset-non-lpsp: SKIP (3.823s)
Comment 1 Lakshmi 2019-07-22 11:14:34 UTC
There were similar bugs like Bug 109308 and Bug 110892 which are closed as NOTOURBUG. But this skip is on fi-icl-u2 which was never skipping.
Comment 2 Lakshmi 2019-07-22 11:15:02 UTC
(In reply to Lakshmi from comment #1)
> There were similar bugs like Bug 109308 and Bug 110892 which are closed as
> NOTOURBUG. But this skip is on fi-icl-u2 which was never skipping.

@Petri, can you confirm if this is a valid bug?
Comment 3 CI Bug Log 2019-07-22 11:16:22 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type)
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_326/fi-icl-u2/igt@i915_pm_rpm@modeset-non-lpsp.html
Comment 4 Petri Latvala 2019-07-22 11:29:49 UTC
(In reply to Lakshmi from comment #2)
> (In reply to Lakshmi from comment #1)
> > There were similar bugs like Bug 109308 and Bug 110892 which are closed as
> > NOTOURBUG. But this skip is on fi-icl-u2 which was never skipping.
> 
> @Petri, can you confirm if this is a valid bug?

What display does fi-icl-u2 have? non-lpsp requires a non-eDP display. If icl-u2 only has an eDP display, this is a valid skip.
Comment 5 Arek Hiler 2019-07-23 10:17:17 UTC
fi-icl-u2 has chamelium connected, so it has non-eDP displays.

The skip is probably caused by Chamelium board reset. The default state for ports is "disconnected", so if a reset happens and we do not run any kms_chamelium test first the connectors are considered disconnected. We probably hit that here.

There may be some other issues when it comes to the port state but this seems to be the most likely one and should be dealt with first. Luckily Simon Ser is already working on the required changes.

This bug can be merged with other, similar bugs. I remember seeing a few of those with a similar root cause.
Comment 6 CI Bug Log 2019-07-24 14:54:40 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) -}
{+ fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_333/fi-icl-u2/igt@i915_pm_rpm@dpms-non-lpsp.html
Comment 7 Jyoti Yadav 2019-07-29 08:39:13 UTC
In the dmesg could see only eDP connected, for other connectors, status remain "disconnected". 
@Simon Ser, did you get any update here.
Comment 8 CI Bug Log 2019-08-19 08:18:58 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) -}
{+ fi-icl-u4 fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@i915_pm_rpm@modeset-non-lpsp.html
Comment 9 CI Bug Log 2019-08-19 09:24:34 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u4 fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) -}
{+ fi-icl-u4 fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@i915_pm_rpm@modeset-non-lpsp-stress.html
Comment 10 CI Bug Log 2019-08-19 09:25:48 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u4 fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) -}
{+ fi-icl-u4 fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@i915_pm_rpm@modeset-non-lpsp-stress-no-wait.html
Comment 11 CI Bug Log 2019-09-02 10:07:12 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u4 fi-icl-u2: igt@i915_pm_rpm@modeset-non-lpsp -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) -}
{+ fi-icl-u4 fi-icl-u2: igt@i915_pm_rpm@(dpms|modeset)-* -skip - Test requirement: enable_one_screen_with_type(&ms_data, type) +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@i915_pm_rpm@dpms-mode-unset-non-lpsp.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@i915_pm_rpm@dpms-mode-unset-non-lpsp.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@i915_pm_rpm@dpms-mode-unset-non-lpsp.html
Comment 12 emersion 2019-09-04 10:43:10 UTC

*** This bug has been marked as a duplicate of bug 110940 ***
Comment 13 Arek Hiler 2019-09-05 10:27:07 UTC

*** This bug has been marked as a duplicate of bug 110580 ***
Comment 14 Jyoti Yadav 2019-09-06 07:17:50 UTC
@simon.ser@intel.com, Please letus know the results with below patch.

https://patchwork.freedesktop.org/series/65292/
Comment 15 emersion 2019-09-06 09:45:09 UTC
(In reply to Jyoti Yadav from comment #14)
> @simon.ser@intel.com, Please letus know the results with below patch.
> 
> https://patchwork.freedesktop.org/series/65292/

See bug 110580, we still see the issue.
Comment 16 Jyoti Yadav 2019-09-11 05:29:47 UTC
any update here?


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.