Bug 110940 - igt@kms_* - skip - No second valid output found / Can't test dual pipes with the current outputs/hould have at least 2 outputs, found 1
Summary: igt@kms_* - skip - No second valid output found / Can't test dual pipes with ...
Status: RESOLVED DUPLICATE of bug 110580
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: emersion
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-18 10:10 UTC by Martin Peres
Modified: 2019-09-09 11:09 UTC (History)
3 users (show)

See Also:
i915 platform: CFL, ICL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2019-06-18 10:10:18 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_306/fi-icl-u2/igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-cur-indfb-draw-blt.html

Test requirement not met in function check_test_requirements, file ../tests/kms_frontbuffer_tracking.c:1719:
Test requirement: scnd_mode_params.output
Can't test dual pipes with the current outputs
Subtest fbc-2p-scndscrn-cur-indfb-draw-blt: SKIP (0.000s)
Comment 1 Martin Peres 2019-06-18 10:14:10 UTC
The machine has 3 displays connected and it is currently reporting 3 displays.

Tomi says he has not changed the configuration of the machine last week. Assigning Jani because he may have updated the BIOS without and forgot to re-enable DP.

We need to know what changed on this machine, and if nothing changed, then we have a problem in our driver that would prevent connectors from being discovered.

Plenty of issues to fix here to prevent future issues like this!
Comment 2 CI Bug Log 2019-06-18 10:14:36 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-icl-u2: random tests - skip - Can't test dual pipes with the current outputs / No second valid output found
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_306/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-varying-size.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_306/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-toggle.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_306/fi-icl-u2/igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-cur-indfb-draw-blt.html
Comment 3 Jani Saarinen 2019-06-18 10:36:28 UTC
NO, have not done anything.
Comment 4 Jani Saarinen 2019-06-19 13:20:37 UTC
This seems to be some random issue as on same run all other tests pass:
[12/91] (860s left) kms_frontbuffer_tracking (fbcpsr-2p-scndscrn-spr-indfb-fullscreen)
Starting subtest: fbcpsr-2p-scndscrn-spr-indfb-fullscreen
Subtest fbcpsr-2p-scndscrn-spr-indfb-fullscreen: SUCCESS (4.095s)
[26/91] (818s left) kms_frontbuffer_tracking (psr-2p-scndscrn-cur-indfb-draw-pwrite)
Starting subtest: psr-2p-scndscrn-cur-indfb-draw-pwrite
Subtest psr-2p-scndscrn-cur-indfb-draw-pwrite: SUCCESS (4.584s)
[27/91] (813s left) kms_frontbuffer_tracking (psr-2p-scndscrn-spr-indfb-onoff)
Starting subtest: psr-2p-scndscrn-spr-indfb-onoff
Subtest psr-2p-scndscrn-spr-indfb-onoff: SUCCESS (5.191s)
[38/91] (552s left) kms_frontbuffer_tracking (fbcpsr-2p-primscrn-spr-indfb-onoff)
Starting subtest: fbcpsr-2p-primscrn-spr-indfb-onoff
Subtest fbcpsr-2p-primscrn-spr-indfb-onoff: SUCCESS (5.991s)
[69/91] (109s left) kms_frontbuffer_tracking (fbc-2p-scndscrn-pri-shrfb-draw-mmap-cpu)
Starting subtest: fbc-2p-scndscrn-pri-shrfb-draw-mmap-cpu
Subtest fbc-2p-scndscrn-pri-shrfb-draw-mmap-cpu: SUCCESS (2.707s)

Starting subtest: pipe-A-cursor-128x128-onscreen
Subtest pipe-A-cursor-128x128-onscreen: SUCCESS (6.783s)
[86/91] ( 29s left) kms_frontbuffer_tracking (fbc-2p-scndscrn-cur-indfb-draw-blt)
Starting subtest: fbc-2p-scndscrn-cur-indfb-draw-blt
Subtest fbc-2p-scndscrn-cur-indfb-draw-blt: SKIP (0.000s)

I would call this invalid bug?
Comment 5 Jani Saarinen 2019-06-19 13:25:41 UTC
Also next runs again:
IGT: igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-cur-indfb-draw-blt	fi-icl-u2	IGT: notrun (external URL)	drmtip_311 (7 hours, 44 minutes old)	
None
IGT: igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-cur-indfb-draw-blt	fi-icl-u2	IGT: pass (external URL)	drmtip_309 (2 days, 5 hours old)	
None
IGT: igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-cur-indfb-draw-blt	fi-icl-u2	IGT: pass (external URL)	drmtip_308 (3 days, 22 hours old)
Comment 6 Martin Peres 2019-06-20 07:34:42 UTC
(In reply to Jani Saarinen from comment #4)
> This seems to be some random issue as on same run all other tests pass:
> [12/91] (860s left) kms_frontbuffer_tracking
> (fbcpsr-2p-scndscrn-spr-indfb-fullscreen)
> Starting subtest: fbcpsr-2p-scndscrn-spr-indfb-fullscreen
> Subtest fbcpsr-2p-scndscrn-spr-indfb-fullscreen: SUCCESS (4.095s)
> [26/91] (818s left) kms_frontbuffer_tracking
> (psr-2p-scndscrn-cur-indfb-draw-pwrite)
> Starting subtest: psr-2p-scndscrn-cur-indfb-draw-pwrite
> Subtest psr-2p-scndscrn-cur-indfb-draw-pwrite: SUCCESS (4.584s)
> [27/91] (813s left) kms_frontbuffer_tracking
> (psr-2p-scndscrn-spr-indfb-onoff)
> Starting subtest: psr-2p-scndscrn-spr-indfb-onoff
> Subtest psr-2p-scndscrn-spr-indfb-onoff: SUCCESS (5.191s)
> [38/91] (552s left) kms_frontbuffer_tracking
> (fbcpsr-2p-primscrn-spr-indfb-onoff)
> Starting subtest: fbcpsr-2p-primscrn-spr-indfb-onoff
> Subtest fbcpsr-2p-primscrn-spr-indfb-onoff: SUCCESS (5.991s)
> [69/91] (109s left) kms_frontbuffer_tracking
> (fbc-2p-scndscrn-pri-shrfb-draw-mmap-cpu)
> Starting subtest: fbc-2p-scndscrn-pri-shrfb-draw-mmap-cpu
> Subtest fbc-2p-scndscrn-pri-shrfb-draw-mmap-cpu: SUCCESS (2.707s)
> 
> Starting subtest: pipe-A-cursor-128x128-onscreen
> Subtest pipe-A-cursor-128x128-onscreen: SUCCESS (6.783s)
> [86/91] ( 29s left) kms_frontbuffer_tracking
> (fbc-2p-scndscrn-cur-indfb-draw-blt)
> Starting subtest: fbc-2p-scndscrn-cur-indfb-draw-blt
> Subtest fbc-2p-scndscrn-cur-indfb-draw-blt: SKIP (0.000s)
> 
> I would call this invalid bug?

Sorry, but the bug is very valid. It happened 3 times in the same shard...

As you said IRL, some of the *2p* tests are passing on the same shard, which might exclude HW change (unless someone rebooted the chamelium while running the shard).

So, we now need to investigate in the kernel logs what might have happened. Disappearing outputs is cause for concern.
Comment 7 Maarten Lankhorst 2019-06-20 08:55:06 UTC
From same run:

<7>[  976.611853] [drm:drm_helper_probe_single_connector_modes] [CONNECTOR:210:HDMI-A-2]
<7>[  976.611890] [drm:intel_hdmi_detect [i915]] [CONNECTOR:210:HDMI-A-2]
<7>[  976.638788] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK for addr: 0040 w(1)
<7>[  976.638826] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK on first message, retry
<7>[  976.639091] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK for addr: 0040 w(1)
<7>[  976.639096] [drm:drm_dp_dual_mode_detect] DP dual mode HDMI ID:  (err -6)
<7>[  976.639100] [drm:drm_detect_monitor_audio] Monitor has basic audio support
<7>[  976.639104] [drm:drm_add_display_info] non_desktop set to 0
<7>[  976.639133] [drm:drm_add_edid_modes] ELD monitor AthenaDP
<7>[  976.639136] [drm:drm_add_edid_modes] ELD size 32, SAD count 1
<7>[  976.639138] [drm:drm_add_display_info] non_desktop set to 0

<7>[  992.181484] [drm:drm_helper_probe_single_connector_modes] [CONNECTOR:210:HDMI-A-2]
<7>[  992.181516] [drm:intel_hdmi_detect [i915]] [CONNECTOR:210:HDMI-A-2]
<7>[  992.181784] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK for addr: 0050 w(1)
<7>[  992.181812] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK on first message, retry
<7>[  992.182075] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK for addr: 0050 w(1)
<7>[  992.182078] [drm:drm_do_probe_ddc_edid] drm: skipping non-existent adapter i915 gmbus tc1
<7>[  992.182105] [drm:intel_hdmi_set_edid [i915]] HDMI GMBUS EDID read failed, retry using GPIO bit-banging
<7>[  992.182132] [drm:intel_gmbus_force_bit [i915]] enabling bit-banging on i915 gmbus tc1. force bit now 1
<7>[  992.187980] [drm:drm_do_probe_ddc_edid] drm: skipping non-existent adapter i915 gmbus tc1
<7>[  992.188007] [drm:intel_gmbus_force_bit [i915]] disabling bit-banging on i915 gmbus tc1. force bit now 0
<7>[  992.188254] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK for addr: 0040 w(1)
<7>[  992.188280] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK on first message, retry
<7>[  992.188603] [drm:do_gmbus_xfer [i915]] GMBUS [i915 gmbus tc1] NAK for addr: 0040 w(1)
<7>[  992.188607] [drm:drm_dp_dual_mode_detect] DP dual mode HDMI ID:  (err -6)
<7>[  992.188611] [drm:drm_helper_probe_single_connector_modes] [CONNECTOR:210:HDMI-A-2] disconnected
Comment 8 emersion 2019-06-20 12:27:37 UTC
Possible duplicate: https://bugs.freedesktop.org/show_bug.cgi?id=110881
Comment 9 emersion 2019-06-20 13:26:02 UTC
I thought that maybe this is an issue with the Chamelium teardown sequence. However it doesn't seem to be the case.

* * *

More details:

We rely on the Chamelium board for providing additional outputs. However by default all Chamelium ports are disabled (unplugged). One needs to send a Plug call to the Chamelium API to enable them.

(Side note: rebooting the Chamelium will disable all Chamelium ports)

In order to be able to use these ports, we need to re-enable them after all audio tests. This is something we do in chamelium_exit_handler. I checked that it's properly executed after a failed test.
Comment 11 CI Bug Log 2019-07-04 12:42:36 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found -}
{+ fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_320/fi-icl-u2/igt@kms_frontbuffer_tracking@fbcpsr-2p-scndscrn-indfb-msflip-blt.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_320/fi-icl-u2/igt@kms_frontbuffer_tracking@fbcpsr-2p-primscrn-cur-indfb-draw-render.html
Comment 12 CI Bug Log 2019-07-08 07:51:42 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found -}
{+ fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_321/fi-icl-u2/igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-pri-indfb-draw-mmap-cpu.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_321/fi-icl-u2/igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-spr-indfb-onoff.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_321/fi-icl-u2/igt@kms_frontbuffer_tracking@fbcpsr-2p-scndscrn-pri-indfb-draw-pwrite.html
Comment 13 CI Bug Log 2019-07-16 09:04:32 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found -}
{+ fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_322/fi-icl-u2/igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-cur-indfb-draw-render.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_322/fi-icl-u2/igt@kms_frontbuffer_tracking@psr-2p-primscrn-shrfb-pgflip-blt.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_322/fi-icl-u2/igt@kms_frontbuffer_tracking@fbcpsr-2p-scndscrn-spr-indfb-draw-pwrite.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_322/fi-icl-u2/igt@kms_frontbuffer_tracking@psr-2p-primscrn-pri-shrfb-draw-mmap-gtt.html
Comment 14 CI Bug Log 2019-07-17 10:44:38 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found -}
{+ fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_323/fi-icl-u2/igt@kms_cursor_legacy@2x-long-flip-vs-cursor-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_323/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-varying-size.html
Comment 17 emersion 2019-07-23 14:04:44 UTC
Today I pinged Google about this. Chromium issue: https://bugs.chromium.org/p/chromium/issues/detail?id=977994
Comment 18 emersion 2019-07-23 14:05:01 UTC
*** Bug 110881 has been marked as a duplicate of this bug. ***
Comment 21 CI Bug Log 2019-07-25 12:28:24 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found -}
{+ fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found +}


  No new failures caught with the new filter
Comment 22 CI Bug Log 2019-08-12 12:00:10 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-cml-u2: igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing - skip - hould have at least 2 outputs, found 1, SKIP
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_340/fi-cml-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing.html
Comment 23 CI Bug Log 2019-08-15 07:36:21 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found -}
{+ fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_343/fi-icl-u2/igt@kms_frontbuffer_tracking@psr-2p-primscrn-pri-indfb-draw-blt.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_343/fi-icl-u2/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-cur-indfb-draw-pwrite.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_343/fi-icl-u2/igt@kms_frontbuffer_tracking@psr-2p-scndscrn-pri-shrfb-draw-pwrite.html
Comment 24 emersion 2019-08-16 13:29:19 UTC
Related, may fix this issue: https://patchwork.freedesktop.org/series/65292/
Comment 25 CI Bug Log 2019-08-19 06:51:26 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-cml-u2: igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing - skip - hould have at least 2 outputs, found 1, SKIP -}
{+ fi-cml-u2: igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing - skip - hould have at least 2 outputs, found 1, SKIP +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_345/fi-cml-u2/igt@kms_atomic_transition@2x-modeset-transitions-fencing.html
Comment 26 CI Bug Log 2019-08-19 09:33:46 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-icl-u4: igt@kms_atomic_transition@2x-modeset-transitions-(nonblocking|fencing) - SKIP - Should have at least 2 outputs, found 1, skip
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_atomic_transition@2x-modeset-transitions-fencing.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_346/fi-icl-u4/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking.html
Comment 27 CI Bug Log 2019-09-02 06:33:59 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found -}
{+ fi-icl-u2: random tests - skip - Can&#39;t test dual pipes with the current outputs / No second valid output found +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic-transitions.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@2x-flip-vs-cursor-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@2x-long-flip-vs-cursor-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic-transitions.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic-transitions-varying-size.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@2x-long-cursor-vs-flip-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@2x-cursor-vs-flip-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipa-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@2x-long-cursor-vs-flip-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-toggle.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic-transitions-varying-size.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@2x-flip-vs-cursor-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@2x-long-flip-vs-cursor-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic-transitions.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic-transitions-varying-size.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@2x-long-cursor-vs-flip-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@2x-cursor-vs-flip-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipa-atomic-transitions-varying-size.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipa-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@2x-long-cursor-vs-flip-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-toggle.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic-transitions-varying-size.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipa-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@2x-flip-vs-cursor-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic-transitions.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic-transitions.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@2x-cursor-vs-flip-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipa-atomic-transitions-varying-size.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipa-toggle.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@2x-long-cursor-vs-flip-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-atomic-transitions-varying-size.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@2x-cursor-vs-flip-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@2x-long-flip-vs-cursor-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@2x-long-cursor-vs-flip-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipa-legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@2x-flip-vs-cursor-atomic.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursora-vs-flipb-toggle.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_cursor_legacy@cursorb-vs-flipb-atomic-transitions-varying-size.html
Comment 28 Lakshmi 2019-09-02 07:01:31 UTC
This issue is occurring 100% and causing lot of tests to skip even though fi-icl-u2 has two display's connected.
Comment 29 CI Bug Log 2019-09-02 07:38:12 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-icl-u2:  igt@kms_atomic_transition@2x-* - skip - Should have at least 2 outputs, found 1, SKIP
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_355/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-fencing.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_356/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-fencing.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-fencing.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking.html
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_354/fi-icl-u2/igt@kms_atomic_transition@2x-modeset-transitions.html
Comment 30 emersion 2019-09-04 10:43:10 UTC
*** Bug 111186 has been marked as a duplicate of this bug. ***
Comment 31 emersion 2019-09-04 13:25:02 UTC
Applied the workaround described in https://bugs.chromium.org/p/chromium/issues/detail?id=977994#c4 to fi-icl-u2's chamelium board.

Will monitor CI results to see if it mitigates the issue.

If not, maybe a better solution would be to enable all ports before running IGT tests.
Comment 32 Jani Saarinen 2019-09-04 14:33:47 UTC
Thanks Simon,
Comment 33 Arek Hiler 2019-09-05 10:27:36 UTC

*** This bug has been marked as a duplicate of bug 110580 ***
Comment 34 CI Bug Log 2019-09-09 11:09:07 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-cml-u2: igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing - skip - hould have at least 2 outputs, found 1, SKIP -}
{+ fi-cml-u2: igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing - skip - Should have at least 2 outputs, found 1, SKIP +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_363/fi-cml-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_364/fi-cml-u2/igt@kms_atomic_transition@2x-modeset-transitions-nonblocking.html
Comment 35 CI Bug Log 2019-09-09 11:09:40 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-cml-u2: igt@kms_atomic_transition@2x-modeset-transitions-nonblocking-fencing - skip - Should have at least 2 outputs, found 1, SKIP -}
{+ fi-cml-u2: igt@kms_atomic_transition@2x-modeset-transitions-* - skip - Should have at least 2 outputs, found 1, SKIP +}


  No new failures caught with the new filter


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.